Fibaro FGS-223 dual relay driver with children please

FGS-223 worked fine on my C4. Im now moving into my new C7. The device driver I used is a "Dual relay driver" because it produces 2 child devices I use in automation.
Now in the C7 this driver does not create children. Don't know why other than this driver is a few years old.
Anyway how can I creat som child devices for this device? Is there another driver working with the C7?
I have several of these I need a driver for producing children.
Anyone get this kind of stuff working?

I just received a Fibaro FGS-223 two days ago and joined it to my development C-7 with no problem. It created two children. What I didn't memorize was which driver was picked. I deleted it from the hub so that it could replace a different dual relay I thought had died. I went to Replace it but it wouldn't because it was acting as if it couldn't join. I ordered the Fibaro, it arrived, I tested it on the development hub then got ready to swap it. I tried Replace one more time and it worked first try. The FGS-223 is back in it's box as a spare.

I can try joining it again to my C-7 and see what driver is auto selected.

This EXEC device does reside as a child device leftover from the C4 device. In Device details, clicking parent device it opens a window which says " Device 6672 does not exist on this hub.

It was most likely deleted at some point. Please update your links."

Do you know how to update a link? I have no clue.

I did re include the FGS 223 again to the C7. Of course the ID has changed to 0B now. It was 08 in nice order as I started including devices from old to new. I only did one before (07) that went fine.

Now I have the FGS 223 back in but still no way to remove this EXEC child.
I would like to know what driver gave you the child devices. I won't touch it until I know what driver works.

Any idea about "updating links" would be appreciated.

Set the FGS-223 to use the "Device" type. You will then have buttons to delete child devices, etc.

Once you are done with that, look at:

And install the EricM version of the driver and child. (Two driver adds.)


Apparently I've had those drivers on my development hub for a while and they got selected. Swap that Device driver for the new one and click Save Preferences. Two child devices (that work) are created.

Oh my! The nightly heal wiped that device off the map for me. No worries.

I just finished my C4 to C7 migration and things went troublefree. I'm now waiting a few days for the C7 to settle down and do it's thing, but it all looks good and most everything is working. Putting my C4 out to pasture.

Thanks for the help.