New starter - help needed on Fibaro and Wall Switches

@jaedgar - glad you got it working!

I on the other hand am obviously still doing something dumb.

I removed the existing S1 & S2 child devices that I (somehow) managed to get displayed, but which were showing Inactive per previous screenshot.

I installed the 222 driver from @bobbles for the Fibaro 223 device

...and have loaded the Virtual Device Sync code as an app. However when I run the Virtual Device Sync, to create the child devices I get an error. I select the 223 device (with 222 driver) and it correctly identifies that there are 2 endpoints...

...but when I hit next, I get the following error:

You mentioned Simulated Switch device handler.....what is that? I'm clearly missing a step somewhere but can't figure it out.

I previously had used the "Metering Switch Child Device" driver code, but can't for the life of me figure out how they all fit together.

Can you go step by step what you did to get this working?


See post 4.

Hi Chris

Yes mate, so overall I needed the 222 driver, metered service, the virtual app and simulated switch.

Simulated switch from the same driverbase on GitHub, don’t have a link to hand as away at the moment but from the same as the 222/223 and Metered Child.

With ALL those installed:

222 - then configure.
Then in the virtual app you can create the switches.

You had the same error I did before installing the simulated switch driver. So grab that and I think it’ll work for you.

@bobbles - doesn’t seem to work in rule machine making on/off dependant on Sunset / Sunrise - going to look in detail but wanted to check you had working and wasn’t a known bug

If you can’t find the code I’ll link it when I’m back on Sunday

Eureka - that did it :+1:

In reading through the instructions I'd picked up on the need for 3 items (driver, virtual switch, metering), but had not realised the simulated switch was a 4th piece of the puzzle. I now have the Fibaro working correctly, with Ruler Machine able to control lights attached.

Thanks both for the pointers!


1 Like

Hey! I'm using the "FGS-222 method" outlined above for my FGS-223. It mostly works fine, but sometimes it's as if the virtual devices goes to "sleep". They don't react to commands anymore, until I do something with the "real" parent device - turn off, on etc. Then the virtual ones works again, for a while.

Hard to explain, but TL;DR I find it a bit unreliable. Is anyone else experiencing the same thing? Any luck getting the "real" FGS-223 driver (Fibaro FGS-223) going? I tried that one as well, but couldn't get it to work.

Hi everyone

I have a number of these Fibaro FGS-223 here and after an initial migration from STT I have been using the Dual Relay Driver to get each endpoint operational. However I then loose power & physical/digital capabilities. I see you have been having some success with the FGS-222 driver with a virtual app to create the child switches and then metering.

Having read this thread twice I am still confused as to how to get these switches working with more functionality?

Also shout out for @ericm as he sent me a link to his HE-ported device drivers from the STT platform.

Can anyone write a defacto guide to getting these FGS-223 switches working on HE please?
I changed the parent device type to @ericm 's driver and created the children but then the endpoints didnt work. Do I need something else?

Do you have the custom DTH from ST that you were using for the double switch 2? If so, you could port it yourself using the single switch 2 driver as a template. If you have the DTH for the 213 (ss2) then you'd really have something easy. You'd just have to compare the driver to the DTH and then make the same changes on the DS2.

I just PMd you, but Hubitat has a different method of crc16 decoding. So check this newer version of the driver:


I have got this working to some extent, but I am having some difficulties which have manifested themselves when I have added the switches to the Dashboard.

Device 1 appears to work (mostly) fine on both the Devices Page and the Dashboard; I say mostly, as at times I have to refresh to update the Devices Page.

However, Device 2 does not update properly. When I control the device via Devices the circuit responds to both on and off clicks, but the Current State does not update. I suspect that this is leading to problems in the Dashboard, as when I Click the tile, the light switches circuit switches on, but I get the "egg-timer" which effectively renders the tile inoperable.

Does anyone else have this problem, or does anyone have a solution?

Welcome jon
you might have to consider a manual refresh outlined somewhere here.
From my memory this is relevant for FGS-222's I believe
Habe a look around as there are articles here about some switches having o be manually refreshed


Thanks for the reply, I suspect I may have found a problem here with how this driver operates (or I am doing something wrong). I now have two of these switches connected and have managed to get a repeatable problem on both devices. Not sure if this is how it was designed to work, @ericm can you advise?

The problem (lack of status change) occurs when I operate the second of the devices (ep2) first, the status doesn't change, it only changes when I the operate the first device (ep1), when the SwitchBinaryReport reports back the value of both devices, followed by the MeterReport running.

Here is the log showing what happens:

Although the devices were operated close together, if I operate ep2 only, the status does not update at all.

Can you try hitting the "configure" button a couple times and try again?

1 Like


Thanks that worked, both circuits now functioning correctly.



@ericm just notice this poping up in the logs

SQL = database issue I'm afraid.
I'd do a backup then a reboot and see if it solves the problem.
Failing that do a backup, soft reset then restore.
Good luck.

did a soft yesterday!!

Oh dear.
Not sure what else to suggest then.
It always seems to work for me.

ive passed it over to @bobbyD , im having issues for awhile now so see what he says

and 200 is meter report, came through with no error