Error 500: A Server error has occurred

Get this error trying to open the device list. Everything else loads from the web interface. Rebooting did not resolve.

Issue started after deleting and recreating component devices.

See code below. recreateChildDevices() was called. I did this a few times before while testing without issue.

def recreateChildDevices(){

def createChildren(){
    state.lastRunningSpeed = 1

def createFanChild() {
	state.oldLabel = device.label  	//save the label for reference if it ever changes
	for(i in 1..6) {
    	def childDevice = getChildDevices()?.find { == i}
        if (!childDevice && i != 5) {
   "Creating Fan Child [${getFanName()[i]}]"
        	childDevice = addChildDevice("stephack", "KOF Zigbee Fan Speed Child", "${device.deviceNetworkId}-${i}",[name: "${device.displayName} ${getFanName()[i]}", isComponent: true, componentLabel:i])
       	else if (childDevice) { "Fan Child [${getFanName()[i]}] already exists"

def createLightChild() {
    def childDevice = getChildDevices()?.find { == "Light"}
    if (!childDevice) { "Creating Light Child"
		childDevice = addChildDevice("stephack", "KOF Zigbee Fan Light Child", "${device.deviceNetworkId}-Light",[name: "${device.displayName} Light", isComponent: true, componentLabel: "Light"])
	else { "Light Child already exists"

def deleteChildren() { "Deleting children"
	def children = getChildDevices()
    children.each {child->

We're looking into it.

fyi, componentLabel is not supported in Hubitat. you can change that to "label:" and it will assign that label to the child device. the find closure above that also needs to be modified.

I realized this after the first time I created the children, but it still saved the info to the data field in each child device. In ST, I used "data:[speedVal]" to save this value. I decided to use componentLabel since it was already referenced in my ST code.

Btw, this has been working fine for the past 3 days without issue. Could it be that the dleteing and recreating of the devices happened too quickly and corrupted something?

No, I was able to recreate the problem. It's because the child devices you created do not have a label. We are working on a fix for it.

Ahhh...I forgot that I changed that as well last night. I initially had the name and label the same and thought that by not defining the label it would default to the driver name.

It should, but that was the bug in the device display list.

Latest Hotfix resolved. Thank you Hubitat team for your lightning quick response (as usual).

1 Like

I have this with Currently running version:
Added a z-wave device and did not name it, then removed it....

I am having this issue as well.
Can't reach any devices. Was trying to troubleshoot some Motion Lighting issues, and discovered that I can load any Devices from the list. Looks like I dropped a few devices on 6/2/19.

Hubitat is painfully slow to respond, too.

I have several devices I cannot delete, that give me the same error. Did anyone figure this out?

Having the same error 500 on my C7... great... Already had to give up using this hub because it was completely unreliable (long story short: zwave would simply not accept devices, create ghosts, lock and the only answer from customer service is: "you suck at managing your hub"... I have 4 hubs... all work but the C7...) and now... that... Error 500.

This is from 2018, I am not quite sure it is the exact same thing. This was a specific driver for the Hampton Bay Fan Controller causing this issue if I am reading the thread correctly. Is this the device that caused this code? What were you doing when you got this?

A little off topic, can I ask you a question though? Why do you think are you having all these weird errors, and troubles with your hubs, and nobody else seems to be having the issues you do? It just seems very odd to me that you are having such troubles. Could it be a certain device you have? Is there something (app or device) crashing your hub somehow? Interference from a device like a portable landline phone or baby monitor? UFOs? :flying_saucer: Bigfoot? :hear_no_evil:

I just cannot believe there is a major problem with the firmware or software otherwise the forums would be completely filled with similar complaints to yours. And there aren't many (or any) other than what you are experiencing.

I don't mean any of this as criticism of anything you have done or said here. But it really boggles my mind that you are struggling so much with this. Did support give you any suggestions or look into why you are having such a difficult time with things?

Maybe it would be best to start a new thread outlining all the issues you are having in one spot. People are going to have a hard time helping you to diagnose with things spread all over the forums.

1 Like

Probably Bigfoot...

First, I like to look for people having had similar issues before contacting support. That's what they ask to do. That's also what their ambassadors ask to do. So I do it. The topic says "Error 500: A server error has occured". So I read a couple extracts and figured I'd testify to a resembling matter. Now, these policies are a no win: If I contact the support, I'm told to read the threads, if I speak in the threads, I'm told that I'm off topic when the title is THE EXACT ERROR MESSAGE I'M HAVING... Off topic??? No, sorry, that's not off topic.

Also, the forums ARE filled with people complaining about C7 instability (just type z-wave hell C7). It is crazy unstable for some of us. At this point, I cannot believe this is just a device issue. I have tried many things over the past 10 days. Just associating 1 first zwave device after full reset was already filled with problems such as not only generating a ghost device if the device is a bit too far from the hub, but also having to take the time for a cold reboot to get rid of this ghost device, which would not always work on the first attempt (getting thos ridiculous SDK statuses such as "the device is failed but, you know what, we are going to consider that it is not so we won't delete it you bastard" (that's at least the way I started to receive those messages at some point :smiley: ). And this happened almost every other device I would associate... And that's really not all. Then, after only 5 or 6 devices, bam! Locked zwave 2 minutes after reboot. Then reset (zwave reset), associate entirely different devices, only zwave plus devices, able to make a couple work for a while then... bam! All nodes dead with no chance of recuperation. Serioulsy?

Now, I have decided to migrate what I intended for this hub back to one of my C5's. No choice, had to finish with this crap, no more time to spend days on it. It all worked immediately, except for one brand new GE wall dimmer that seemed to block the entire network... Took me a little while to figure that one out but, at least, there was a CAUSE that I could find.

When I was attempting to use the C7's new Zwave chip (that is, from 10 days ago until yesterday), I did not own this new GE Zwplus wall dimmer yet, so that could not have been the issue. But, again, I had issues after installing any device on the C7... Zplus devices are generally ok, even if they can make you go through the ghost hassle, they generally pair fine with the C7... But non-plus devices, OMG! It's crazy insane and unstable.

I think I'm having a serious hardware issue on this hub, period. 10 days trying device after device, letting the hub rest, doing everything the doc says, starting over... It never worked. I had hubs for the past 10 years... Never seen such a mess, except with Smartthings, but that was mostly cloud issues.

Again: I have several hubs, 1 C4, 2C5, 1C7. C4 is now decomissioned but it worked well. C5's are working, I have like 60 Z-wave devices on one of them, no problem and, when there's a problem, there's a cause I can find, disabling apps and/or devices and infer the one causing the problem. On the C7, what I OBSERVED was that any device was a fair candidate because the hub's behavior was simply erratic.

Now it just crashed with error 500. WTH?

Just a couple examples of people struggling with C7...

I have given up on trying to get help. I now just want the staff to realize how angry some of us are: 150$ for a hub that simply doesn't work and no knowledgeable answer from the staff. Instead, ambassadors accusing user errors... Well, guess what, that's not how it works in CRM. User errors count for 90% of the problems, doesn't mean any user having issues can't be facing real issues with the expensive piece of hardware.

You don't understand. It IS good to try and get help on this forum. But this specific error was referencing a very specific driver and this very specific issue was fixed in 2018. There might be some relation here, but if you weren't working with the fan controller, I doubt it is the same error.

That is why I was questioning what you were doing when you encountered it so someone could try to duplicate it, or give some steps to try and fix it. And I still don't see what led you to have this error? Which device, what steps, etc.

And again I (nor have I seen anyone) am not blaming you for what is going on. I said that above. I am just trying to see if there is some pattern that is happening that someone recognizes.

We are just trying to help with what information you are giving us. We can't see what you are seeing, nor can we see the steps that led you to these problems. And I apologize if you think our advice isn't helping. I guess I won't try to help any more if you feel this is bad advice, or if you are thinking I am blaming you for this.


thanks, I know, I get it... just exhausted by days of struggle. Lol. I have described my issue in some other threads. Did everything I could. This C7 hub that I have will simply not work reliably, even with as little as 5 devices less than 10 feet away each, or as many as 60 devices in an NYC 3 bed apartment... (NYC means: small apt., like really small compared to other cities).

Update: @bobbyD: ALL pages were giving me the error 500, so no logs to access or show. Only reset solved the problem, as usual with this dysfunctional C7 hub. I looked for error 500 and what I read is that this was an old problem. Instead, you'd rather make me look for an idiot while this was again an issue you chose to ignore instead of investigating further. Not a 404 webpage error, ALL PAGES were giving me this message, all menus.

While the text of the error message remained the same over the years, its meaning has changed significantly. In the past, there was a period when we didn't know what was causing this particular error. That has changed since 2018, when this thread was created. We have also added logs so that users can track this error, better, since then.

So if you screen your logs, you could probably learn why you are seeing this error. Error 500 simply means that the page you are trying to access is no longer there. If you removed a device or an app, and trying to access the same page, you will get that error. Please screen your logs (past logs) and if you cannot figure out, send us an email at, with a screenshot of the error that includes your browser's address bar.