[DRIVER] Zooz ZEN Switches Advanced (and Dimmers)

@jtp10181 you don't happen to have a Zen32 driver do you?? Trying to automate the LED colors for the buttons but having a difficult time without the LEDs being treated as their own entries.

Since there was already a good community driver I actually assisted with adding that functionality to this one: [RELEASE] Zooz ZEN32 Scene Controller (community driver) . You can set the LED colors and flashing from a custom commend.

I also made a few custom tweaks to that driver on a forked repo: https://github.com/jtp10181/Hubitat-RMoRobert/blob/master/drivers/zooz/zooz-zen32-scene-ctlr.groovy

Thanks, I have that installed, I think my set-up is the hedache or at least I cant seem to figure out how to send the command from Home Assistant to Hubitat. I'm going to give it a try using Node-Red instead and connect directly to Hubitat and see if I can figure out sending the command from there.

I know it works from Rule Machine, if you want to make a new thread about or post on that driver you can tag me I will look. I have never tried sending a custom command from HA or NR though.

I think I actually found the solution, there is a hubitat.send_command service in HA that I never realized, I tried sending commands and I'm seeing good log data in hubitat, just need to physically check when I'm home if the LEDs are changing.

1 Like

Configure command causing ZEN22 dimmers to become uknown

My ZEN22 FW 4.04 dimmers are becoming unrecognizable [edit out: when I enable parameter 13 for scene control]. The device model becomes unknown (deviceModel: UNK00) and the advanced parameter section disappears.

State Variables

  • deviceType : 45330
  • resyncAll : false
  • configVals : [1:0, 2:0, 3:0, 4:60, 5:0, 6:60, 10:1, 11:99, 12:0, 13:0, 14:0, 15:1, 18:0, 21:0, 22:20]
  • group1Assoc : true
  • deviceId : 7964
  • WARNING : Unsupported Device Model - USE AT YOUR OWN RISK!
  • manufacturer : 634
  • lastCheckInDate : 09/11/2023 01:28:45 PM
  • inClusters : 0x5E,0x26,0x70,0x85,0x8E,0x59,0x55,0x86,0x72,0x5A,0x73,0x5B,0x9F,0x6C,0x7A
  • lastCheckInTime : 1694460525251
  • deviceModel : UNK00
  • firmwareVersion : 4.04

This is a second dimmer in a row that this has happened to today. I had to factory reset and re-pair the first one which was successful. I've power cycled the switch. I've restarted C8. I've tried generic dimmer. I've tried Configure and Refresh Parameters. Nothing seems to get the driver to recognize the ZEN22 again. What's odd is that I did this to another ZEN22 a couple of days ago and didn't have the problem.

I didn't do anything exotic, just Enabled Scene Control Events under Preferences, then Save Preferences, then Configure.

Whoops!! I just did a simple Configure on another ZEN22 (without parameter change) and the dimmer became unrecognizable:

State Variables

  • resyncAll : false
  • lastCheckInDate : 09/11/2023 01:42:18 PM
  • lastCheckInTime : 1694461338059
  • deviceModel : UNK00
  • group1Assoc : true
  • WARNING : Unsupported Device Model - USE AT YOUR OWN RISK!

Any ideas for resolving this problem? Thanks.

Edit: Devices remain responsive to Z-wave commands. No change with Refresh and Repair in Z-wave details.

If the device is not responding it likely has nothing to do with this issue you have encountered.

Looks like you used Swap Apps on the device? A lot of that info you are showing in the States is supposed to be in the data at the bottom. Example below.

When you use Swap Apps it copies that to states and then is supposed to clean it all up and put it back where it belongs. Has been a rare bug in Swap Apps since it came out.

My driver uses some of that data to detect that you have a supported device, so if its not there all the settings get hidden but other the driver would continue to work as normal despite the warnings.

I will make another thread to discuss this issue since it is not really related to this driver.

I’m having trouble with my ZEN30 800LR v4.10. When I add the device using this driver, configure, create child device, turning the relay on and off using the child device doesn’t function. The parent device turns on the dimmer just fine. But I really need to turn the relay on and off. Ive rebooted.

One note is that I’ve added the device with security.

Any ideas?

You are in luck because Zooz just alerted me of this yesterday, and I just finished what I think will fix it. You will need to run the "Configure" command after updating to this driver, so that it will detect the new endpoint setup on the v4 model.

Code: ZEN30 800LR v4 test code · GitHub Included in 2.0 Release
Use the "Raw" link on that page, then that URL can be used to import into the code editor in Hubitat.

If it is still having issues please enable debug logging and get some log screenshots for me. I also have one of the v4 models on the way to me so I can fully test it once I have one.

UPDATE 11-20-2023: Updated code linked above to include new settings for ZEN30 800LR model. Now going to work on getting all 3 drivers updated for a 2.0 driver release.

1 Like

IT WORKED!! Man, what great timing! Thanks so much!

1 Like

Hey @jtp10181 I've had the following scenario happen quite a bit recently

What actually happened is the light was already on and when motion was detected, the switch (Zen26) turned the light off. After 2 minutes, the light stayed off. I've been having this problem for a few months actually, but it's usually just a one off thing and I keep forgetting to check the logs. Today though my wife said it has been doing it all morning and seems to continue doing it so I finally got the logs.

I waited a bit and went into the laundry room again. The light was still off. It turned on as expected. I waited the elapsed time and the light didn't turn off.

When I look at the device and go to Events, I see an event from RL that seems to be a command to turn off. Then I see an event from the switch that says the switch turned off. What I don't know is if that is the switch telling the hub "Hey I turned off" of if it's your driver reporting "Hey I told the switch to turn off."


I tested it several more times and it seems to be alternating between these 2 states. So the light is on and it turns off with motion. The device page will report the light state as off and then change to on. So the opposite of reality. I don't quite understand though because if the light is on, if an on command is sent shouldn't nothing happen?

The second state is the light is off and activating it works normally. The device page says the light is off. It changes to on when activated. When the time is up, the device page changes the state to off, but the light doesn't actually turn off.

The driver only changes the state based on a confirmed response from the device. So the device is telling the hub that it turned off. The "command-off" is the off command being called, where the driver tells the device to turn off, and the "off" event is when the device responds that it is off.

If you want to edit the driver code and enable trace logging at the very bottom and reproduce it again you can see the full message the device is sending back (which I will understand).

Sounds like maybe the device is having a melt down. Have you tried power cycling it?

Here is the scenario where the light was on and motion turns it off instead of on.

I was going to post the opposite scenario where the light is off, turns on as it should, but then doesn't turn off after but the log is identical.

Have you tried power cycling it?

Not yet. I wanted to gather some logs and troubleshoot first. It's annoying that the on/off switches don't have an air gap you can pull like the dimmers do.

That confirms the the device is sending a response that it is off, the SwitchBinary(0) is from the device and is supposed to mean it is off.

Power cycling had no effect on the behavior. I noticed if I open the device page, the on command acts like a toggle and the off command doesn't seem to work at all. Now that I think about it, I think it started acting up about the same time as the zen30 I posted about here Pretty sure my switch needs replacing. Any troubleshooting steps I should try that I have not thought of?

So I'm wondering if I had a surge or something that damaged them. Both devices are among the very first I ordered when starting though, so I'm wondering what this means for the longevity of my switches, which are all Zooz.

If they are less than 5 years old and you registered them (which not sure what that entails even) then the warranty ids supposed to be 5 years. Might be worth putting in a claim.

Is the ZEN30 800LR fix already included in your HPM package? I saw you make a comment to that effect but I'm not sure if you already did it.

Not yet, I am working on finishing up all my updates right now so hopefully by the end of the day. Brining all 3 drivers in this pack up to date with all my other improvements from other drivers.


OK, if you expect to merge that soon I might just wait for HPM version because its easier to maintain than manually installing a custom driver.... I bet it will fix my issue.... they update the official one I could optionally change back... or just keep using yours if it has advanced features anyway.

You can always do a GitHub install and then later just do a Match-Up in HPM to "sync" it.

1 Like