[BUG] Swap Apps does not always properly copy device data

@gopher.ny I have brought this up a few times and here it is again.

See this post and my reply directly below it:

@kkl - Please reply here as to what Hub and Firmware version you have. In the off chance you have a very old firmware this bug was possibly already fixed.

As for a solution to your issue, if the device is not responding there might be something else messed up behind the scenes from Swap Apps or something else you have done. I would do this to resolve:

  • If you want to preserve your apps linked to the device, Create a virtual switch, then swap apps to the virtual device.
  • Exclude the real device, make sure device entry and zwave node are removed.
  • Include device again as a new device.
  • DO NOT Use swap apps again on it.
  • Go into your virtual device and look at the In Use By section, open each app from there and manually switch it to the new working device.
  • Once done remove the virtual device.

Thanks very much for your reply. All of the devices are still responding to Z-wave commands but your custom Z-wave driver no longer recognizes the model. I probably did use Swap Apps on some of them as they lost their Z-wave pairing when the FW was updated. They are all FW 4.04 which is the latest for ZEN22. Hub is C8 with This was all done over a week ago so I'm not sure what's different about today.

I still have several ZEN22 switches that I haven't touched today and are recognized properly. Can I provide any more info from those or the ones that are affected? Thanks.

1 Like

Here's one that I thought was working OK after parameter change but I see now that there's a discrepancy on the device page.

State Variables

  • resyncAll : false
  • lastCheckInDate : 09/11/2023 01:55:47 PM
  • lastCheckInTime : 1694462147650
  • deviceModel : ZEN22
  • group1Assoc : true
  • lastSequenceNumber : 28

shows ZEN22 but DATA below doesn't:

  • configVals: [1:0, 2:0, 3:0, 4:60, 5:0, 6:60, 7:15, 8:2, 9:1, 10:1, 11:99, 12:0, 13:1, 14:0, 15:1, 16:5, 17:1, 18:0, 19:0, 20:0, 21:0, 22:20, 23:0, 24:0]
  • deviceModel: UNK00
  • firmwareVersion: 4.04
  • zwNodeInfo: D3 9C 00 04 11 01 5E 26 70 85 5C 8E 59 55 86 72 5A 73 5B 9F 6C 7A 68 23

Here's one that I haven't done anything on which doesn't show much under DATA

State Variables

  • deviceType : 45330
  • lastCheckInDate : 09/11/2023 12:23:21 PM
  • configVals : [1:0, 2:0, 3:0, 4:60, 5:0, 6:60, 8:2, 9:1, 10:1, 11:99, 12:0, 13:0, 14:0, 15:1, 16:4, 17:0, 18:0, 19:0, 20:0, 21:0, 22:20, 23:0, 24:0]
  • inClusters : 0x5E,0x26,0x70,0x85,0x8E,0x59,0x55,0x86,0x72,0x5A,0x73,0x5B,0x9F,0x6C,0x7A
  • zwNodeInfo : D3 9C 00 04 11 01 5E 26 70 85 5C 8E 59 55 86 72 5A 73 5B 9F 6C 7A 68 23
  • lastCheckInTime : 1694456601948
  • deviceModel : ZEN22
  • firmwareVersion : 4.04
  • deviceId : 7964
  • manufacturer : 634

Data * zwNodeInfo: D3 9C 00 04 11 01 5E 26 70 85 5C 8E 59 55 86 72 5A 73 5B 9F 6C 7A 68 23

Since the devices are working still, if you want to repair the data there are a few things you can do.

This app: [RELEASE] Z-Wave Universal Device Scanner
You can use Get Info to request some of the data from the device and then it will save it back where it belongs.

This app can be used to add or edit the device data: [RELEASE] Custom Device Note App
It designed to add notes but you can actually add or edit any data field.
The important ones the driver needs are deviceType, deviceId, manufacturer
Also worth fixing is the inClusters

Once you get the Data sorted out, I would switch the driver to "Device" and use the Clear States command button to wipe out all the extra junk in the states. Does not hurt anything but it would bother me. Then switch back to my driver.

Then you can run a configure and it should pick up the model and firmware again, showing the parameters.

1 Like

Thanks very much for these additional instructions. I have Z-Wave Universal Device Scanner installed in Drivers Code. I created a device called Universal Scanner but I don't know what to do with it. What parameters do I enter to link/scan an actual Z-wave device? Thanks

You don’t create a new device, you switch the existing device to that driver then switch back when done.

1 Like

Fantastic! I'll just list the exact steps I used in case it helps someone else:

  1. Change Type under Device Information to Z-wave Universal Scanner…Save Device

  2. Configure (syncStatus : Save Preferences to finish Configure)

  3. Save Preferences (syncStatus : Synced)

  4. Get Info (no observable change)

  5. NOT NECESSARY. Scan Parameters (scanStatus : Scanning (1))

  6. Sync From Device (syncStatus : About to Sync Settings from Device)

  7. Save Preferences (syncStatus : Synced)

  8. Change Type to Zooz ZEN Dimmer Advanced OR Zooz ZEN Switch Advanced… Save Device

  9. Configure (syncStatus : Synced)

  10. Refresh browser window. Device model should now be correct.

I really appreciate your help and expertise Jeff.

No Problem, the Parameter scan was not necessary, but no harm really. The Get Info is what fixed it, and if you refreshed the page after that you would see the needed data fields had loaded.

I attempted to also query the device for the cluster info so that could be restored from my scanner driver but I was never able to figure out how to get it from the device.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.