Can't get second user logged in to hubitat

Trying to get my wife's iOS app up and running, so we'll have it as her presence sensor.

  1. I went to Hubitat Portal and added her email as a user
  2. She got an email with a code, and tried to use it. iOS app crashes (every time)
  3. She made an account on her own with that same email
  4. She tried to log in (iOS app) and gets an overlay that says "Loading user data" then it just goes away (doesn't log in, no error message)
  5. if she opens portal.hubitat.com in a browser and tries to log in she gets the error "user is no confirmed"
  6. If she tries to register from portal.hubitat.com it says account already exists, go to login
  7. If she tries to login, see (5) above
  8. If she tries to use the "have a code?" option it says "code has been confirmed. please login"
  9. If she tries to login, see (5) above.

This is infuriating.

I just used my account as the login for my wife's phone and it shows up as a different presence device in Hubitat. No second login needed.

What you did sounds correct, at least it looks right to me when I try to walk through it. I don't have an Iphone though, so I can't quite duplicate your steps.

@bobbyD Can you help @jared.zimmerman?

1 Like

other than the crashing, I get roughly the same failure behavior at portal.hubitat.com and in the iOS app.

Thanks, I'll try that if we can't get this resolved.

Never heard back from support about this, so I just gave up and logged her phone into my account, and gave it a new name in the app. However it never showed up in Hubitat as a new presence device. Is there something else I need to do, like create a virtual device for it?

Send a Geo Event from it.

tried that, no new device in the device list.

Have you tried installing the beta version of the app on her phone with testflight?

1 Like

yes, still doesn't work

Did you try what @bravenel suggested:

Following these new instructions, Yes, I was able to login with my primary hub login (this was never an issue)

  • I think (based on timestamp) that a new app device was created
  • The Instance name in the app does not match the device name in hubitat
  • The state is incorrect (shows 'not present' even though app says 'inside of geofence')

Yes I've tried restarting the app
Yes, I've tried sending a new geo-event
Yes, the app is the most up-to-date via testflight

I tried sending a push notification to the app and it didn't arrive
yes, location and push notification permissions are enabled for the app

looks like after leaving the house, and coming back it did register as present. Push notifications still aren't being triggered however.

Pull up the phone in devices and under "Device Notification" try sending a test message. (After typing the text, click the device notification button)


Let us know if it comes through.

1 Like

That’s what I was doing. They don’t.

If you look under events in the device is it showing the test?

Yes

DM some things to try.

Checked the obvious?

1 Like

I setup and verified all worked fine on my Son's iPad this morning on iOS 13.2.1, I then logged out and removed the mobile device. Upgraded the ipad to iOS 13.5.1 logged in and created a new mobile device. I am now unable to receive a notification. Tagging @bobbyd as this appears to be a bug.

Also my notifications settings are identical to the image posted by @SmartHomePrimer above.

2 Likes

Download the Hubitat app