August Pro Z-Wave issue

Finally got my C7 Hub and moved all my things from SmartThings.

It is good that Hubitat support WebCore, so I can easily copy all the pistons from SmartThings easily.

However, one thing that has been painful is the August Pro Z-Wave.

It is easy to pair, and use the "August Pro Z-Wave Lock" Device Handler.
However, I'm not able to control the lock with it (no response when clicking Lock/Unlock/Refresh)
But when I Lock/Unlock manually or through August App, the status is correctly reflected in Hubitat.
(Battery shows 100%, but August shows 87%)

When I switch the device Handler to "Generic Z-Wave Lock". I'm able to control the lock.
But sometimes it fails (probably due to the firmware, so I asked to rollback my Lock firmware to 1.8.15).

Any way I can get it working with "August Pro Z-Wave Lock" device handler?
@mike.maxwell

Thanks

can you post a screen shot of the very bottom of the driver details, specifically the data section?

  • deviceType: 1
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x55,0x98,0x9F
  • zwNodeInfo: 53 DC 84 04 40 03 5E 55 98 9F 68 23 F1 00 86 72 5A 73 80 62 85 5C 71 8E 59 6C 7A
  • secureInClusters: 0x86,0x72,0x5A,0x73,0x80,0x62,0x85,0x71,0x8E,0x59,0x6C,0x7A
  • deviceId: 1
  • S2: 132
  • manufacturer: 831
1 Like

That driver didn't get updated for S2 security, we will get this updated in the next release (2.2.3), in the mean time continue to use the generic driver.

Can did this get updated? I hadn't seen it in the readme of 2.2.3 release notes.

It is working now

Bug Fixes
August Pro Lock: Added C7/S2 support.

?

Thanks!

I am facing the same problem here, but I have a C5 hub and everything was working fine until two days ago. Now I can see in the events' page all open/close (manual or via august app) but I am not able to control the lock via HE. I tried to change the device Handler to "Generic Z-Wave Lock" but it still not work. @mike.maxwell, could you please help me find a solution for this? Thanks

so what's changed in the last two days?, did you update the lock firmware through the august app?

1 Like

Not consciously, but I think it is possible that the lock did it automatically. I tried to find this information in the app but I couldn't.

My August Pro gets added as "keyWe Z-Wave lock" and is not working with any of the device drivers - keyWe Z-Wave Driver, Or Generic Driver or the August Pro driver. I don't see any activities in any of the logs (Lock events or system logs) irrespective of what driver or button I choose. Works just fine from the August's Native app. I have tried including/excluding a few times w/o any luck.

In the device setting the scheduled job section has some funky schedule, not sure if that is somehow related here.

the lock didn't include properly
When it is included correctly the driver data section should look like this:


You will need to exclude and factory reset the lock, then include it again.

The scheduled job runs a refresh every 18 hours, mostly to fetch the battery level.

Followed steps, including resetting August to factory settings and eventually re-added it to HE but no change in the behavior - it was added as back Keywe Lock and still not taking any commands.

There's something wrong with the lock (probably the firmware), if you have access to it via its mobile app I would contact their support and request that the firmware be downgraded, multiple users have had issues with the latest firmware version.

3 Likes

Is this still current?

I'm a brand new HE7 owner and trying to set up my first device. Anyone have any experience downgrading the firmware on their locks - what did you ask them to downgrade to?

I am running the most recent firmware on my locks and have had very little problems with the latest 2.2.3 hub firmware on the C7.

Several people have reported problems getting them included, but I didn't have any difficulty.
Here is a recent message I sent on a related thread with my notes from the zwave inclusion process:

Thanks for your message! I was encouraged to hear that it worked smoothly for you. I had a lot of difficulty getting paired, but it ultimately did work for me.

I was able to pair by unchecking the S0 box. I think that I originally tried this and it did not work, but it is working now! I did not get any errors from either the August app or the C7 dashboard by pairing this way, nor did I see any big lags.

One other item of note: The august app said that the locks needed a firmware update before using Z-wave, but as best as I can tell this update never installed.

My 3rd gen. August Pro looses its connection and is unable to be controlled from Hubitat. After using the August app to lock/unlock the device I can control it via Hubitat again.

Should I switch to the ‘Generic Z-Wave Lock’ driver or try something else?

If you have the connect, I would strongly consider using the wifi integration which has better stability compared to the z-wave in my experience:
[[Release] Alpha version of August Home (wifi door lock)]

Download the Hubitat app