Anyone using Sonoff S31 Lite Zigbee Smart Plugs?

I have to preface this with a disclaimer that while I've had my hubitat for a while, I still consider myself a newb at this. Here goes...

I picked up a couple of these on Amazon for a reasonable price, after briefly skimming this post.

I was able to discover them, but they show up as "Nue Zigbee Switch". Looking at them in device view, I can hear the relay click on and off in them when I turn them on and off, so I think I have basic functionality working...

Anyway - the point of my post - is anyone else using these, and if so, how did you do it, given that they're not supported?

The reason I bought them, was to create the start of a zigbee network so that I can create a network to connect to my Schlage Connect Smart Deadbolt, Zigbee Certified

It turns out my back door (where the lock is), is too far away from my hub to connect directly, so I was hoping to use a couple of these outlet switches to bridge the distance.

So far I have two of these recognized by my hubitat, but I haven't tried to discover the Schlage lock yet.

Has anyone else done anything similar with success? Are there any gotcha's that I should be watching out for?

Thanks for your help!

Wasn't aware that Itead had starting making the S31 in a zigbee variety. I knew they made the Sonoff basic in a zigbee version but this one is new to me. One thing to note however, you won't be able to flash Tasmota or anything to this device since it doesn't use the ESP8266, which is a Wifi chip, not a Zigbee chip.

I tried to look at the info on Itead's website as well as the Zigbee alliance and there is no listed there so it's not zigbee certified. I can't find whether this is a Zigbee end device or a router. If you go into your hub's zigbee router table, then you would be able to see if it was listed one way or the other. I'd be very interested to learn which it is.

I would recommend changing to the "Generic Zigbee Switch" driver. One thing you want to verify is that the switch attribute in the edit device page updates as you command the device on and off. If that works and the device is a repeater, then that's all you have to do. Putting it in proximity to other zigbee end devices will start to build up your mesh network.

Do you know if they have UL or CSA certication?

I was interested to purchase a couple of them but I was waiting to know if they are certified. I looked on their site and in the Amazon product description but no luck!

The ZBR3 was petty much just a R3 basic with the 8266 chip replaced with a CC2530 and works as a router so Itead probably did the same with this.

I'm happy to do this, but not sure how exactly.

It looks like its updating. I'm on the edit page, and clicking on the on or off buttons causes the current states status to switch, immediately. I switched one to the Generic Zigbee Switch driver, and it seems to work as well. Not sure what 'Flash' is on the generic driver...

I have all 3 switches discovered and working. I was also able to discover my Schlage Zigbee lock - but I'm using the Generic Zigbee Lock

I do not see a UL listing on the Itead website for this one but the S31 is UL listed and the only difference is the chip.

1 Like

Do we know how well it works as a repeater yet?

Mine works fine but admittedly I only have 1 temp/humidity sensor that goes through it because of it's location. I did manage to force some switches onto it when I first got it by moving it's location.

Also when I read on the HA forum (I think) when I bought it that it was even working with Xiaomi devices.

This goes into the devices a bit in depth and has it repeating for a hue bulb.

I have 2 of them. I did have to change the drivers to just generic zigbee switch and they work great

I also have five of them. My hub was slowing down significantly and I couldn’t figure out why. I came across a thread on here saying peanut plugs could be the culprit. I switched all of my peanut plugs out and it’s back to screaming fast. I switched all of the drivers to generic zigbee switch and they are all working great, and are just as easy as any zigbee plug to pair.

@erilaj It doesn't appear to have either certification. Good catch - had I noticed, I probably wouldn't have bought them. I'm using them only as repeaters at this point, so will likely continue to use them until I can find something at the same price point that is UL or CSA certified.

1 Like

Total Newb question here - but I can't even get my hub to find these plugs..... is there something I'm missing?

Hard to say without any more details.

Are you following the steps listed in the hub documentation?

Sorry - I later moved the plugs waaaaay closer to the HE and was able to detect them.... seems like a silly issue now that its resolved....

That said, now I have the devices found, and the switch status (on/off) is appearing through the HE interface; but I still have no ability to control the plug...the only way I can get it to turn it on or off is by physically pushing the button. This is my first 'generic' Zigbee device, so I'll have to figure out where to start troubleshooting it!

Which driver did the hub assign to the device when it paired? Since it’s not on the supported device list, it’s possible it’s not using the right driver.

Edit: In case it's not clear, you can check in the device settings page here

Interestingly, the Hub automatically assigned the device as a 'Generic Zigbee Switch' as those posts above suggested! I've tried 'Generic Zigbee Outlet' As well as a number of others and thus far nothing, unfortunately!

Probably won't find another generic driver more likely to work than either of those. Have you clicked "configure" on the device settings page before trying to use it? Have you left a browser tab open with live logs running while you use the device (both the physical button and the commands on the device's settings page in the hubitat UI)? Maybe turn "debug logging" on in the device settings page before taking a look at the live logs.

Trying to troubleshoot this with the logs now; but it might help if I had some clue what I'm looking for haha. Thus far I've been completely unable to get the plugs to do anything!

Just received my Sonoff S31 Lite zb from Aliexpress.
However, tried multiple times in device discovery, found the device but all got stuck at "Initializing".
Anyone knows what's the issue?

@mcdull Are you on the latest firmware? Shut down the hub from settings completely, once shutdown (red light turns on) pull the power and leave it off for 30 seconds or so. Plug it back in and once it boots, try pairing again.

If that solves it, great, if not, something else is up: