Sonoff zigbee switch

You are at the latest version of HE 2.2.0?

Yup, Now on

I have had an issue as well, but in my dev environment so have not narrowed it down. I downgraded to 2.1.9 and that was not enough, then I did a soft reset and restore, then it worked to pair new devices. Maybe a a soft reset and restore without downgrading would be enough?

Will try that. Maybe after one's had issues, a soft reset is needed after an upgrade (to or downgrade

1 Like

Looking forward to hearing how it goes :slight_smile:

No luck. Still stuck at Initializing

That is not good, I will try some more with my dev hub later when I have time, see if I can capture the packets with wireshark and maybe report more details. What solved it for me was a downgrade. Not a great solution though.

I shutdown my hub. Pulled the power at the back and plugged back in. Then I noticed my Hue bridge was on same zigbee channel (20) so I changed the channel of the Hue bridge.

Then tried to discover the hue dimmer switch and initialized very quickly this time. Not sure if it was the Hue or if it needed a reboot but working now. Thanks

1 Like

It was probably this, let us hope that is it.

Very slow getting around to this but I have my fourth zbr3 connected and working properly.

Pairing process went smoothly, it picked up adam’s driver automatically - I assume that because I had it paired before - and that was it.

1 Like

Does it show endpointId in the Data section of the device page? And what is your current HE firmware version?

HE version

Re: endpoint - yup


Then it IS back to basically normal in this revision. Yet there are reports of strange pairing behavior...

Working great for me @markus :slight_smile:

1 Like

Well I've removed my sonoff zigbee from my mesh as I've been having the odd random problem with my SmartThings contact sensors. I tried removing one of my other repeaters before this and it made no difference.

Once the sonoff zigbee was disconnected my SmartThings sensors are working again without having to re-pair. Interesting thing is my xiaomi sensors were fine even when in the same area as the SmartThings sensors that lost connection.

Touch early to be sure the sonoff zigbee was causing problems with my mesh, but everything is indicating that. I've now put a genie wifi power plug in its place and feel that device running tasmota is better anyway.

1 Like

Since they use a CC2530 chip without any amplifier the signal is not very strong, this can be problematic depending on the device that connect through it.

1 Like

Hi all,

Thanks for the useful info in this thread I was able to pair and use a Sonoff ZBMINI.

Work fine with @at9's handler and with the NUE Zigbee Switch handler (at9's is cleaner tho').


fingerprint model:"null", manufacturer:"null", profileId:"A1E0", endpointId:"F2", inClusters:"", outClusters:"0021"

and pairing results:

**Manufacturer:** SONOFF
**Product Name:**
**Model Number:** 01MINIZB
**deviceTypeId:** 419
manufacturer : SONOFF
idAsInt : 1
inClusters : 0000,0003,0004,0005,0006,1000
endpointId : 01
profileId : 0104
application :
outClusters : 1000
initialized : true
model : 01MINIZB
stage : 4
manufacturer :
idAsInt : 242
inClusters :
endpointId : F2
profileId : A1E0
application :
outClusters : 0021
initialized : true
model :
stage : 4

I used the generic zigbee switch and it works for me

A mi tambien me funciona, pero hay un problema.

Si manualmente toco ese interruptor, luego no ejecuta correctamente las rutinas. Es decir, para que me funcione adecuadamente tiene que estar el interruptor fisico en una posicion de cerrado.

Sabeis como puedo solucionarlo?