All devices under Z-Wave Details missing

I have had this happen 3 times now. Some background is I had some ghost devices I could not get rid of. I hadn't done much automation yet inside Hubitat so I decided to rebuild from my system from scratch. Removed everything and did full Z-Wave reset and reset on Hub. I then added most of my devices back in (around 40). I first noticed this happen a week or so later when trying to add in a device and it would not pair. I checked and found the list blank. I still see all the devices under the device section and automation still work. So shutting down the hub and powering off for a few minutes does fix this. However this is the third time it has happen now in a couple weeks. Restarting does not fix the issue. Only full shutdown and pulling power. Should I try doing a Z-wave repair.

1 Like

Z-Wave repair won't correct this. Can you post your Zwave Details, sounds like there still may be a device issue.


Tagging @support_team.

I’ve seen one other report of this issue. And I think in that case, a Soft Reset followed by database restore fixed it.


This is not normal, please send me a PM along with your hub's MAC address, I would like to further investigate.


The one time I've had this happen to me was immediately after the 7.17 upgrade, but IIRC there have been instances where a device caused a similar issue; in my instance a power down restart corrected it. Your devices look good, so I'm going to bow out and let HE Master Jedi @bobbyD do his magic. :sunglasses:


Still loosing the Z-wave details. What are the steps for a soft reset with database restore. Do you use the latest database backup?

I usually download a current backup right before doing this.


What @thebearmay said. Then use the one you downloaded to your pc to restore. That will ensure the database is clean.

1 Like

Did the restore last night and shutdown restart. Device came back, but when I checked again this morning everything gone. :confused:

I would recommend opening a warranty issue on

1 Like

I know this is a bit old, but I used the advice from this post to do soft reset followed by database restore, and it worked, but now my zwave is completely gone again so I’m going to have to do the same thing.

@bobbyD you had mentioned that this should not happen, so I’m curious if there is a solution to fix this z-wave problem once-and-for-all!

my current zwave details page, before and after doing a normal restart:


1 Like

Soft Reset is not very likely to bring a Z-Wave radio back online. When devices are not listed in Z-Wave Details table, power cycling the hub by shutting it down from Settings and unplugging it for 30 seconds when the led on the hub turns red may help. If the problem persists, you are likely dealing with a hardware malfunction and the hub will need to be replaced.

I'm experiencing a similar issue. None of my z-wave devices show up on the z-wave details page. They are all on the devices list.
Here's the sequence of events that occurred prior to the disappearance:
-update the hub to latest firmware ca 1 week ago.
-added new IKEA motion sensors (Trådfri & Vallhorn), updated firmware on those.
-started migrating zigbee bulbs & 1 dimmer switch from Philips Hue Bridge to Hubitat due to issues w/Hue Bridge
-paired new IKEA trådfri outlets & zigbee repeaters to support the zigbee bulbs.
-added automations for the bathroom with a motion sensor & 2 bulbs.

Yesterday evening the lights I have in the kitchen (on 2 Qubino mini dimmers) started flashing and doing weird things. I tried to do some troubleshooting, but it was late and I couldn't find an obvious answer. I decided to do a z-wave repair, started after 11pm.

When I woke up the repair was complete, but the z-wave details page was empty, and the z-wave dimmers in the kitchen were completely unresponsive. Another Fibaro 2 dimmer in an adjacent room was also unresponsive. Ie, the physical switches work, but none of these respond to commands from Hubitat. None of my other z-wave devices seem to be communicating with Hubitat, including 4 Aeotec multisensors & an Aeotec nano switch.

I don't see anything weird in the logs, but I'm no expert. I don't really know how to proceed or what to post to seek help.

I just finished wiping the database, restoring the hub to previous firmware & a backup from a week ago. I then updated firmware again to the latest. Unfortunately the devices are still not showing up under z-wave details. They're also not communicating with Hubitat.

Any ideas? What screenshots would help troubleshoot?

I have a C-5 Hub.

Edit: Before wiping the database, I shutdown the hub for ca 30 min, had it unplugged for ca 30-60 seconds before I plugged it in again.

Some screenshots

2x Logs from Hub Events

Easiest thing to try is a shutdown and unplug for about 30-45 seconds to force a reload of the ZWave radio database cache.

Do you have Hub Protect with scheduled cloud backups? There is a known issue being worked on right now that could cause zwave to crash during the cloud backup.

The suggestion of the power down and unplugging for 10+ seconds is the only way to bring it back.
A Soft Reset and local backup restore does not touch anything on the Z-wave radio, so that does not help.

yes, I did a shutdown and unplug before I wiped the database & restored. Forgot that in my sequence of events. But I shutdown. Left it for ca 30 min. unplugged for 30-60 sec. then plugged in again. Then when the z-wave details page was still empty I did the wipe & restore.

No, I don't have Hub Protect., but I did power down, unplug & restart as described.

You should submit a warranty claim. This honestly sounds like a Z-Wave radio failure. You could give them a link to your post here so you don't have to explain it again.

The only other thing that could explain this behavior is if you reset the z-wave radio, but that button was removed on the 2.3.7 firmware you are running so that seems highly unlikely.

Doing the power off and removing power for 10 seconds should always bring the radio back online as it was before, if it has just crashed.

One last thing I thought of, how is the hub being powered? The supplied block or PoE with a splitter? If you are using PoE, switch to a regular 1a power block. That issue however usually causes an issue 100% of the time, and would leave z-wave partially functional, not dead.