[2.2.7.125] Z-Wave Ghost Nodes

2.2.7.125 Got an update to the logging for failed node removal. If you have a ghost node that can't be removed can you please post the log from the removal here. It will look like:

Failed node XX remove status: X

Remember when trying to remove a ghost node only click remove, and if it is not showing as failed yet click refresh.

4 Likes

A somewhat related question......

What are the conditions that allow the REPLACE button to show up? I've seen where is shows FAILED without a Replace option and then some time later REPLACE shows up. I may not understand the implications, but feel like it would be nice to have the REPLACE option any time a node appears unresponsive.....or lt least a better understanding of why sometimes REPLACE is there and other times its not

The node has to be in the SDK's failed node list.. If the node is truly down and non responsive, clicking refresh (sometimes more than once) should make it be marked as failed if it does not respond..

What about a case like this.

Node is in table:

But, repair works fine, most of the time:
Screenshot 2021-05-12 163732

I have no idea what this device is. How do I get rid of it?

That node is alive.. Try clicking discover to see if it can match a driver..

I always thought that one needed to place the device in discovery mode for this to work…. If I understand this, it doesn’t need to?

I have a stubborn ghost node (device physically dead and pulled) that I can't seem to Remove.

Below is the log output from a Repair attempt, multiple Refresh cycles (have done this process a few times), and failure to ultimately Remove the node.

Node only ever says Pending even after identified as unreachable.

hub/logs#sys1)2021-05-12 03:56:50.095 pm Failed node 96 remove status: 0

hub/logs#sys1)2021-05-12 03:56:20.022 pm Z-Wave Network responded with Busy message.

hub/logs#sys1)2021-05-12 03:55:54.316 pm Z-Wave Network responded with Busy message.

hub/logs#sys1)2021-05-12 03:52:55.534 pm Finished Z-Wave Network Repair

hub/logs#sys1)2021-05-12 03:52:48.522 pm Z-Wave Node 96: Repair failed node unreachable

hub/logs#sys1)2021-05-12 03:52:36.288 pm Z-Wave Node 96: Repair is pinging the node

hub/logs#sys1)2021-05-12 03:52:36.276 pm Z-Wave Node 96: Repair starting

hub/logs#sys1)2021-05-12 03:52:11.049 pm Z-Wave Network responded with Busy message.

hub/logs#sys1)2021-05-12 03:52:11.044 pm Refreshing Node States

hub/logs#sys1)2021-05-12 03:52:11.037 pm Starting Z-Wave Network Repair

If it is a mains powered device and it is online like this one is, it should discover..

2 Likes

Do me a favor @rhinoroo.. Reboot and only click refresh if it does not have the remove button.. Repair is not your friend on dead nodes ..

You only want refresh and remove on ghost nodes..

Thank you @bcopeland that is good information to know on the Repair side.

Completed the reboot and did a Refresh (twice) and then attempted Remove.. still no joy.

Node still shows Pending with log output as below and same image as previously shown.

hub/logs#sys1)2021-05-12 04:22:52.641 pm Failed node 96 remove status: no reply

hub/logs#sys1)2021-05-12 04:22:42.617 pm Z-Wave Network responded with Busy message.

Nope, never does. BTW, this is on a C-7, 2.2.7.125

Summary

It did discover the device... and found there was no matching driver, so it picked the closest guess a driver named "Device". :smiley:

Aeon Labs device perhaps: Aeon Home Energy Meter (ZW095-A) ??

Ahh but it did.. It didn't find a matching fingerprint.. so it matched it to "Device"

Yup.. just matched up the manufacturer / deviceType / deviceId:
https://products.z-wavealliance.org/products/1289?selectedFrequencyId=2

Thanks, but this opens up another can of worms then. I do have that device but I have NEVER tried to pair it with this C7. I use to have it paired to my C3 but didn't have any need to connect it to the new C-7.

So why would it grab it? What if this would have been my neighbors device? Not good that it would randomly grab a device I didn't try to pair.

But problem solved on the node. I can now delete it. Thanks.

3 Likes

It would have to have been not in a network and sent a NIF (Node Information Frame) while you were in inclusion mode.

@bcopeland Just FYI this is what I was always getting as well when trying to remove ghosts on my C7 (network busy). Then it would basically bring the whole network to a halt if I kept trying and I would have to reboot. Once I got a USB stick I went in with that and two clicks and they were gone. Come to think of it the whole thing has been much more stable since I got rid of them.

Typically, I would do the same @jtp10181 and I’ve never had any problems removing them with a stick as you noted.

Let me know if you’d like me to proceed with additional troubleshooting @bcopeland otherwise I can take my usual path here..

1 Like

You can go ahead.. I have the information I need now.. Thanks

Is there a guide to the status values?

I got: Failed node 49 remove status: 1

Update: after reloading z-wave details it appears the device is gone now.

2 Likes

Download the Hubitat app