[2.2.7.125] Z-Wave Ghost Nodes

Sure:

2 Likes

I had tried removing this device a day or two ago and I got the dreaded "Z-Wave Network responded with Busy" message. So surprised it worked this time. :slight_smile:

2 Likes

My current ghost device issue was caused when removing a particular Zooz device. I have since reset this device. Is there any concern with me adding this specific device back into the network while there is still a ghost device for the same physical device? Or should I first wait until I am able to get rid of this ghost device?

I have ordered a UZB Stick and will receive it tomorrow. Would you prefer I wait a while to use the Stick to delete the ghost device? Or is it likely that troubleshooting and resolving this problem is going to take a while?

Sooo, bcopeland, what are you thinking???

I'm having issues removing a ghost node also. I'm seeing this in the logs after hitting remove:

sys:12021-05-16 17:47:56.893 Failed node 0F remove status: no reply
sys:12021-05-16 17:47:46.914 Z-Wave Network responded with Busy message.
sys:12021-05-16 17:47:16.868 Z-Wave Network responded with Busy message.

And sometimes:

sys:12021-05-16 17:48:36.411 Failed node 0F remove status: 2

The device has been reset manually. Will I need to remove power from the device? It's currently still wired into the light switch and I hope to be able to re-include it eventually.

This is likely the device responded and as such is still active in the mesh..

Thank you upfront for any help. @bcopeland

C7 running 2.2.7.126

clicked "refresh", takes about 5 seconds, page refreshes, shows this:

click "remove". takes about 15 seconds, page refreshes, still shows this:

Logs show this:

image

thoughts?

Every time I've seen that zwave busy message I've had to shutdown the hub from the menu and pull power for about 30 seconds to be able to remove ghosts. Pulling the power is the only way I know of actually shutting down the zwave radio. Just be sure to pull the power from the wall side since the connector to the hub is pretty delicate. Once it comes back up do the refresh thing and then remove.

4 Likes

I use a smart plug on another hub to kill power to the hub. Large home 200 plus devices. Had over time at least 20 ghosts. The smart plug saved a lot of time.

Do you make sure it is shut down before turning off the power? “Pulling” the power otherwise could cause DB corruption…

2 Likes

I hope you were not replying to me. UI Shutdown takes about 15 seconds so I wait 30 then I turn off the plug. Wait 60 seconds then turn the plug back on and wait about 3 minutes for the C-7's and the C-5's are back at in about 2 minutes. Not sure why the c-5's seem to boot faster.

2 Likes

I have tried this multiple times. I run the shutdown function, and then kill power to hub. wait 2 minutes. turn power on, immediately login to try again, and get same result. Network busy. Any other things to try? I dont own a windows PC, so not sure the zstick method is a good option, but that may be my only choice. I have three ghosts, and the network has been unreliable since they showed up.

Would wait for @bcopeland to see if he can fix the issue with removing these type of ghosts.

You could try flipping the breakers for everything except for the hub. That should cut down on the number of packets the radio is getting. I'd also do the safe shutdown and unplug again after you flip the breakers to make sure the radio isn't any locked up and then try to remove them.

If you have any zoom 4-1 sensors I'd pull the batteries on them also while you remove ghosts. they are super chatty and can hose up the radio.

You'll need a windows pc for the usb stick.

1 Like

Not quite true.

2 Likes

thank you for the suggestions.

Np, if you need more help just lemme know. I've helped a bunch of people squish ghosts. The VM route is also a good choice if you're up to it. Saves you from having to track down a windows pc but windows and mac are way different operating systems and can be confusing if you haven't used a windows pc before.

1 Like

i have 2 devices and have tried averything above fresh power cycles and everythins and i jsut tried again after the last update and i cannot get them to remove

sys:12021-05-20 17:11:34.527 Failed node 13 remove status: 2

sys:12021-05-20 17:10:49.870 Z-Wave Network responded with Busy message.

sys:12021-05-20 17:09:46.716 Finished Z-Wave Network Repair

sys:12021-05-20 17:09:39.658 Z-Wave Node 13: Repair failed node unreachable

sys:12021-05-20 17:09:27.436 Z-Wave Node 13: Repair is pinging the node

sys:12021-05-20 17:09:27.434 Z-Wave Node 13: Repair starting

dev:432021-05-20 17:09:20.764 infoWash Room Motion temperature is 71.19°F

sys:12021-05-20 17:09:14.953 Refreshing Node States

sys:12021-05-20 17:09:14.952 Starting Z-Wave Network Repair

sys:12021-05-20 17:08:40.722 Z-Wave Network responded with Busy message.

sys:12021-05-20 17:08:37.720 Z-Wave Network responded with Busy message.

sys:12021-05-20 17:08:27.010 Z-Wave Network responded with Busy message.

sys:12021-05-20 17:08:24.035 Z-Wave Network responded with Busy message.

FWIW. I tried turning all the electrical circuits off but the hub, removing batteries from few z-wave sensors, and still couldn't remove the ghosts, network busy error every time. I ordered a z-wave stick from amazon to got the silicon labs route. The only PC I owned was a work machine, that I can't install software on, everything else in my home is OSX. But I was able to get the labs software to work running a windows vm on parallels. Removed all the ghosts (I had 3). Hopefully this returns some stability to my network.

2 Likes

I ordered a Z-Wave stick as well. When it got here, I installed the software and then had to reboot the hub as it wasn't able to pair. When the hub came back and it paired I found my ghost had magically disappeared.

The network still isn't stable though. It's only stable after a hub reboot, then becomes unusable at some point. Suspect it's this latest firmware.

Should be able to roll back to the previous version to test if it was the firmware update.

Download the Hubitat app