- GE Smart Fan Control and Alexa

After upgraded my C-7 to, my Alexa and my fan are not getting along.
When I ask Alexa to turn ON or OFF the fan:

  • Fan response quickly and correctly
  • Alexa immediately says: "I'm not quit sure what went wrong" instead of her usual happy chime.

I've tried removing and re-adding the device in the HE-Alexa app which caused Alexa app to rediscover it. Also, nothing useful in the HE logs.

Not the end of the world, but Alexa is our main control path to our devices on HE.

Also have noticed after upgrading, may of the z-wave switches aren't as snappy as they use to be. I've done several z-wave repairs that go through clean, but they still seem sluggish.


Try opening the Alexa app on Hubitat's apps page and enabling "Respond immediately without waiting for device".

If they are all z-wave plus, they self heal and repair is not necessary. Other than that, I haven't had this issue, but have seen people suggest doing a shut down (from the "settings" tab) and then pulling the power for 30 seconds and then plugging it back in to see if it solves the problem.

I have the same issue exactly as described. The setting to respond immediately didn't make any difference.

1 Like

@Ken_Fraleigh - thanks for pointing out this feature! I tried it, but for my fan, alexa still says the same time. In the past when I've had a slow device, Alexa says something after a while like "device not responding" which is what I think that switch will help, but with the fan this issue is new and different. Almost like the driver is no longer compatible with Alexa.
I've been using the same switch/fan with Alexa for a really long time on my C-4 then upgraded to C-7 two weeks ago and it's been perfect. It was only after 2.2.3.

1 Like

@HAL9000 - glad it's not just me!

1 Like

Fan control was added to Alexa in this update. Maybe @bobbyD can help with this since it's obviously not unique to your setup.

I'm at least glad to know it's not Z-wave related ( I have enough concerns in that area)... rather a driver mismatch between HE and Alexa this fan device.

I have 3 of these switches, and 2 work fine, 1 sees this error. Haven't done any troubleshooting yet.

FWIW, the level and switch events are logged immediately, and Alexa's response is quite immediate as well .. no lag or timeout evident. Could be a driver issue, but as the lady said .. I'm not quite sure what went wrong.

1 Like

@bcopeland is aware of this fan issue.


Same problem with my Bond hub integration for HE

Same here oh zwave not plus GE fan controller.

Changing to immediate response removed the devices unresponsive message and now is not sure what went wrong.

Working but annoying, glad I found this and known issue.

I just updated to and the problem is still there. I'm guessing they've had their hands pretty busy with z-wave issue. Hopefully it will get fixed soon.

1 Like

Same here .. but in testing just now I found what could be a workaround.

Me: Alexa, set fan to 25%
Alexa: I’m not quite sure what went wrong.
Me: Alexa, set fan to low.
Alexa: OK
Me: Alexa, set fan to 75%
Alexa: I’m not quite sure what went wrong.
Me: Alexa, set fan to max.
Alexa: OK

Haven’t figured out a way to avoid back talk when turning off, though.

Confirmed it is not fixed in


I was just installing that, hoping it would be fixed. It is annoying, although less so than if it did not work at all, I guess.

Same problem with Leviton Vizia fan controller as well as the GE fan controller. It appears to be related to the GE Smart Fan Control. It started happening two updates ago. It worked fine before that.

If you have door locks on your system, I don't recommend setting the "Respond immediately without waiting for device" option as you will not get the correct confirmation that the door is locked. Alexa will respond that it is locked whether the command executes or not. I tried it and changed back when I got false responses.

Good to know. I don't share locks with Alexa. Only Tim Cook needs to know when my doors are unlocked :rofl:

Also, that setting doesn't fix this problem. It's not a timeout. It's the additional level information that upsets her. You can avoid the problem by saying "low", "med", "high". It still gets confused with "off", though.

1 Like