Zooz ZEN21 unresponsive

I will start off including @agnes.zooz in case this is an issue that has come up before. I have a couple of these switches, which are version 3 and use firmware 4.0:

Occasionally (once every 6 weeks or so), they will seemingly lose communication where neither digital nor physical command will turn the switch on or off. If part of a rule, or app, the hub believes them to be switching state (based on dashboard tiles), but the load never turns on or off. I am using the ZEN21 scene controller driver of @bcopeland from HPM. I have not been excluding/including to get them working again, but instead cutting off the circuit breaker, and turning it back on resets the functionality.

What can I do to keep them from losing connection, and it's there anything I need to try first to troubleshoot?

I have several Zooz zen22 and I have the exact same problem. They will randomly lockup and lose all control (zwave and physical). I am using the built in Zooz central scene dimmer driver.

There is slightly newer firmware but not sure if they have done anything to fix that. I believe another firmware update is coming very soon as well.

I used to see this issue sometimes on my ZEN27 switches which were the first I installed (I have 21s also). Not sure if it was firmware updates, hub updates, or my custom driver but I have not seen it happen in a long time. I would make sure your device and hub firmware is up to date. You could also try my driver to see if that makes a difference. I know Bryan's driver is no longer being maintained since he now works for Hubitat. [RELEASE] Zooz ZEN Switches Advanced Drivers

Can I ask what do you have the switch controlling.

I have had this behaviour with zen21s and zen26.

Zen21 - using three of them with an exhaust fans. One of them was giving me issues and I installed a snubber circuit (RC) across the fan to protect the switch from high speed transients when the motor is switching on or off.

Zen26 - many cases where the load on the switch was too small and the OFF current through the load was too low to keep the switch in a good state. You can test this scenario by temporarily using an incandescent bulb and seeing if it fixes your issue. A permanent fix here may simply be swapping non-dimmable bulbs for dimmable ones. Yes I know this seems silly but some non dimmable led bulbs will not allow any current to flow until a certain voltage is reached. This leaves the switch high and dry in the off state. An alternate solution is to use an Aeotec bypass (expensive) or load resistor.

1 Like

That is a good one. I have spiked a couple switches this way. There is a commercial duty GE (Enbrighten) switch that IS fan rated.

What does the Zwave routing table look like? Weak signal? Only routing to 1-2 things? If you are just on the fringe of receiving a signal, something on the 900Mhz band like a baby monitor or portable landline phone might be enough to make the Zooz lose signal.

Yes I have seen the GE mentioned in other threads as well and I know a lot of people swear by them. I started off my zwave with three GE switches/dimmers back in my Wink days. After switching to Hubitat a couple years ago and adding Zooz to the growing mesh two of the GE died on their own accord. The last one came out of the wall recently. Even though it was zwave plus it didn’t support scenes and AFAIK there is no FW upgrade available. For these reasons I will not buy anything GE again.

Note re: zwave. If that was the cause of his issue I would expect that local control of the paddle should not be affected in this case. The one zen71 that I was having issues with was definitely on the fringe of my network - although I have four other switches in the immediate vicinity that did not show any issues. The snubber has been in place now for 4-5 months and zero issues since.

Yep, I only buy the GE for this due to the issues you note.

I did this on one of my fans too, (I think we talked about this a couple years ago) and it has been fine since. But on the other fan, I took the simpler route of just using the "better" switch.

Doh, was distracted when I answered this. I didn't read that post correctly, you are correct.

Lol you may be right. I may have referenced one of your posts when I did it. And time is a blur. Quite possibly could have been farther back than I remember.

And I definitely get the comment about a better switch. For me it came down to the devil you know. :wink:

Oh and I lied. My latest exhaust fan is a zen71. I was installing the new fan and switch at the same time ready to include a snubber when I noticed they had at least a cap module already installed in the fan. I never looked up the part number to see if it’s just a cap or in fact a snubber but just went with it to see. I haven’t had issue and it’s been installed for 2-3 months. Again please take the time duration with a grain of salt.

1 Like

They are with exhaust fans. I have 3 switch/fan setups, but only 2 of the 3 seem to have the issue. Different fans. I had tried to work with @agnes.zooz in advance about the potential inrush current, and thought we resolved they should be ok. I'll have to take a look at what you mean by snubber.

Regarding the test with bulbs - clearly the prior reply rules that option out.

Is this the routing table (sorry noob)?

0x28 and 0x2C

Bad news! I killed a Zen 21 exactly like this, as soon as the fan kicked off, the switch died. Brand new switch out of the box, probably 1-2 days old. :frowning_face: I took it apart, and the switch was absolutely fried. I didn't even bother warrantying it, it was my fault I killed it as they aren't fan rated. I think I still have it in a box here someplace, I might be able to dig it up.

You might see a R-C circuit associated with this. A resistor and capacitor in parallel, attached to the hot side of the fan.

I cannot remember for sure what values, but I stole them out of a dead ceiling fan remote (out of the canopy wifi device). I want to say it was a 47mf@250V and a large (maybe about 100K 1/2W?) resistor. Don't follow this exactly, this is totally from memory. I could be and am probably wrong with these values.

So it has been working with the least problems on the fan that gets used the most. That fan is the same model as the one in the other bathroom that has required the most times resetting the breaker. They've both been in use since last September. Maybe it's progressively dying, but not catastrophic like what you described. The circuitry is a bit over my head. I know you mean a resistor and capacitor in series. Is that what the Aeotec bypass is? Are you saying I should look to see if one is in the fan housing?

I agree the values are not really that critical but I think you are a little high on your resistor.

I used R = 120 ohms and C = 0.1 uF

Yes the cap should have a rating of 250W

I was a little concerned about power on the resistor so I used four 30ohm 1206 surface mount but I measured the RMs voltage across them and it’s only 4v so power is not a huge concern there.

This page shows 100ohms/0.22uF.

Man...exact same issue using Zen21s for 3 bathroom exhaust fans. Worked fine for a couple of months and then they all died - and can only be resurrected with flipping the breaker. Then they work again for a couple of weeks. Then they die. Rinse,repeat. They are now sitting on the shelf and have been replaced with the higher rated GE Enbrighten switches. The GEs connected to my hub immediately from dozens of feet away (had to have the hub within inches for the zen21s) and have totally behaved so far.


I totally love opening up the switch boxes :roll_eyes:, but I'm glad I'm asking now rather than later.

Someone said they had some limitations regarding firmware and scenes (not really an issue for running the fan on that one, though)?

Realized we didn’t address your question. The Aeotec bypass is market as fix to flickering leds when the load is less than 4W. Not sure if it’s just a resistor or something else, but from its description I’m not sure it would work as a snubber.

So I would venture that the zen21s are fine and can be repurposed somewhere else in your house.

1 Like

Besides the ZEN21, what other devices is this driver for?

I have support for all the ZEN standard switches and dimmers, and also a separate driver for the ZEN30 double switch. All the models supported is listed in the top post.

1 Like

Is there another thread about how to build one?

1 Like

Sorry, I overlooked the link. Thank you.

Just so we are clear, when I posted originally I wasn’t sure if your load was a fan or a low led load. I believe the Aeotec bypass will only address the low led loads.

Now that you have confirmed you are controlling exhaust fans and assuming you want to stick with the zen21, then a snubber circuit is required.

It’s just a resistor and a cap in series. I originally build three but didn’t use the third one in the last fan. I had a piece of shrink wrap around it but removed it to take a pic.

Edit: and @jtp10181 drivers are excellent. Using for all my zen21/22/26/27/71/76