webCoRE for Hubitat Updates

Seeing same here this morning, I'm on Hubitat 2.2.7.128, and just updated webcore to v0.3.113.20210805_HE this morning. I was going to make some changes to try to use the webcore weather device in a couple of pistons, but held off on updating anything since I saw this...

Thanks for the quick response!! That seems to have fixed the issue. My pistons look normal again!

Sadly, this is the first time I have read through the first few posts here. I did notice something....

Added new trigger capabilities

  • if Device receives attributeValue or if Device gets attributeValue (for momentary devices like buttons)
    • receives / gets triggers have the piston only subscribe to attributeValue (vs all state changes) of the attribute. (ie switch.on (only on events of switch) vs. switch (all switch state changes). This is also interesting for buttons (gets 1) to only receive button pushes for button 1.

Does this mean that pistons won't trigger on every state change of the device? For instance, they will only trigger on the "on" event and will not trigger again when the device is turned "off" ? (like they do in ST)

Pistons will trigger based on your selections. If you select both on and off events, both will trigger. Don’t recall that I had to change any of the pistons that I imported from ST (outside of the devices) to make them work as expected.

1 Like

These are additional trigger types, and the existing trigger types are unchanged.

1 Like

I hope this is the right group to ask this. I updated my Hubitat app to the latest Hubitat patches at the top of this topic - 0825. Now I am unable to access my pistons - it just gives me an error at the top that says dashboards could not be loaded - then it does nothing after that.

I have tried logging out then back in registering another browser - nothing works.

my pistons still work if I run them from hubitat - Any suggestion what I need to do to get my webcore interface running again?

---EDIT---
I reset all tokens, set new password, register new browser, went to dashboard.webcore.co - it eventually asked for password. Put in new password and exactly when the error message hit the browser, I got this log in my hubitat logs:

[app:13](http://xxxx/logs#app13)2021-08-27 04:17:31.828 pm [error](http://xxxx/installedapp/configure/13)groovy.lang.MissingMethodException: No signature of method: static hubitat.helper.RMUtils.getRuleList() is applicable for argument types: (java.lang.String) values: [4.1] Possible solutions: getRuleList() on line 4033 (api_intf_dashboard_load)

Thanks, TODDL

what version of HE firmware are you running?

(TODDL reply to what HE firmware)
Hubitat Elevation® Platform Version
2.2.7.128
Hardware Version
Rev C-7 (edit) looks like this is a few versions old --> I will try to update

FINAL UPDATE - upgrade ultimately fixed it - but had to revoke all tokens and register browser again - but thankfully I can now edit my pistons again and make sure I have good backups just in case. - Thanks to nh.schottfam for poking me in that direction. --TL

I also have the set variable issue. I have tried to update using HPM but it doesn't recognize webcore as being a managed package although it is listed in packages. Is there another way to update or repair?

you can update the webcore main and piston source file

Also, you can ask HPM to match again, or re-install HPM

1 Like

Thanks! I didn't think about reinstalling HPM, I was obsessing over having to reinstall webcoRE. Reinstalling HPM was the ticket. Worked like a charm!

Hi Everyone I've been spending hours trying to get this to work without success
I would highly appreciate some help

When i click on Dashboard (in the HE app) i get this:


When i click on "register a browser" i get this:

I enabled full logs - yet, this is all i get:

Here is my settings:



Testing the local endpoint url:

App version (From HPM)

HE Version:
image

Here is the repo im using:

My apache config:

Here is the network log from the browser when i try to register


It looks like the url is missing some "/" and it also calls "https" and not "http"

  • online version without custom url works

  • i tried to clean all the cache and security and reinstall webCoRE and HPM and also reinstall webcore on pi and restart pi and the hub - it did not make a difference

Please help! :slight_smile:

You should try to go to the dashboard from the webcore app

HE console -> Apps ->webcore

After you have configured the local dashboard in settings.

Yes, I tried that as you can see in my post I get:


and no log output (log settings is set to full)

please notice:
I edited my last post with some extra info regarding the browser requests

I went into Webcore to change something in a piston I hadn't touched in a very long time. Next to every Set Level xx% command for some zigbee bulbs there was "(?)". When I went into each command and saved it without changing anything, the question mark went away. What does (did) the question mark mean? Searched this topic and all of the HE forums and didn't find anything.

1 Like

@ipaterson any thoughts?

I'm getting this error when I control Hue bulbs with an inovelli scene. What does it mean?

org.codehaus.groovy.runtime.InvokerInvocationException: java.lang.StackOverflowError (deviceHandler)

I would try a polite reboot of your HE hub. Not seen this before.

HE console -> settings -> reboot

You also could shutdown (politely), power off the hub for 1 min, and restart.

I have posted a new release (but have not forced it on everyone).

  • use HPM repair to install it

It adds support for hub variables to webCoRE.

You should be running recent HE firmware to use this. (I suggest 2.2.9.134 or later)

Hub variables are referenced in webCoRE via @@variablename

So if you have a hub variable called 'foo'
in webCoRE you would reference this via @@foo

These work like other variables in webCoRE

  • you can get events (trigger on them) if they change
  • you can see them in the webCoRE IDE

Note that HE requires you to create hub variables via the HE console -> settings -> 'Hub Variables'

  • once created, webCoRE can use them (read, or update, or trigger from them)
  • also note that types are limited. (integer, bigdecimal, boolean, string, datetime (which for webCoRE should work for time, date, and datetime))
  • webCoRE automatically maps webCoRE types to HE hub variable types.
  • the webCoRE IDE can change the value of a @@ variable while you are in piston edit mode.

This change did not break webCoRE global variables @variable name

If you were using webCoRE super variables (the previous @@ format) - my apologies.

Feedback welcome

Few Q&A

  • do I do anything special to use them?

    • not really - just use them like other webCoRE variables (albeit only for types supported) and webCoRE will handle and conversion between HE formats and webCoRE formats. Ie you can just assign values to them the way you do today with other variables.
      • you can assign a webCoRE date, time or datetime to hub datetime type seamlessly
      • same for string, integer, boolean and decimal webCoRE types
    • you need to create them in HE console before you can use them
  • how do they update?

    • they update in realtime, and changes can cause change events to be generated by the HE firmware.
  • should I use these all the time?

    • your call, but if you don't want to clutter the hub variable view (or deal with name collisions), I suggest use them when you need to share data across apps (that are not webCoRE). Otherwise local variables and webCoRE globals are useful.
      • scopes
        • piston local variables - only piston sees them
        • webCoRE global variables - only webCoRE pistons on this node can see them
        • HE hub variables - all apps on this hub can see them, and perhaps other hubs in the future
  • Can I create them in the webCoRE IDE? (when editing a piston)

    • you use to be able to create them from the webCoRE IDE, but the HE folks have restricted this (for a variety of good reasons) that you can only create them from the HE console -> settings
    • you can modify their value in the webCoRE IDE
    • the webCoRE IDE will show their values
  • these also should work for remote access
    webCoRE for Hubitat Updates - #904 by nh.schottfam

10 Likes

Just updated webcore and ran a simple rule I have to set day of week HE variables using the webcore constants. It said both HE variables were invalid, See below. It did work, however, I reset the HE variables before executing the webcore piston and they updated after running the piston to the correct values. I originally had them updating connectors, thought I would try the direct variable method? Is this not how you do it?

Download the Hubitat app