Patched webCoRE for Hubitat (2018/09/09)

@ipaterson @nh.schottfam

I've been having an issue with restoring pistons from backup recently.

I like to take a full webcore backup before I do any major development. This way, if I make any big mistakes, I can import that backup and restore the piston back to its old version. The problem is, I tried that yesterday, and it didn't work. It loaded the backup file, showed me the list of pistons it had, (correctly) marked them as already present, and offered a "Restore again" button by each. When I pressed "Restore again" on the piston I wanted to revert, it gave me a strange error about being unable to load the piston data from the backup. My backup file has no password.

Can someone try to reproduce this? I'm willing to help get any information you might need.

I am running my own webCoRE server locally.

Thanks

Is there any way at all to use my PWS, an Acurite that reports directly to WU, for $weather?

I put it as a variable in the Pistons I need as an expression "[PWS : temperature]" but for some reason it's not showing up in all of the device details pages as being part of the piston. It shows as part of several of them but not all of them. It's weird it seems to work properly and send the right info when requested but it's the only device I have that if I search it thru the hub and look at the pistons it's a part of it doesn't show on all of them.

I guess you would need to change webcore-storage app to teach it to work with WU apis.

It is webcore storage that polls/populates $weather, and it understands how to interact with the weather apis (that it understands).

Several parts of the webcore graphics are missing. It is effecting the use of the dashboard as well. Such as the arrows to move things aren't there and I can't move things. This is like this on my phone and laptop. If I go to Chromium on the pi localhost it's normal. Any ideas how to fix this?

Upper left side of the piston edit screen:

Notice if you look at the upper left side of my edit screen those buttons are just blank boxes. I have the same box as you have clicked but the arrows that allow me to move pistons don't pop up. So I'm unable to choose them to move the piston. If I go to my dashboard that's hosting my WebCoRE server, a Raspberry pi, everything is normal. However, this behavior is occurring on any other client...including another raspberry pi.

Image 4

Notice it happens on the webCoRE cloud dashboard too. I tried staging.dashboard too with the same results.

I think I figured it out. I blacklisted fontawesome on my pihole. That was blocking these from loading properly.

1 Like

Hi, I've used the guide to install webcore on mi Pi.
It runs smoothly. I used git clone with the hubitat-patches branch

I installed the hubitat app from HPM including all the apps/drivers
so everything is supposed to be well updated.

I added my ip in the app's settings (without api call, otherwise it doesn't work) and used browser register to get a code and log in to the webcore dashboard.
I enabled all the devices in the hubitat app.

however, i can not see any devices in the webcore dashboard.

Please help :raised_hands:

If i turn on API
when i click dashboard in the hubitat app i get this:
image
and if i use browser register i get this:


either way, i can not see my devices in webcore

Also, this is definatly not my hub'w ip:
image

UPDATE:
after clearing all cache and data and enabling api urls access. now when i log in i just get an error message.. looks like this:

I would suggest try it first with superstation (NPM) package to see if that works.

Do ensure you have the right files, as not using the current branch will cause it to fail.

Otherwise you need to turn on logging on webcore to see what is going on.

Thank you very much for replaying!
I am using the package from NPM you mentioned.
I think one of the problems is that i used "http://ip-address-of-webcore" instead of just the ip.
Now when i click on dashboard i get this:


if i try "register a browser" i get the same error as before

I've put a more elaborate details of the problem here:

It just looks like a more updated thread

Has anyone else run into the problem of WebCoRE not "remembering" the devices you've chosen for a particular Piston? I find I'm having to return again and again to make those selections, and they (most of them) disappear – become un-checked – almost immediately after I do. Here's a screenshot of what I mean:

Right after selecting these 6 devices, but before I click DONE:
piston_set

And then a moment later, after clicking DONE and returning to Piston setup screen, only 1 of the selection remains:
piston_unset

Any insights to share on this? Strikes me as a certifiable "bug" in the Hubitat instantiation of WebCoRE, but I truly hate to cast aspersions. :slight_smile:

I promise to scour the previous 1020 replies to this thread for clues...

So you are looking at the piston?

It sets this itself automatically based on devices it accesses.

You only need to set devices for webCoRE main app. This piston when it accesses something will add it to the list of what it is accessing.

So just let it run, it will let you know what it actually accesses.

Ah, that's good to know (wonder why this control is even presented, then?), but I gotta wonder still, since I have a local variable within the Piston's "define" section which does reference 4 of those sensors -- to calculate their variance -- shouldn't they be enumerated as well?

Or do all references have to appear within the 'execute' section in order to qualify?

show me the piston in private message, I'll have a look

Can answer my own question now:

YES, it matters where you place those references. Instead of...

define
tempVar = variance of device's temperature(s)

do
set @@global_var = tempVar

...I went ahead and consolidated everything into the do section...

do
set @@global_var = variance of device's temperature(s)

Lo and behold, all 4 of the referenced devices now appear in the "devices used" list!

If you can share the original, I would like to see why it is not working

thx

Sure thing. I thought I had shared the original Piston above, but that must've been on a different thread, so here it is again:

I'll now paste the modified version (with Triggers removed, since I now call this Piston directly from a rule in RM):

I hope the slight change(s) I made to the Piston are self-evident in nature. Note that everything is "working" inasmuch as my workflow (i.e. calculating temperature variance among 4 sensors, and setting a Hub Variable accordingly) reliably goes to completion.

Ok, I found the issue, will have a fix in next update.

1 Like

Yay, glad I brought it up then! And that I wrestled with it for only two days, not longer. :smiley:

Download the Hubitat app