UltraPro zw3010 dimmer and zw4008 switch drivers

Two aggravating problems.
The ZW3010 Dimmer (39351) takes a couple of seconds to turn off when physically switched off. I find myself waiting to see if it does. I've researched the driver options and tried them all to no avail. Ramp rate is non-functional.
The ZW3010 switch operates correctly, but lately in the last month or so, after turning it off, it doesn't report off, even though it is off. I've tried the recommended drivers posted here on Community also to no avail.
I've written Jasco/UltraPro and have gotten no response.
I've also reviewed the firmware changes they've posted but have been afraid to implement them fearing trashing the switches.

If it used to report, and no longer does so, indications are there are zwave mesh issues. Do you have a C5 or C7?

1 Like

Running a C-7
No zwave issues with the rest of the 30 or so zwave products.
I thought the same and ran a zwave repair.
The dimmer, which is a plus device, is 10ft or so from this switch, which is less than 10 ft fromthe next device.
There are no zwave logs.

Is the ZW3010 controlling dumb lights via load? If so, there nothing involved from the hub on that (other than getting status), the switch works just like a regular switch would to turn the bulb(s) on/off. Changing drivers won't do anything to affect this issue. Something in the switch itself may be going south.

Can you clarify that the Dimmer is controlling dumb bulbs and the switch is installed normally (line/load/neutral/ground)?

As to the switch, if it's a Z-Wave Plust switch (and I believe it is) the lack of reporting may indicate problems w/your Z-Wave mesh.

What drivers are you using, and have you tried these? After changing the driver and saving the change, make sure you hit the Configure button at the top of the Device page, and then refres the Device page.


Yes, dumb LEDs.
The driver you noted is the driver installed.
The reason I thought it was firmware is that as you noted about the switch not needing a driver to physically turn it off.
I've found another person with the same problem, but he gave up and installed a Zooz switch.

On the other switch, I'm running a generic driver for just on/off after trying the driver you noted. I DID see that it had S2 on it, so I may reinstall without.
Thanks for the info, I'll report when finished.

Checking those devices with S2, all are having zwave problems, even after repairing them.
I updated zwave, then booted the hub. Some are working others are not.
But all devices are digitally and physically working, which I thought was strange. Maybe I don't understand zwave like I should.


Changed UltraPro switch to GE Zwave Plus Switch. But didn't help.

Definitely a zwave problem.
Found 2 ghost devices on the network.
Repaired after removing, but didn't help.
Shutdown hub for 5 mins. Unplugged so the radio would restart.
Topology looks great.
Switch is responding/reporting correctly.
AND, beyond my belief, the UltraPro dimmer switch responds immediately when physically switching off!

There are two devices on the zwave list, 0B and 0C that are connected to each other, but do not show a device and will not remove, but all devices are working, so I'm leaving it alone.

Can you post your z-wave details page? If you still have ghosts your mesh will not be healthy and you will continue to have issues. If your the devices that created the ghosts still have power to them the ghosts won't remove so those devices need to be powered down.

1 Like

Thanks for the screen caps, but we need to see to the last column in the table, particularly the "Route" column is very important. If that is empty that's a bad thing...can you repost w/the full width of the Z-Wave Details table?


Post the whole z-wave details page including the routing column :slight_smile:


Did you adjust any of the switch's settings in the drivers? Like in particular on a dimmer, change the ramp rate?


And can you clarify this - you are referring to a physical swapping of switches (remove UltraPro and installed GE). You excluded the UltraPro switch from your mesh and then included the GE, and you had the same problem with reporting with either switch, and using either driver (the Generic Z-Wave Plus, or GE Enbrighten Z-Wave Smart Switch, or Jason's drivers that I linked to)? And, importantly, your hit Configure at the top of the Device page after saving the driver change?

I did not change the switch out, I replaced the botched driver with GE Zwave Plus driver.
No routing on 0B and 0C.

Dimmer details... No Ramp Rate option.

Thanks for the updated shots. You're going to want to get rid of those ghosts...

  1. Do the hub power down/wait a minute/power up
  2. The shower switch is the likely source of one or both of the ghosts. Pull the air gap on the shower switch and hit Refresh repeatedly on the ghosts. The Remove option should appear, choose that. Do that for both of the ghosts.
1 Like

It's right here in the second screen shot in your post, third preference below: :wink: It's set to Default so should not be causing any problems.

0C removed ok.
0B is giving me problems.
Have shutdown the hub twice after removing 0C.
The shower switch is a toggle, which doesn't have a pull tab so I followed instructions to reset it by upx3 downx3.
Tried to remove 0B 20+ times with nothing but "Pending" returned.

You need to power down the device that created the ghost the. Power cycle the hub (clean shutdown and unplug for 5 mins) the. Attempt to remove. As long as the device that powered the ghost is still powered it's pingable and therefore can't be removed


So in that case the source device for the second ghost could be one or two devices further down in the Z-Wave Details list - it will be another "Specific_Type_Power_Switch_ Binary" device in your lest.

Hopefully that other switch will have an air gap. One option that has been used in the past when trying to remove ghosts and it isn't clear which other device create the ghost, is to keep the hub from communicating with devices while trying to get rid of ghosts, is to temporarily encase the hub in a tinfoil Faraday cage. Then you can run the Remove and it should work, since the hub can't communicate w/any device. So you could try that option.

BTW, you don't want to keep resetting switches as that disconnects them from the hub but doesn't properly exclude them, which can result in new ghosts. At some point soon you're going to need to re-join the Shower switch to your hub. You can use the Replace flow:

  • Hit Refresh repeatedly on the Shower switch until the Replace button appears
  • Put your switch into pairing mode and hit REPLACE button
  • The switch should re-join the hub w/the same DNI as the orginal shower switch, using the same entry on the Z-Wave Details page, and automations using it will all continue to work
1 Like

14 devices of this type.
I wrapped the hub in tin foil. Tried shutting down, unplugged, replugged.
Tried to remove 0B ... pending.
Tired of fooling with it, maybe since it's pending remove, it'll be gone one day.
I've been at it for many hours.
Reminds me of debugging COBOL programs for 30+ years.
All seems to be working good with no error messages in the logs.

Maybe y'all can put a force remove in one of these days.
Maybe if a switch is ever communicated with, you could store the switch identifier (MAC address?) in a file stored on the hub that could be recalled.

Download the Hubitat app