UI speed still challenging on a C8Pro?

I have posted on this twice before. Once in general and once specific to the button controller speed:

I have a large automation implementation - pretty much everything in the house is automated. A quick count looks like ~450 rules. I use multiple hubs (1 for zigbee, 1 for Zwave, etc.) - but centralize my rules on one C8Pro.

My goal in the house is to minimize the input from the family members and have the house know what to do using sensors, timing, etc. This is working really well and everyone enjoys the fact the lights come on when they want to, the temp is always right, their music plays, etc. Bravo to Hubitat for pulling this all together.

As such I enjoy tweaking the rules daily - I am always coming up with new ways to predict things that need to happen.

So now I get to my question. The UI seems to be dragging quite a bit. I already mentioned the button controller speed which has been acknowledged but I don't think any timeline on resolution?

But the apps page is giving me challenges as well.

Opening a rule - 13-15 seconds
Changing any part of the name of a rule or while creating a new rule saving the name - 13-15 seconds
Leaving the select actions to run window back to the main rule details - 13-15 seconds.

And these numbers seem to get slower as I create new rules. Assuming the number of rules is a multiplier - I do spend time pruning the rules which I guess is a good practice.

I am posting not to rant - as mentioned above I am extremely happy with Hubitat. I just want to learn if there are ways I can improve this speed and not see the spinning green wheel in my sleep? Thanks.

1 Like

Are you running an Ad Blocker? If you are add an exception for your IP.
Also try another browser just to eliminate that variable.

Thanks for the suggestions. No ad blocking beyond native browser. Safari and chrome give the same performance. Consistent across multiple relatively well powered machines - Mac Studio M2, MacBook Air M2, etc. What are your response times and how many rules do you have?

I am open to the possibility of it being specific to my environment but so far I can't figure out what the issue could be.

My rule list is pretty small by comparison and probably not helpful. If you are using Chrome you could look at the performance insights. That will tell you where the time is being spent.

That is an eternity. Is your hub connected via Ethernet cable? If so, have you tried changing the Ethernet speed to fixed 100mbps? Or if it's already set to 100mbps, try changing to auto. I don't think you are running into memory issues or any real hub limitations regardless of how many rules you might have. :thinking:

Yes to connected through ethernet. Speed was set to auto, so I changed it to fixed 100. Not seeing any change in performance.

I have included a short video in real-time of what I am seeing. Happy to provide more diagnostic information as appropriate to see if this can be solved?

https://imgur.com/a/qBmq0u8

Did you reboot the hub after changing the settings?

Please send me your hub id. I haven't seen pages loading so slow since dial-up days.

I did reboot the hub.

Will PM the hub id

1 Like

Is anyone having a similar issue with the C8Pro in terms of response times in UI?

I recently noticed another quirk:

I ran the latest software update on multiple hubs at the same time. I noticed that the C8Pro took significantly longer to download the file. The other hubs did it within seconds whereas the C8Pro did it in over 10 minutes. In fact all other hubs had completed the update before the C8Pro had downloaded the file.

Just curious if we can try to pin this down as to what may be causing this?

I haven't seen others report this on the forums. It certainly isn't widespread, or we surely would see many others complaining about this.

I didn't see you mention that you actually tried a different ethernet cable as suggested. Did you try plugging into a different port on your router, preferably the port for the hub that works fast/normal? I would also be tempted to swap power supplies, just to rule out everything in your power.

Thanks - I will be sure to try this. But I am dubious that this is a network or power issue. I can connect to the hub just fine.

I also have two other hubs on the same switch which are having no issues - a C8 that I use exclusively for zwave and a C7 which I use exclusively for zigbee. I started doing this when I first switched to the C8 and started having all sorts of zigbee issues.

The C8 and the C7 don't have much on them as I just access them through Hub Mesh. They are all running fine and are quite responsive.

I was having serious performance issues with my C8 when it was my main workhorse. I posted about that. But then the C8Pro came along and I installed that and things were much better. Then that started to get slow which is what caused me to post this.

Perhaps it is too many apps, too many rules, too much on Mesh, or none of the above.

But this is being looked at by the Hubitat team:

and is "still under investigation"

My main hub, a C8 Pro, which has all my z* radio devices and basically all my rules takes that long to do any update. It has been that way on the previous C8 I migrated from and the C7 before that (which I also migrated from). The other various hubs I've had for LAN integrations, sharing with outside integrations (Alexa, Home Assistant), and an ill fated attempt at a Matter hub that I could never get to connect to HomeKit matter over thread devices all updated within seconds. I've given up trying to figure it out. I've done the changing power supplies (which I did anyway when moving from C7 to C8 to C8 Pro), obviously had different power cables, tried different network ports (connecting to router, connecting to a hub, including ones that are "fast" for the other hubs), different network cables, etc. I'm just guessing that something with the Z* radios or I guess the rules/automations/etc. that makes the update time much, much slower. I suppose I could try just blowing everything away and starting from scratch, but I'm not going to invest that kind of time and effort. I chose Hubitat because it is easier to set up than home assistant and wasn't the cluster that SmartThings was.

Interesting. I have my z-wave radio disabled on my C8Pro as I have all z-wave traffic running through my C8. I do have about 25 zigbee devices on the C8Pro. I am slowly moving everything off to the C7. I would expedite this process and disable the radio if I knew it would make a difference.

Just out of curiosity - how many rules do you have running on your C8? With around 450 rules I can't help believe that there is some connection between slowdown and rules running.

I don't know for certain, but in the logs, it shows 201 "apps." So not a real heavy user in those terms. I am running hub mesh (but I also was on all the other hubs when I used them). Around 33 Z-Wave devices and 76 Zigbee (24-25 are repeaters). A Lutron hub with around 29 devices. Some LAN devices meshed in from the other hub (which updates very quickly). I will say the actual update process probably isn't much slower than the LAN hub, but the download takes forever. When I had 4 hubs running, I could update the 3 other hubs in consecutive fashion and the main hub would still be downloading. Backup time is comparable between the two.

Not quite to the level you have experienced, but I did notice my performance took a big hit when I was running some high traffic LAN integrations on it. UI was slower and I noticed zwave and zigbee devices seemed slower to respond.

I resolved the issue by moving the integrations over to my second hub (which I should have done to start with, as its entire purpose is to run Network integrations).

This makes me wonder how Hubitat Elevation manages multi tasking. I never saw more than 20% CPU load on my C8P, and yet it ran like it was a Linux PC @ 90% load.

Many modern operating systems assign themselves priority access to CPU core or two, to prevent the OS from becoming sluggish - this might be worth looking into for the Hubitat team? @mike.maxwell @bcopeland @bobbyD

How did you determine which integrations these were? Trial and error? Also which ones were they? Might help me to offload things onto other hubs to help speed things up?

That was easy, I knew exactly what I’d installed and when the performance started dropping.

The main ones were InfluxDb, Fronius inverter, and Tesla Powerwall manager.

I normally only run the radios and the bulk of my automations from my primary hub and only run LAN integrations on my secondary.

It was my own fault as I was being a bit lazy, however, my solar and battery management integrations + rules run every minute and as a result work the hub quite hard.

That said, I’ve found my Secondary C7 performance is completely fine - I suspect this is due to it not running any radios.

@simon4 you might want to follow this conversation I’m having with a couple of devs that have CPU monitoring functions in their apps.

Interesting. I have the z-wave radio disabled on my C8Pro hub. But I do have the zigbee radio enabled running some devices. I keep most of my zigbee devices on my C7 hub.

I didn't mov all zigbee off the C8Pro to the C7 as I had some devices that were tricky to get setup.

But I think as my next step I will start moving all zigbee off to the C7 hub and work on shutting down the Zigbee antenna. Presumably that will help to reduce the load and may improve performance. If nothing else it keeps things clean.

The other thing that I have always wondered about is the Ecobee suite:

It is consistently showing as using half of the buy time. I did post on the developers thread to better understand this. Things got a little defensive but the basic position is that in this case it is 42.1% of 16.4% busy time which is 6.9%. As a test I could uninstall this plugin and compare before and after performance. But this does seem a bit arbitrary.

1 Like