Types of devices for Alexa Skill

Being new to hubitat can anybody help me with getting alexa to see devices, the alexa skill is activated and all that I have entered are showing up but not in alexa, up to now alexa sees a Osram bulb, virtual switches but not a smartthings multisensor or 2 ziaomi orignal motion sensors


The current Hubitat Alexa Skill does not support Motion sensors or Contact Sensors.

Numerous threads on this topic... :wink:


Is it only sensors or are there more types of devices that that do not work I tried a z wave flood sensor and that also failed


Switches and Dimmers work. I think that's really all that works at this time. Also, I am not sure that Alexa even supports leak sensors whatsoever.

[Updated to remove Thermostats per @doug's response below.]

Thermostats through HE do not work, AFAIK


I use a Alexa skill for node red that allows me to control my thermostat through hubitat maker api. A bit of work to setup. But does the job well.

I can get virtual switch to show up as a device in Alexa but I can use it to trigger a routine.
I am trying to get Alexa to announce something when a virtual switch is turned off by a Hubitat rule.

I am trying to avoid using HE to announce through Alexa and renewing the cookie every two weeks. "No raspberry pi."

Only motion sensors and contact sensors can be used to trigger an Alexa Routine (Amazon restriction, not Hubitat). Use a virtual contact sensor instead of the virtual switch. Using RM, you can set the contact sensor by using a “Custom Action”, then delay 2 secondS, and the set the contact sensor back. This way it will be ready for the next time you want to trigger it.


All that work, or take 2 minutes every 14 days to replace a cookie :innocent:


Or, save the 2 minutes by running the Alexa Logon Cookie service on a rPi and never touch the cookies again. :wink:

Is this working for you? The first cookie it retrieves works for my setup. The second cookie onwards it stops working.

Yup! I've had it running for probably 9 or 10 months now. I had to restart NodeJS once in all that time. However, I think that Amazon has done some "refactoring" in terms of their login processes as I've heard other people have issues with it as well.

Not sure why it stopped working for me. What I know is that the inconsistency in why it stops working has made it difficult for @gabriele to figure out why it stops working. Weird ...

Custom action requires a parameter to be set. String, number or decimal. I would think it would be a boolean.

Actually, they don’t require a parameter. Just leave that field empty. Simply call the “open()” or “close()” command on the virtual contact sensor device.

1 Like

I actually ran into a similar problem the other day. I couldn't even setup the Amazon login in the AlexaCookieNodeJS app, the page always got stuck in "Please wait" but the logs of the app indicated that the login was successful. After some troubleshooting I found out that there was no CSRF entry in my cookie anymore. I double checked that with Chrome and the CSRF record is missing there too. So, long and behold, I modified "AlexaCookie.js" and changed line 185 to look like this:

else if (result) {

and voila, it works. At least for me. Even went through a cookie refresh by now and my house still speaks to me. I was going to let it run for a bit longer before contacting @gabriele with that information


I'm going to try this today. Thank you very much!

The first cookie refresh worked; however, after a second cookie refresh TTS stops working. Even though the logs indicate the new cookie was downloaded and parsed successfully.

I'll test a bit more tonight/tomorrow

1 Like


I think I found a way. First, revert back the change I told you before about. Change line 185 in the AlexaCookie.js back to

else if (result && result.csrf) {

Now, go into the AlexaNodeServerJS directory and rename the folder alexa-cookie to alexa-cookie.org (or something like this)
If you have git installed, you can just run the following command while being in the AlexaNodeServerJS directory

git clone https://github.com/Apollon77/alexa-cookie.git

If not, download the zip from from git here https://github.com/Apollon77/alexa-cookie/archive/master.zip and extract that in the AlexaNodeServerJS folder. Make sure that the folder structure is the same as before and that you have an "alexa-cookie" subfolder again.

Now, redo the registration in the AlexaNodeServerJS and then update the cookie in the Alexa TTS Manager. Your house will hopefully speak again

@gabriele, you might want to consider updating your git repository to include the latest alexa-cookie implementation (or just make it a dependency of your project and install with npm install.). Apollon77 made a change in version 2.1.0 where the URLs for the login were updated to still be able to get the csrf value. Apparently that is what caused the issues. I'd be happy to refactor your plugin and send you a pull request to use the npm dependencies instead of copying to folder in there, just let me know if you would rather do it yourself.