Tuya Humidity & Temperature sensor

Hi all, just starting with my Hubitat so excuse me for asking possible dumb questions :wink:

This is the device
Don't know how to get this device recognized fully, it's paired but identified as an "unknown zigbee device".
"Get Info" gives me "getting info for unknown Zigbee device" and that's it.
Used the native zigbee discovery of the Hubitat.
Should I use another integration maybe?

Hubitat uses the set of values obtained during pairing to identify the device. Unknown devices are just that, devices with values that don't match anything. The result is not knowing which device driver to use. So it uses a driver called "Device" which is a "do nothing" device driver.

You must then choose a better fit driver... you can search the community for someone else that is using the same device and learn what driver they are using, However, it certainly is possible that there is no matching driver, yet.

You could try any of the built in drivers that might get part of the sensor working. For example, you could try the "Generic Zigbee Moisture Sensor" driver to see if it might get one of the two sensors to make a report.

1 Like

Some people have used this driver with the TuYa sensor:

1 Like

Thanks a lot to both..
Konke seems to works indeed.

I just got three of the AliExpress "Zigbee Temperature & Humidity Sensor" devices:
https://nl.aliexpress.com/item/1005003715976060.html
The box says "Powered by Tuya" and it has a "Smart Home" logo. Bar code: E20578

I used "Add Device", "Add Device Manually", "Zigbee", "Start Zigbee Pairing" and pushed the button on the device for five seconds to get it into pairing mode. Hubitat found it and shows this info:

  • manufacturer: _TZ3000_fllyghyj
  • model: TS0201

Under "Device Information" I set the Type to the built-in Hubitat "Generic Zigbee Temperature/Humidity Sensor" and after a page refresh it shows these "Current States":

  • battery : 100
  • humidity : 39
  • temperature : 24.81

Depending on how fast you add the device and set the right driver, the "battery" state may not show up. The device puts that out quite early in the pairing and you may miss it. I don't yet know how often it issues battery updates.

I have a Tuya humidity and temperature sensor.

  • manufacturer: TUYATEC-yg5dcbfu
  • model: RH3052
    The "generic Zigbee motion/humidity sensor" reports battery, temperature and humidity.

I purchased a couple of these.
They have the manuf. of Moes but powered by Tuya. Model kctw1z-02.
I selected the Generic Zigbee temp/humidity since it selected Device.
Seems to work ok but the humidity is one digit (3% 4% 5% etc.) instead of 34% 42% 55% (for example).
The model reported on the device's page is :
image
Is this a possible problem with the manuf that I bought? Not a big deal because I really just need the temp, but humidity would be nice.

You can use this driver. This is a non-standard Tuya device and the humidity will not be reported correctly with the inbuilt HE drivers.

Thank you I am trying it now.
I saw that but was concerned if there might be a problem using that driver and my sensor that does not have the clock.. and if a conflict might happen, but no harm in trying!

So far so good! The humidity is reporting correctly and I like the ability to set min/max reporting intervals as well as triggering a report with change.

Thanks for this! It is really a BIG driver with lots of research and additions to it.
Makes a versatile driver.

Of course if Tuya wasn't so weird, things would be a little simpler!

Have a question about my sensors.
When I click on Refresh on the device page, the log shows this:

Is this due to my sensor being an oddball??
This is what the device page indicates:
image
and

These are the preferences that I set, mainly for testing:

1 Like

I am trying to understand whether the reporting parameter values in the driver make any real changes to the device reporting behavior or not. And I am changing my conclusion several times now .. : ( ... will have to monitor the results for a longer period,

The first graph is for 24 hours, the second is for a 2 hours period. For both the temperature and the humidity, the minimum reporting period is 30 seconds and the maximum is 600 seconds (10 minutes). Temperatre dealt is 0.1 deg and humidity is 1%. Seems like if the humidity is reported every 30 minutes (not 10!) if there is a 1% change, but much more frequently if there was a rapid change! The reporting settings seems to not affect the temperature reporting frequency..


I will wait 24 hours with these settings and then will configure bigger deltas ( 1 deg temp change and 5 % humidity change) and bigger maximum reporting intervals.

I checked the configuration of the same sensor with a Tuya gateway - no any commands are sent to configure the reporting intervals, the SmartLife UI also does not provide any configurations. So it may turn out that despite the device accepts and confirms the changed reporting intervals, it actually ignores them and uses some hardcoded values inside the firmware.

On the error logged when Refresh button is clicked - I will fix it in the next update. Actually, the Refresh button can not do anything with this cell battery-powered device, as it is sleeping all of the time except when it is sending T/H reports. So it is impossible to force / refresh the readings.

As I understand it there are a (large?) number of different manufacturers who make devices labeled Tuya. The standards aren't the same across all those devices... Results in complexity getting things to work.

1 Like

Thank you for posting your graphs and your info.
I am still trying to figure these sensor's reporting out but will let you know what I found out.

Does the initialize button do anything then? What are the differences between initialize and refresh?

So Tuya is not the manufacturer of these devices labeled Tuya then?
That makes things very difficult, thinking that you are getting a device from the same manuf. and brand X is actually the producer of these things.
Even between the different temp/hum sensors, some with time/date, some with lumin., and just because it is a TS0201 it could be MANY different "versions" of the same thing, hence the "_itnrsufe", but that refers to a manuf. of TZ3000!

They sure make it confusing as this info is not on the seller's listing so you don't know what you are getting!

FRUSTRATING!!!!

Thank you for your info!

Thanks @KKossev

Once again your modified driver saved the day.

I already had some of the standard Tuya temperature/humidity sensors and they worked with the generic driver. When I added one of the devices with the LCD display panel, the humidity did not report correctly. The driver you provided in your post above fixed the issue. :smiley:

1 Like

Well I got tired and fed up with the sensors that I bought, and just returned them!

I was spend WAY too much time trying to get these non-Tuya sensors to report temperature, and when I compared them to the Aeon tri sensors that I have been using for a while, the Tuya's were junk.... very slow and incorrect temperature reporting.

Since I liked the display on each sensor, the fact that they fail on the reporting is not worth it for me.

I tried several different drivers, and none of them really worked well, so back they went!

I am looking for temp/humidity sensors WITH display that can update at LEAST once a minute, or when the temp changes (adjustable), since I am using them to average temperatures for my HVAC.
I average about once a minute and use the average with the thermostat controller app.

Thanks all for your help though...

And not too keen on buying from Aliexpress or Bangood because if I need to return them, the hassle and lack of support.

I attempted to install this driver for my new TS0201 devices. But still not reporting anything. :sob:

Oddly enough I tried another sensor on the generic ZigBee temp/humidity drivers and now they all work. Go figure.

1 Like

If you have used the Tuya driver to pair the sensor at least once, it often 'unlocks' the device and it starts sending T/H reports using the standard Zigbee clusters. This may be an explanation.

1 Like

Download the Hubitat app