Sweet Jesus - do the new Schlage drivers make a difference or what?!


#41

yeah, i didn't have the log window open. I should have. Still learning.


#42

Rock solid advice.

We all are. Best thing about Hubitat is the user community.


#43

I've learned alot about this platform from the logs, and I myself usually always have a log tab open on each of my hubs, I mentioned to staff having this open automatically with certain things (paring/configuring/zwave repairs/etc) would help people learn, hopefully one day that happens.


#44

Anyone having success using the new driver with the BE468 Zigbee locks?


#45

I might be wrong, but I think the BE468/BE469 drivers are for z-wave deadbolts. Specifically, these:

BE468 and BE469

The zigbee deadbolt is BE468GBAK. I think it was dumb on Schlage's part to give it such a similar model number.

Edit: What @mike.maxwell wrote in this post suggests they are for z-wave locks.


#46

Got it, and you're right - dumb model number. Hopefully the Zigbee version gets some love eventually, although my lock has been 100% reliable between it and Hubitat. Only exception is that it doesn't seem to report which unlock code was used consistently.


#47

I myself haven't been saying Sweet Jesus today on these Schlage Be469 locks..in fact I was beginning to think these locks should be renamed to Scl-Hell666.

I did add 2 extenders after all 3 of my locks dropped off. I decided today to try and re-pair one of the locks.
Tried a long network cable & put HE hub basically on top of the lock installed on the door.

I followed what @waynespringer79 suggested.

  1. Unpair
  2. Factory reset lock--disconnect batteries, hold down Schlage light up keypad, plug batts back in.
  3. Pair to HE.
  4. Delete the 2 factory user codes AT THE LOCK ITSELF
  5. Add codes in LCM.

Initial attempts at these first 2 steps worked...step 3 "Pair to HE" did not work as HE never would discover the lock...tried Z-wave exclude, pair again...no go....kept trying...no go...looked for local exorcist on craig's list...no luck there either.

I then gave up on the long network cable...took HE back to my computer & LAN room & then
removed the Schlage lock from the door. A PITA but I was to the point of going back to Wink just for these locks.
Took lock into my computer room and set it right beside the hub.

Put lock in pairing mode and HE found it immediately but hung up on "initializing" it.

Tried it all again and this time it found "2 locks" which was the same lock with ID 37 I 38 (?)...did z-wave exclude...started discovery again and this time it found the lock again and initialized it properly!! Sweet Jesus!

I took lock back to the door and installed it....a pain yes, but it was working.

Next I deleted the 2 factory user codes AT THE LOCK ITSELF like @waynespringer79 said...

Loaded up LCM and then put in my user code & wife's user code...at this point in time this lock is working perfectly.

I tried a second lock of mine...did all of the above the same way except this time I decided to try deleting the 2 factory user codes in the device settings of the lock rather than at the lock itself...as usual, this lock was displaying the "????" at the code positions 1 & 2 after initial discovery by HE.

By entering code position 1 and pressing "delete code" the first one deleted fine...it took several tries for me to delete the 2nd code at position 2 but it finally deleted it...should have stuck with @waynespringer79 advice to delete factory code AT LOCK ITSELF.

Anyway, I have the 2nd lock up and running fine. Sweet Jesus again!

At this point, I decided that I've had enough religion for the day & wife was tired of me not exactly being politically correct with my language upon trying to pair it initially with the long cable, so I decided to save the 3rd and final lock for another day.

Sure the removal of the locks is a PITA but at least they are working now...can't figure out why HE would not find the locks with the long network cable & hub practically sitting on the lock.


Be469 driver not logging some events
#48

One thing I encountered when I originally set up my lock using the generic driver, to switch the lock code to six digits, I could not do it via the driver in HE. Had to do it at the lock.

Same thing with the Schlage drive. Had to do it at the lock and then set it to 6 in the driver to program new codes.


#49

Does this mean that you don't have to take the hub to the lock to get it to pair any more?


#50

I haven't had to do this since I strengthened by z-wave network by adding four Aeotec Range Extenders (ZW117).


#51

I'm happy to report that the new driver has SOLVED the battery drain problem with my Schlage lock.

Many thanks to this great community for the support!


#52

So I finally bit the bullet and updated my main hub to the latest firmware....primarily to try the new 469 driver on my 2 schlage locks. I changed the Front door lock driver, saved and hit configure. It wen through the obligatory code fetching and when I refreshed the driver page I got this.

All looked good so I did the same with my Kitchen door lock. All seemed to run fine but my device page for that lock looks like this

@mike.maxwell both locks seem to operate fine but why does one have the association state variables and the other does not and should I be concerned?


#53

My Schlage lock looks just like your 2nd picture without the association state variables using the new Schlage driver.


#54

I'm 80% :man_shrugging: sure that wasn't there before I updated the driver for the first one.


#55

No nothing to fret over, those aren't used in the new driver.


#56

Is anyone still finding a need for the reliable lock code to be used after updating to the new driver? Just curious.


#57

Yeah, I have one lock that still falls off the network about once a week and the battery drains faster than the others. It’s the furthest from the hub. Firmware 7.1. I have 4 Aeotec repeaters. Thus, I’m using Reliable Locks to try to help that one stay on the network.

The other 2 are firmware 0.8.0 and 8.0 and have been flawless.

The one bad lock drives me bonkers once a week. :slight_smile:


#58

Maybe relocate the problem lock closer and use one of the others with the newer firmware to it's location, see if the problem follows it?


#59

Yeah, that’s the next step I think I’ll take for sure.


#60

I am curious. For those who have communication issues with your locks. Have you let the batteries completely die after they were working good?

My lock has worked solid for many months. The other day the batteries died. Now it intermittently quits responding to commands and reporting status. Pulling the batteries gets it working again for some time. Then it just quits. It is kind of strange.

Every time when I am about to get all angry and deleting and excluding things, it starts working again. If it quits again after this time i do plan to exclude and repair to see if it fixes it....