Sweet Jesus - do the new Schlage drivers make a difference or what?!

I just updated to and changed my lock drivers from generic z-wave to Schlage FE599 and Schlage BE469 drivers.

Huge difference! They are extremely responsive. I can use Lock Code Manager reliably.


Big thank you to @mike.maxwell!!

I'll be setting up my Aeotec Doorbell 6 after church tomorrow. Thank you for adding that driver too!!


Yes they definitely do, I would say for some people the extenders/amplifiers will still be needed though as 2 of my locks with the new driver every command every time is instantaneous. The 3rd one (farthest away and on a metal building) has a "slight" delay (relative to the other two) but is still night/day improvement over what it was with the Generic driver...also I do have 4 extenders, and will probably get one more just to make that third one be just like the other two.


Love it. My FE599 is at last a happy lock :smiley:


There is a definite difference. I wonder what is in this driver that is not in the generic one? Device specific commands?

No, just differences in how the association group commands are sent (secure vs non secure)
Rather than trying to jimmy these into the existing driver it was just easier to spin up dedicated drivers for these locks.


2 of my 3 locks are performing great now! Thank you @mike.maxwell for all of your work on these drivers! I very much appreciate all you have done to help us!

While 2 of my locks are performing exceptionally, one of my locks is having more problems than before the update, and I think maybe it has to do with the firmware version of the lock.


  1. Changed driver to the Schlage 468/469 driver on all 3 BE469 locks I have
  2. Saved
  3. Hit configure
  4. Watched logs for the configuration to complete, and all 30 codes to be fetched. 2 of the 3 locks did this without any issue.
  5. The problem lock never responds to the configuration request. It occasionally responds to a 'refresh' or a 'lock/unlock' request. Anytime I hit "configure" I can't operate the lock unless I reboot the hub.

Steps to try to resolve this on my own, in the following order

  1. Put fresh new alkaline AA energizer batteries in the lock
  2. Disconnected and reconnected the battery pack in the lock
  3. Rebuilt my z-wave mesh
  4. Rebooted hub
  5. Tried configuring flaky lock again, no luck
  6. Shutdown hub, unplugged hub, waited 30 seconds, plugged hub back in
  7. Tried to configure flaky lock again, no luck
  8. Rebuilt z-wave mesh again
  9. Tried configuring flaky lock, no luck

Occasionally I can lock/unlock the lock following a hub reboot, but after 1 or 2 lock attempts the lock stops responding to commands and stops reporting it's state.

Firmware on the 3 locks (as shown on their back label)

  1. Front Door: MAIN_8.0
  2. Side Door: 0.8.0
  3. Garage Door: 7.1 (this is the problem lock)

Other elements of note: I have 40+ Z-Wave devices on my mesh, 95% are Z-Wave plus. I have 4 Aeotec Z-Wave Repeaters. One next to the hub (3 feet), one next to the problem lock (5 feet), one in between the hub and the lock.

Before adding all of the repeaters, all 3 of the locks worked fine on Wink. I added the repeaters and a few more Z-Wave plus devices to strengthen my mesh after coming to Hubitat.

Hopefully the new driver continues to work great for everyone, including those with Firmware 7.1. My next step will be pulling my hub out to the garage to reset and repair the lock, but I'm going to hold tight for a day to see if anyone with firmware 7.1 is experiencing similar issues.

EDIT: I just excluded, reset, included the problem lock. Then I did a Z-Wave refresh of my mesh, and rebooted the hub. At first the lock worked well, albeit a bit slower than the other two locks (even when the Hub was hanging from the lock during the inclusion - I ran a few unlock/lock tests and there was a few seconds longer delay with this lock than the others). I was able to use Lock Manager. But now my Z-Wave network is running super slow (5+ seconds to turn on/off lights and switches) and I am unable to control this lock again. I'm going to wait till tomorrow to see if the network settles down after the inclusion and refresh of the mesh.

1 Like

You might try excluding the lock from your mesh, and try including it again (with the hub near the lock of course) maybe it will join and automatically assign it with the new driver and configure properly. (just a thought)

This was also a recommendation shown here Aeotec Range Extender 6

Cancel this....guess you edited while I was typing....lol

lol all good - I appreciate the advice!

Of (good) note - when I included the lock, it did auto assign the correct driver and I was able to run a configure on it without issue (not needed, but did it as a test)


I seem to be in that same boat with the Schlage BE469 lock performing worse AFTER the updated drivers than before. I have 3 of the BE469 locks. I moved them from Wink last week.

They locked & unlocked fine from HE dashboard before the update for a week. I only put 2 codes in the locks from the Schlage keypad--NOT using HE...(code 1234 for me and 4321 for wife) (These are not my real codes--only example.)

The dashboard would lock & unlock them fine just by clicking on them--again, I did NOT put codes in them from HE using Lock Code Manager.

I do have 5 Iris Keypads & I used LCM to input arm/disarm HSM codes for my wife & I...they work fine....I have a code & my wife has a code...same 1234 for me and 4321 for wife.

After I had these locks securely paired in HE, I went back to LCM & decided to include the 3 locks in the list along with the 5 keypads and tried to update the 2 codes in to all eight "devices"--5 keypads & 3 locks.

I always get a "failed" on the "3 jobs pending" which I assume is the 3 locks, but the keypad jobs always work on each user, which is my wife & I.

This is where I am confused on how HE handles these locks.

Say I use code "1234" for me & code "4321" for my wife...I've programmed these codes into all 3 of the Schlage locks using the lock light up keypad itself--not HE LCM.

I can lock unlock the locks from the Schlage lock keypad & I can use the HE Dashboard to just unlock them by clicking on them--HE just asks me "Are You Sure?"...no code need if unlocking/locking with dashboard.

I also use the same codes in LCM for the 5 keypads...they work fine to arm/disarm HSM.

I'm not sure how the Schlage locks are supposed to function in HE if successfully paired & proper input codes working with no failed jobs pending.

If I used the dashboard to unlock the lock from HE, is HE supposed to ask me for the code "1234" BEFORE it unlocks assuming that the code was successfully input from LCM? This is what I don't know.

Also, am I NOT supposed to use the same lock codes that I used in the Schlage light-up keypad that I have in HE LCM?
Is this what is causing the failed jobs of inputting the codes into the locks?

Now, for the problems I have AFTER the driver update last night.

I can live with the failed jobs of the codes not being entered in the 3 locks. I was fine just using the light-up Schlage keypad to enter the house or if I'm in the house & just wanted to locks the doors by just clicking on the Dashboard tile for each lock to lock or unlock them and just answering YES to "Are You Sure?"...they DID work like this until after the update last night.

Of course the Schlage light-up keypad is working.

The problem after the driver update now is that when I click on the tiles for any of the 3 locks & I answer the "Are you Sure?"--HE just gets stuck on "Sending"--the locks never lock or unlock anymore with the HE dashboard.

I have ordered 3 of the Aeotec repeaters as suggested...should be in in a couple of days.

Again, I don't know if HE is supposed to ask me for for codes to unlock or not..and should the lock codes be input from LCM AND be different from the ones programmed directly into the locks from Schlage keypad?

LCM will not be able to retrieve or know what codes you program into the lock itself, me personally I deleted the 2 factory preset codes in the lock itself before using LCM to add codes (they come back with factory resets), I would imagine you (may) not have to but you would have to make sure (if possible like I said mine were deleted so mine started with code #1 of 30 when entering) that the code you create is assigned after whatever the latest code position # you have programmed into the lock. I do know from the lock's device page you can assign the code number, name, and "position #" from there.

The Dashboard tile has the same function as if you were to go to the lock's device page and click "Unlock" (Except Dashboard has the pop up to make sure you didn't accidentally touch the wrong tile and unknowingly unlock the door) I believe there is some other tiles you can use that can require a pin number before unlocking, but that too I don't use, but think it is available but the standard "lock tile" does not (search the forums for this if needed).

When you changed the driver did you click configure and verify in a separate log window that it did configure and retrieve/trace all 30 possible codes?

First thing to check if you see the "hour glass" for any length of time, is to go to the device edit page (where you changed to the new driver) and verify if the lock works or not there, if it does not the dashboard tile will not work.


@mojoman2600 - like you, I moved from Wink. I did exactly what @waynespringer79 indicates: a) unpair the locks from the previous controller (wink in my case); b) factory reset; c) pair to HE; d) delete the two factory codes using Hubitat and the device page for the lock; e) do this for all your locks; and f) add codes using LCM.

@waynespringer79 - was that pretty much what you did?

1 Like

Yes everything except I had to delete the two factory codes at the lock itself as LCM only shown ???? for each code so I just assumed it wouldn't delete from LCM, and did it from the lock itself

1 Like

I’ve been able to delete the factory codes from the lock device page by putting in the position number (1 and 2) for the two ???? factory codes and hitting the ‘delete’ button. That said I never went back and tried the factory codes after deleting them this way to confirm deletion. But, I’ve been able to add new codes to position 1 and 2 without issue after deleting the factory codes this way.

Just sharing some anecdotal info on my experiences with these tricky locks.


Update to my issue above - things seemed to have calmed down. My garage lock appears to still be connected and is updating so far. Hopefully it stays that way.

Unrelated, with the new 2.1.1 RM updates with custom conditions triggers I was able to remove the WATO app I was using to trigger rules when it is raining (I am grateful that WATO existed and was a happy user). Hopefully this frees up a few cycles on my hub that maybe helps the locks. Unlikely but who knows. :slight_smile:

2.1.1 was a great update. A few bugs that a hotfix will sort out, but loads of other goodness!


Just some more info to consider. I recently hard wired the locks power (no batteries) and noticed when I tried to pair the lock with the hub (platform it would usually only get to the initializing and get stuck. The occasional time it flashed a green check mark to indicate it completed pairing the lock would show state (unlock/locked) but not take commands.
I used an adjustable power supply and the results were the same using voltages 4-7 volts
I put the rechargeable battery pack back in and it paired and work first try.
I then tested removing the battery pack and hooking up the power again and the lock worked fine.
But the motor was slow sometimes.

I ended up putting in a rechargeable circuit with the rechargeable batteries and trickle charging the lock.

To power the lock I used the houses pre-wired security wire, an adjustable wall plug (set to 3 volts) and some copper plating to make contact sensors on the top of the door.
Then ran wiring down the edge of the door covered with weather stripping and into the lock.
So it is only charging while the door is closed.

The point being the locks appear very sensitive to the power they are being feed and how they act.

All 3 of my Schlage locks have dropped off and not controllable by HE so I'm just waiting for the Aeotec Randge Extenders to come in and then I'll start over and re-discover them all over again...a task I sure dread. :slight_smile:
If nothing else, I will just put them back on Wink.

Range extenders should arrive today or tomorrow.

I'm on version and I don't see the Schlage driver.

have you tried using different type of batteries?
using adjustable power supply the locks work read from 60-100% but never correctly pair.
I even tried a USB power adapter that only put out 1 power setting (I metered it at 5.5 volts) still did not pair.
but rechargeable batteries they paired perfectly.

Rebooted router again. Found driver.

1 Like

Could you please share your steps where you are looking for and not seeing the driver?

It should be on any device page driver drop down. Here’s a screenshot:

1 Like