SNZB-06P Zigbee pairing failures

C-8 Pro
Sonoff SNZB-06P Presence Sensor

I had 3 of these sensors operating in HE that were FWV 1003. In order to resolve some firmware issues I connected these device to Home Assistant running a Phoscon Conbee 3 and performed a firmware upgrade. I can no longer connect these devices to HE. I have reconnected them to HA and they're working, retrying them on HE I can't get past 'device found, initializing'.

I've rebooted, rebuilt, changed radio channel, lent the sensor up against mains fed repeaters, faced east and prayed, cursed and kicked, all to no avail.

From what I can tell the C-8 has had some fundamental zigbee issues. I'm not sure they've been fixed, but I'd like to know if anybody has any other ideas...

1 Like

you may have to un-pair them from HA and reset them .. to factory default.
And then try a repair HE. ( may even need to reboot HE )
I also found if you try a pair them really close to c8 it may or may not work.
sometimes i have to goto the far part of the house very far from the c8 to get something to pair.
IDK why .. but give it a try ..

thanks, they are being unpaired first; but I'm factory reseting as well.

yeah something is up with pairing on the C8. A long shot but try removing any custom drivers for the snzb-06p, if you have them. I had to pair my inovelli canopy module to my C7 instead of my C8 due to pairing issues

The (in)ability of the Hubitat C-8 hub to pair and stay connected with some new Zigbee 3.0 devices has nothing to do with the drivers used, no matter whether these are system or custom drivers.

having already taken the driver out (my own custom driver) in order to test this; I'd agree with krasimmir. the presence of the driver isn't making any difference in the hub's ability to pair.


What I should add is the devices have 'stopped' pairing with Hubitat. I've had them paired, but pairing and unpairing has put Hubitat in some state where It will no longer pair with them. I'll state it's the hubs fault on this as I've also done this with HA and the Conbee 3 and all the devices still pair/unpair quickly and reliably with them.

But rebuilding the DB, rebooting the Hub, restarting the radio, changing channels, signal strengths, none routing pairing, 'clear key' pairing, pointing east on a sunny day and any other alchemical suggestion isn't going to work; because I've probably already tried it. Don't let that deter you from suggesting it though, just in case...

I have over a 60 devices connected to the hub working happily. A very eclectic selection of manufacturers and devices from double sockets, power strips to temperature sensors. The majority of things on my mesh are mains fed, so routing isn't an issue. All of the items are zigbee 3.0 compliant. Over a dozen of them are Sonoff plugs and sensors. I have paired and unpaired those items without issue (not all of them and not at the same time). So, in this case, with these devices (or maybe generally, based on previous pairing comments), there is some 'trick' the hub isn't doing that it should be, in order to complete the pair.

Thanks Krassimir for clarifying. My thought was if the clusters were misidentified it could affect the pairing, but maybe the pairing is at a lower level and misconfigured driver only affects
functionality after pairing?

I had 5 bulbs paired and working on the C8 after moving from Smartthings. After an update a month ago they stopped working. I restored the config from a back up but that didn't solve my problems. I have reset the bulbs several times. I moved them all over the house and nothing. When I scan and do a repair, it doesn't work. The bulbs that do show up in my map, and show on, don't respond to any buttons or brightness settings. I am about to throw this expensive box out.

Sorry to hear about the issues that you have encountered. The problems discussed above are specific to the Sonoff mmWave sensor; your case is different... What model/make are your bulbs? Are they WiFi of Zigbee/Z-wave) ?

The things I am having issues with is anything using Zigbee. The Z-Wave products haven't had issues. I have Osram Lightify RGB, Osram Lightify White dimmable bulb, and 2 Ecosmart 60 watt bulb. I have upgraded the hub, restored it from a previous backup, disabled/enabled the radio, tried to rebuilt the network, and that hasn't worked. I also tried resetting the bulbs but they aren't picked up in pairing mode. I even pulled out a new bulb and it doesn't get discovered. I tried outside of the closet where the hub is located and across the house. I deleted one of the bulbs and after resetting it, the bulb won't pair again. I am open for any suggestions as I have a bunch more stuff to add to include a few of the sonoff switches.

They would have to be Zigbee 3.0? Assuming that, I would expect them to pair. But, in the absence of a 'driver', I would not expect you to be able to utilise the device for automation as you would not have any accessible attributes.

Unfortunately, here the problem is not the drivers, but the C-8 issues pairing and staying connected to some Zigbee 3.0 devices in certain configurations. Currently, there is no 100% working solution (other than using C-7 or other hubs).

1 Like

the bottom line is, it's fixable. it just requires 'Hubitat' to do it.

1 Like

When I set it up in February, everything worked great. After an upgrade I can't get it to work. So it has to code oriented.

Based on what I've experienced it seems like something in the hub or Zigbee chipset is retaining some info about the device or network address. I say this because I've seen my hub produce with a Zigbee scan old addresses of a previous network existing on that hub. I don't know how that could happen when my Zigbee network had switched it's PAN ID, but in the scan was the previous PAN ID from many months ago, even after many reboots and DB rebuilds. I don't know if that makes any logical sense but just sharing what I observed

1 Like

My observations are the same.

1 Like

How long has the C-8 been out? How long have you been observing these issues? Is it time this was sorted? @bobbyD thoughts?

Just so I understand I'm not going mad, I paired these devices back to Home Assistant (now v2024.4.1). it took about 20 seconds to get them all back in and reporting.

I'm not that familiar with HA as they seem to have things called 'quirks'. It would appear a 'quirk' is an adapter/driver and operates much the same as an HE driver. I can't find any information relating to HA's capability to pair with the device to determine if there is something peculiar about the sensor. But the presence of the 'quirk' would suggest a mapping operation is in place, much like a required Hubitat 'driver'.

So there is really isn't any reason I can see why HE shouldn't pair other than the hub being deficient in some way.

I don't want multiple hubs, and let's be clear I've paid a lot of money for this thing; is it unreasonable to expect it to work? @bobbyD

Mind sending me a private message along with your hub id? I'd like to take a look at your hub's engineering log for clues.