Schlage Locks - It's the built in driver, stupid

So, after a few years of my locks running fine, they have become completely unresponsive Tried resetting, excluding, including, adding repeatings, changing batteries etc, etc, etc They would work until a reboot, then nothing I would get reports from the locks, but NO action could be taken.

I then found an OLD driver for the Schlage locks, and wala, they work again

The "built in" driver is borked.

I used this 4 year old driver..


I haven't seen any issue with the built in Schlage driver. I have 3 locks and I haven't had to mess with them in a long time.

I am curious why this would work and the built in one would not.

1 Like

I have the older locks, they were solid until something changed, I'm assuming built in driver changes, BUT since they are not open source to the best of my knowledge, I can't really troubleshoot those.

With the built in driver, my older locks will report correctly, but will NOT act on any command. They only happens as I re-pair them. I have one lock I've never re-paired, and it's humming along fine, the other ones, nope, not with the built in driver. I applied this 4 year old driver, and flipped the knob, then immediately locked the darn things, which I haven't been able to do in a while.

The driver hasn't changed in a long time. The only change was about a year ago in 2.2.9 where "Added supervision encapsulation for improved reliability of commands to the following drivers when used with S2 on C7:" which I don't believe would apply to older locks.

1 Like

What version Hub are you using with the locks, C-5 or C-7?

I have 4 Z-Wave Schlage locks setting on a shelf that I replaced with zigbee ones because of numerous troubles on a C-7. They worked great for 2 years with a v.3 SmartThings hub, but when I migrated to Hubitat I could get them to pair and sometimes work for a couple of days and sometimes within hours issues. I just figured it had to do with the series 700 chip in Hubitat and what I think is in SmartThings, a series 500 chip.

The Zigbee ones have been perfect but are hard to find at a reasonable price.

That's probably about the right time frame. I had one go down a while ago, and had to re-pair it, it then quit working after the next reboot. I then swapped one with the "broken" one, requiring a re-pair, which now both don't work correctly. I've this last week moved a third working one, requiring a re-pair, and now it doesn't work after a reboot. They work great until the reboot, but after that they stop working.

With the 4 year old driver, they seem to not work initially after a reboot, but once the lock wakes for any reason, they work after that. With the built in driver, they just continue to not work.

It's an older C-5 hub, and I have 5 of the locks, which worked swimmingly until recently. The two that haven't been excluded and re-included work fine, but the other 3, done during troubleshooting, are bad at this point I'm guessing the problem lies in the Initialize or Install portion of the driver But no access to the actual driver and my developer butt has no idea.

My intentions are to take the code from

Munge it with the code from

Fix the issues, and there are issues with both, and test it thoroughly. After a few changes, both seem to work fairly well on the unlock/lock portion. Code sets are a mess in both, and they break Lock Code Manager.


So your Schlage locks haven’t worked for a year?

1 Like

The first one probably hasn't worked reliably for a year, YES, that's what I'm saying. If I re-pair them, they work until the NEXT reboot, then quit working. Trying to troubleshoot that particular one has spread the love to 2 other locks, so now I have 3 of 5 that don't work after a reboot, requiring a exclusion and inclusion to get them working again.

This is typically symptomatic of a poorly functioning z-wave mesh. If you have a C-5, have you examined your z-wave mesh using PC Controller (or Z-Wave Toolbox)? If you have a C-7, then this app from @tony.fleisher is very informative.

1 Like

I hate to be that guy, but NO, this is NOTHING but a cop out by the Hubitat crew. If it was a poor mesh, then the 4 year old driver would also not work, but it does.

The built in driver is BORKED. If I load it, after a reboot the locks fail (the locks that have been re-paired in the past year)

I can take that same lock, and just change the driver to this one, save the device, and all of the sudden locking and unlocking work again on those locks, I don't have to do anything else.

Currently though, this 4 y/o working driver does not support Lock Code Manager, and it makes that fail, so working on updating it currently. I'm just trying to get it's functionality to work, it's also exposes WAY more options than the BORKED built in driver.


It will be interesting to see what you end up in terms of your customized driver. I'm sure some Schlage users may be interested in an alternative driver to try out.

I have an older Schlage BE469NX plain Z-Wave lock that I have used on ST (three years) and on HE (three years) w/out any incidents. I'm using the built-in driver on HE. I mean literally zero incidents on HE (or ST for that matter). Joined the hub fine, works 100% of the time, never burns batteries, etc. So the built-in driver isn't "borked" from my perspective, far from it. No idea of course why you're having issues.

Which model lock(s) do you have?

I don't understand why you think Hubitat is "copping out." They decided that they didn't want to support Schlage locks, have communicated that decision to the community, and removed them from their supported device list. That means if we still decide to use a Schlage lock on their hub, what happens is on us.


As long as you don't exclude the locks, you will be fine, but if you exclude and include, they will start to fail. Mine are also BE469NX. They all worked until I excluded and included them. Now 3 of the 5 don't work, the other 2 hum along nicely. I put all of these locks in place in 2019, and didn't start having issues until this past year.

The cop out is the standard answer of "It's a Mesh problem," when 100% it's not a mesh problem, it's a driver problem, as I think I've illustrated. It's not a device problem, it's not a network problem, it's not an interference/SNR/RSSI problem, it's a DRIVER problem. Adding repeaters, moving the hub, etc, etc, etc, isn't going to fix it, code is.

And my experience and previous job was in their field, I worked as a solutions architect for an IIOT (Industrial Internet of Things) company called Trilliant Networks. I currently am a solution design lead and senior engineering manager for a top 8 Fortune 500 company. My college focus as a CpE (Computer Engineering) graduate was automation, robotics and wireless communications (specifically focusing on Zigbee before it was common, think stupid little Xbee modules.) I'm pretty technical.

My biggest complaint right now is that the driver code for this device is locked away, and they have pretty much indicated that it's abandonware. Open source it and release it, I'll fix it.


I have a Schlage JBE109 Deadbolt, and would love a good driver.

I would like to say THANK YOU for this post.

My Schlage lock also just randomly stops working as well. Same symptoms as OP. This last month, the lock would update it's lock/unlock status on our dashboard just fine, but I couldn't control it.

I just installed the drive he posted in this chat and presto chango! The lock instantly started working again. Didn't reboot, didn't z-wave repair, and didn't exclude and include.

The driver was the first and only thing I did, and it worked immediately afterwards. Interestingly enough, the lock now starts to beep 3 times before it unlocks/locks, which it has never done in the that's pretty cool.

Thanks again!

1 Like

@bravenel does any Hubitat staff want to comment on this?

This driver will do the basic lock/unlock and configure. I'm still having a time with lock code management, but again, the basic lock/unlock functionality is here.

My front door lock has stayed active and working since December 5, so it's definitely an improvement over the built in Hubitat driver. It has endured MANY reboots since then, due to Hubitat version updates, which was the problem since I started having it.

1 Like

The beeping is the setAlarmMode. Apparently you click it to cycle through the modes. Off doesn't beep.


I added AlarmMode and AlarmSensitivity as ENUMS and verified they work.


I got everything working last night. It's all spaghetti code at this point, so I'll clean it up and commit it to my GitHub account tomorrow.

Integration with Lock Code Manager works, alarm and beeper modes work, lock and unlock work, encryption works, and best of all, the locks survive a hub reboot.