Schlage Locks - It's the built in driver, stupid

Congrats on your success...if I ever have any issues w/my Schlage BE469, I'll know where to look. :slight_smile:

Very much looking forward to your update. I have 3 Schlage locks on a shelf that worked perfectly with SmartThings but never worked right on Hubitat. I had to replace them with Schlage zigbee versions of the same locks.

Anyway, I will pull one of them down and test your updated driver. I doubt if I replace the locks in the doors. but I was planning on setting up so rules to unlock, lock, etc several times a day and even manually use the keypads. I also want to move them around to different locations around the house to see how the z-wave signal responds.

Good job on this. My fingers are crossed all goes well so I will then know I have backup locks.

1 Like

I have updated it. The code is still very cludgy and hacked together, but it is solid and works. As I get more time, I will clean the code up, but for now, it's a working driver. I hope this helps out with others.


Unfortunately, this did not work for me. My Schlage locks are the BE469ZP models, and this driver does not work on my locks. I am saddened by this but do hope those with the NX models will have success.

1 Like

Those are z-wave plus. If the firmware is 7.10 or newer they should work. Did you attempt pairing within 2 feet of the hub?


I have weizer smartcode 5 z-wave lever locks. They were using the Schlage driver and all of my locks have stopped working in the last couple of months. They worked for a year without any issues.

I tried excluding them, resetting them, everything. I just gave up and flipped the auto lock dip switch inside and removed them from our hub. Seems I may not be alone here.

I'm running 3 be469's no prob. That said, After you repair them, use the generic z-wave lock driver then hit configure and see if they respond

1 Like

I'd love to try but they won't even pair now, they just sit on initializing. I added a different device to confirm it's not the hub and it paired right away.

I would suggest excluding them before trying to include.


Can you post your entire z-wave details page?

1 Like

Hmm... You're stuff looks a bit spread out. You might want to add some beaming repeaters to your mesh. Can you pair the lock within 2 feet of the hub? (before you do, shutdown the hub from the settings menu, unplug for 2 mins and power back up. This will clear the radio)

One of the doors is right next to the hub. That being said, I have a breaker tripped with node 31 and 32 currently offline. Will try again once that is resolved (this afternoon hopefully)

I did try powering off and unplugging the hub for a couple of mins after I got the ghost devices/half paired locks removed.

You may need those nodes online to pair properly so your mesh is whole. That said, 2 feet or less is usually the recommendation as some locks use a whisper mode for security exchange during pairing. Also factory reset the lock.

1 Like

I'm having this same problem for my lock that worked swimmingly on ST. Now all kinds of problems under Hubitat. Pairs just fine as others have said and they report lock change status just fine, just can't issue controls to them. I tried the very old school driver at the top of this discussion without any luck. Also tried the Frankenstein-ed driver code =) as well. Same end results. There was talk about using an Aeotec repeater on various discussions around Schlage locks. Has anyone tried this recently that has suffered from this issue?

Does it open/close from the device page?

It isn't clear if you tried the built-in driver or just the community ones?

You do need repeaters near these locks, they don't act well if there is not a repeater close by. It doesn't necessarily have to be the Aeotec, nor even a dedicated repeater. Light switches, outlets, and most other line-powered devices can act as a repeater. The repeaters as well as outlets are often helpful as you can move them around (unlike light switches) to try and optimize signals.

A weak mesh and ghost devices can cause the issues you are seeing. I would start by posting your Z-wave details page in full. (Settings tab, Z-wave) It will help us to see if there is a basic mesh issue. Please include all columns and rows of this table, preferably using a computer instead of your phone. Post multiple screenshots if necessary to capture all devices.


I'm able to successful use the legacy driver 'Z-Wave Schlage Touchscreen Lock' by 'garyd9' . Code looks like it's a port from SmartThings back in 2014 (scroll up ) and lock/unlock via the Device control page however this will only last for a short few days before it stops working again. When it does stop, it will continue to report manual physical lock/unlock, but I can't issue hubitat commands anymore. Zwave Repair reports fine the first few days and eventually identifies the lock as needing repair..and eventually unsuccessfully. I can remove the battery for a few minutes and restore which will repeat the temporary working cycle.

The zwave details tells me it's directly connected to the C8 hub. I have a number of ZWavePlus devices which I know acts as a repeater, however the page shows I am connecting directly to the Hub at ID 01

What firmware is it? Pretty much anything below 7.10 is a crap shoot


Could you post all your Z-wave devices (the whole table) please.

It really sounds like a mesh issue, weak signal, lack of repeaters, repeaters in the "wrong" spot, etc.

1 Like