Ring keypad v2

I have tried both the built in driver as well as the community driver.

OK so this is where I stand now. I have the keypad added to Hubitat. I can see it in my device list and my zwave details. I added the keypad to hubitat safety monitor.
In the device details page, I can arm away arm night and disarm the keypad and HSM also changes the status. And this works the other way as well. If i change the status in HSM the keypad recognizes it.

But it the keypad itself doesn't let me arm or disarm. I have added the code to the keypad and can see it in the details page. But if i type in the code and press the arm away button nothing happens. What trouble shooting steps are there to try and get the keypad to recognize codes and arming/disarming.


I ran into the same behavior when I got my first Ring Keypad. I actually thought I was missing something about how the keypad was supposed to work.

It is some weird connection issue, where the keypad and hubitat think they are happy together but are not. I went back and forth between S2/no S2, smart start/classic, etc. Eventually after pairing it showed the secureInClusters and everything started working.

I had a lot of trouble with it, and did all sorts of things that I dont know if mattered or not. But I remember unpairing the keypad gracefully from hubitat, resetting the keypad back to factory default, rebooting hubitat, pairing the keypad via smart-start with s2, and then i had to go in and finish with pairing something-or-other that didnt go all the way with smart-start (smart-start was just sitting/spinning/waiting for something). I have three keypads and paired them the same way, they've been solid for a year or so. HTH.

I think @bcopeland the ring stuff NEEDS to be paired at s2 for it to work correctly. I know my Ring sensors did but I think the keypad was an especially special case.