Ring keypad v2

Adding to what @brad5 mentioned, the community driver can enable/disable the proximity sensor... If it is constantly being tripped and sending events, I could see that being a major battery drain.

Great point, but I'm not sure the proximity sensor sends events, even with the community driver.
But it does cause the backlight to turn on, which obviously uses some power. My two are both in pretty big traffic areas though and I only charge these guys every 6 months or so. I even use the strobes on mine as notifications of various events, and they still get really good battery life.

@drlondon how's the health of your zwave mesh?

I am new to diagnosing zwave products. How can I check?

The easiest way is to go to settings / zwave details using a full-size screen (not a mobile device), take a screen shot (please don't copy/paste) and post it here. I'm sure folks here will take a look and help you out. There are a couple of things to look for...

(1) any devices with no route back to the hub
(2) devices that have re-routed many times (since last reboot)
(3) devices with excessively long response times
(4) the number of repeating devices scattered around, and whether any of them are actually repeating
(5) devices that the hub has paired but not identified, or that have a "discover" button


Wish there was an automated way to remove the devices that fits these things to look out for and notify.

Im having the same problem. I refreshed and removed all gost i only have 3 zwave devices. Is a zwave reset the only solution?
My hub finds them but says ( Looks like you’re having trouble including your device. Please exclude it or perform a factory reset on the device before attempting to include it again. If the device still won't include after exclusion or factory reset, please review the best practices for building a solid Z-Wave mesh.

And im two feet away from the hub.
Any help would be greatly appreciated.

I’ve had the best luck by excluding them, and then using SmartStart from inside the mobile app to include them.

Reset the keypad and use smartstart

1 Like

I keep getting ghost when painting and having trouble removing one. Is there anything else I can try. Also is there a way to force remove a ghost.

Pull the batteries from the keypad, shut down the hub via the settings menu. Unplug power to hub (at wall not hub) for 5 mins and power back up. On the ghost line (or any ghost line, you don't want multiple ghosts) click the refresh button until the remove button appears and click remove and wait

Finally got it to show up in devices using smart pairing. Im still not showing any activity in events when using the keypad though. Im thinking it might be the driver.
Do you know or can you recommend a driver that works?
Thanks for all your help.

Switch to the Ring Alarm G2 driver then click save then click configure

Im not sure whats going on here.
If I use smart start it finds it ,puts it in devices but doesn't pair correctly ( no logs from the key pad and adds a ghost every time).
When I use find devices. It finds it but cant include. Anything els i might be missing here?

Did you switch to the Ring Alarm G2 driver, click save then click configure?

Yes it was the right driver installed when I used smart start

Im starting to think the keypad might be bad.
I ordered two. Ill give the other one a try.

Historically (in these forums) the ring keypads have been very finicky to pair properly - some claim better success with Smart Start, I personally was successful with a standard pairing. Kind of have to keep trying until it pairs right, it seems.

Once fully paired, with bidirectional comms, they're rock solid though.

1 Like

My experience as well. A pain to get included, only smartstart will work for me, but once they're in they're solid. They are FLiRS devices though so beam repeaters are important.

I can't get the Ring Keypad to work. I think I got it paired with no ghost devices. I used the Ring Community Driver. All I want it to do is when I type in my code and press arm it puts HSM into armed away mode. And when I come home and put in my code and press disarm it switches HSM to disarm. I don't see anything at all in the logs when I press any buttons. I have removed it and reset it a few times. I used smartstart to install it. I'm at a loss as to why it won't work at all.

What driver are you using?