Ring keypad v2

Got this to pair..
Going to device settings I can press home away disarm and the keypad gets the event.

Tried to set a 4 digit code and arm. But the keypad is not recognizing the code.

I have not connected the keypad to HSM yet...

You may need to setup the keycode in the driver or with Lock Code Manager.

You may also need to reset the Keypad to factory and include again. I had to so that with mine to get everything working.

Just removed, factory reset.
added Lock Code Manager
repaired.
added a new code from "Lock Code Manager"
same issue, I can arm disarm from the decvice settings. but I can not use the keypad with the code to arm/disarm...
I also added the keypad to HSM..

I have the latest firmware on habitat 2.2.7.128

What do you see in logging for the device when you you punch in your code and push the mode button to activate.

Just to confirm you do have a c-7 version of the hub, used SmartStart to add the keypad, and didn't change any of the security options.

On the device page do you see the programed code listed.

1- I see no loggs of any sort when I press the keypad. However, if I arm from HSM I see logs. Also when HSM arms the status on the keypad changes (using machine rules)
2-I have C7 with latest firmware.
3- I did not use SmartStart, only used direct Z-wave pairing to the C7 hub
4- I see the lock code on the device settings.

3 is likely your problem. The ring devices are finicky about how they pair and what kind of security they use. If they don't get exactly what they expect then they will not work.

So reset back to defaults again. Remove from hubitat. Scan the qr code for smart start and try to re-pair with smart start. Do not change any of the security settings that pop up.

Ok this is getting frustrating..
Factory reset keypad,
Scanned through smartstat then it said failed, pending..

Removed. Scanned then factory reset keypad. Same thing..

Not sure why it's not being added. I can always add it through c7 z-wave directly..

I'm stuck..

Thanks for help

Make sure the keypad is removed from HE and that it didn't leave any z wave ghosts in the hub.

When doing the factory reset make sure you are holding the button in the pin hole for like 20 seconds.

I finally got it working.
it was the ghost z waves.
reset my whole hub z-wave.
pain .... It reminded me of windows 95 IRQ days.

Thanks for the great help....

1 Like

Glad i could help. I would add doing those ring devices with Smartstart from the very beginning has been pretty painless for me. On the other had trying to get stuff added like above has been a pain. I went through the same pain with my keypad which is why kind of had the ideas of how to help.

Just remember for any Ring device especially before you even pull the battery tab or start pairing to add them to smartstart. That generally make things go smoother. I think in about 30 devices i had maybe 2 be finicky and require messing around with.

1 Like

Why did you reset your z-wave radio? Did you go through the normal ghost removal procedures?

1 Like

mavrrick58 , do you have your keypad paired in hubitat and the ring alarm . if so could you walk me through how you did it ?

The ring keypad can be paired to Hubitat or to the Ring alarm hub, but not both.

Is I possible to you virtual switches to sync the ring keypad use In hubitat to the ring alarm ? The reason I’m asking is I recently purchased the ring alarm and I would love to utilize the 24 hour support but I have way more motion and contact sensors in hubitat. I would like be able to arm with the keypad and it arms the ring alarm also .

I use the ring keypad with HSM but I don't use the Ring alarm. There is a community integration with HE that may help. Not sure if it allows you to use HE sensors to trigger the Ring alarm but there might be a way to get it to work...

Ok thanks for your quick responses .

Just got a Ring Keypad. I guess I made the mistake of pairing through Devices. Since excluded it, and tried SmartStart, it just sits on "pending". Multiple factory resets on the keypad, exclusions and reboots on Hubitat. Also sits on pending. Any advice?

Still "pending" in SmartStart, but showing up as a device. But odd behaver, I can send to the keypad, but nothing back to Hubitat when I press buttons on the keypad.

If i press a button I get this:

java.lang.IllegalArgumentException: The JSON input text should neither be null nor empty. on line 419 (method parse)

Try doing a graceful shutdown of the hub. Then pull the power from the wall to fully reset the radio. Let it sit for 2 min. While the hub is off remove all devices from SmartStart. Now plug it back in and add it back to SmartStart. Then reset the keypad. Make sure you take all the defaults for the securiry options.

You should also check for zwave ghosts just in case and resolve that if any ghosts exist.

1 Like

Download the Hubitat app