Ring keypad v2

Wish there was an automated way to remove the devices that fits these things to look out for and notify.

Im having the same problem. I refreshed and removed all gost i only have 3 zwave devices. Is a zwave reset the only solution?
My hub finds them but says ( Looks like you’re having trouble including your device. Please exclude it or perform a factory reset on the device before attempting to include it again. If the device still won't include after exclusion or factory reset, please review the best practices for building a solid Z-Wave mesh.

And im two feet away from the hub.
Any help would be greatly appreciated.

I’ve had the best luck by excluding them, and then using SmartStart from inside the mobile app to include them.

Reset the keypad and use smartstart

1 Like

I keep getting ghost when painting and having trouble removing one. Is there anything else I can try. Also is there a way to force remove a ghost.

Pull the batteries from the keypad, shut down the hub via the settings menu. Unplug power to hub (at wall not hub) for 5 mins and power back up. On the ghost line (or any ghost line, you don't want multiple ghosts) click the refresh button until the remove button appears and click remove and wait

Finally got it to show up in devices using smart pairing. Im still not showing any activity in events when using the keypad though. Im thinking it might be the driver.
Do you know or can you recommend a driver that works?
Thanks for all your help.

Switch to the Ring Alarm G2 driver then click save then click configure

Im not sure whats going on here.
If I use smart start it finds it ,puts it in devices but doesn't pair correctly ( no logs from the key pad and adds a ghost every time).
When I use find devices. It finds it but cant include. Anything els i might be missing here?

Did you switch to the Ring Alarm G2 driver, click save then click configure?

Yes it was the right driver installed when I used smart start

Im starting to think the keypad might be bad.
I ordered two. Ill give the other one a try.

Historically (in these forums) the ring keypads have been very finicky to pair properly - some claim better success with Smart Start, I personally was successful with a standard pairing. Kind of have to keep trying until it pairs right, it seems.

Once fully paired, with bidirectional comms, they're rock solid though.

1 Like

My experience as well. A pain to get included, only smartstart will work for me, but once they're in they're solid. They are FLiRS devices though so beam repeaters are important.

I can't get the Ring Keypad to work. I think I got it paired with no ghost devices. I used the Ring Community Driver. All I want it to do is when I type in my code and press arm it puts HSM into armed away mode. And when I come home and put in my code and press disarm it switches HSM to disarm. I don't see anything at all in the logs when I press any buttons. I have removed it and reset it a few times. I used smartstart to install it. I'm at a loss as to why it won't work at all.

What driver are you using?

I have tried both the built in driver as well as the community driver.

OK so this is where I stand now. I have the keypad added to Hubitat. I can see it in my device list and my zwave details. I added the keypad to hubitat safety monitor.
In the device details page, I can arm away arm night and disarm the keypad and HSM also changes the status. And this works the other way as well. If i change the status in HSM the keypad recognizes it.

But it the keypad itself doesn't let me arm or disarm. I have added the code to the keypad and can see it in the details page. But if i type in the code and press the arm away button nothing happens. What trouble shooting steps are there to try and get the keypad to recognize codes and arming/disarming.


I ran into the same behavior when I got my first Ring Keypad. I actually thought I was missing something about how the keypad was supposed to work.

It is some weird connection issue, where the keypad and hubitat think they are happy together but are not. I went back and forth between S2/no S2, smart start/classic, etc. Eventually after pairing it showed the secureInClusters and everything started working.

I had a lot of trouble with it, and did all sorts of things that I dont know if mattered or not. But I remember unpairing the keypad gracefully from hubitat, resetting the keypad back to factory default, rebooting hubitat, pairing the keypad via smart-start with s2, and then i had to go in and finish with pairing something-or-other that didnt go all the way with smart-start (smart-start was just sitting/spinning/waiting for something). I have three keypads and paired them the same way, they've been solid for a year or so. HTH.

I think @bcopeland the ring stuff NEEDS to be paired at s2 for it to work correctly. I know my Ring sensors did but I think the keypad was an especially special case.