(Resolved) Moving from Wink - Bali/Somfy Shade Woes in Hubitat. Help!

I spoke with Spring Fashion support (Bali/Graber) one more time. This time it was a nicer support personnel. Still couldn't get any resolution but sharing some information on here for anyone reading this future. He basically said Shades have two way communication, so hub/driver plays a big role. Wink is also no longer their supported hub ; he recommended to get their Graber Virtual Cord Hub (that being the only supported hub for Bali/graber). I am not sure if I want to drop another 200 on another hub and just wish I could get some help updating/fixing the driver for HE.

I looked into the 'dimmer post' but couldn't glean much. @ZebraBlinds are you able to provide some assistance please?

1 Like

I wonder if @bcopeland would be willing to look at it. He seems to work magic with lots of these Zwave devices.

2 Likes

@yashvind Thanks for the Tag

The issue with the shades stopping at random positions is firmware related and you need to check the version you are on. If it's below 11.03 what essentially happens on most hubs and sometimes on wink as well (you were just lucky) when a command is sent and the shade is in motion or just about to start motion from a command it already received or it decides to repeat another z-wave command in the z-wave network a bug in the firmware caused the motors to think they are overloaded with power and forced them to stop (with a red light on the motor) to prevent damage to the motor. When this happens it can be any where from mins to an hour for them to respond again directly to the hub or if you move the shade the opposite direction using the remote and try again it will work.

I find that SmartThings and Hubitat tends to repeat commands in the z-wave network which is when this happens.

Pm me if you need further help. Just double check the firmware version on the shade first.

1 Like

I sent you a PM with some details but posting it here as well for benefits of others who might have the same problem. My firmware is 11.2. So that would explain the issue. The shades act exactly the same way you described.

Called up Spring Fashion again to see if I can get access to new firmware file and they claimed that the motors have not changed or the firmware on them in last 4 years. I don’t think the person knew what she was talking about. She initially didn’t even know what firmware is!!

1 Like

replied to the PM

1 Like

I had the same problem when I was using Wink but then created a shortcut rule within the Android Wink app to raise Left, Right & Center shades separately and also to various degrees of openness: ie, 25%, 50, % etc. Then included a robot for ALL shades : open, closed and then at 25%, 50% and closed. Finally then used IFTTT to be able to incorporate the Wink shortcuts so that you can use Alexa devices via voice by saying: Alexa, TRIGGER all Blinds, UP-DOWN-50%-25% etc. Should be able to use Hubitat to get the same results thru IFTTT.

I think I finally have a solution with the help from @ZebraBlinds. No need to involve IFTTT. I am still testing it for stability but so far so good (finally). I will post an update and summary for community member's future use by this weekend.

6 Likes

Watching! I have the Somfy AutoViews on my blinds as well.

Also watching. I have the exact same issue, just not sure about the red light. Never looked.

Update for my issue. I did notice a solid red light on the blind in question after a failed move. Interesting part is if I use the AutoView Multi-Channel remote to command a mive right after a failed Hubitat move, it works as expected.

1 Like

Sorry for the delay folks, just haven’t be able to find time to document my summary for the fix. But in the nutshell, after upgrading shades to the latest firmware, it’s been stable 99% of the time. How to get there, will explain soon.

2 Likes

I look forward to your information on the solution. It really surprises me that there is not a fine tuned Bali/Graber driver for everyone to use. The generic or even using the dimmer settings on others is not an acceptable option for most.

@yashvind and @ZebraBlinds,

My Graber shades have firmware version 11.2

Is it possible to get and apply the updated firmware?

I am experiencing all of the behaviors you have described. Random positions, red light, ignoring commands, etc. Somewhere along the way we figured out reversing the requested direction and letting the shade open or close would reset its ability to accept commands.

I've wasted many hours in the Rules Engine and groovy trying to figure out why my shades and virtual shade group driver were not working.

I don't recall ever having issues when they were on the Wink Hub, and the Graber remote works flawlessly, so I assumed the issue I've been having over the past couple of months was related to my code.

Thanks

I just updated my original post with details. Please give it a read.

3 Likes

Where did you find firmware code for your shades? I too have Bali/Somfy shades with these exact same problems. Complete hit or miss where it stops and then I get the red light. Other times it works.

The first post above said to contact the Zebra Blinds rep. That rep is just a couple posts above...

2 Likes

Thank you, seems like I need to wait to PM a user here as I just signed up today. I recently installed this Hubitat as part of a total renovation and I've got a lot to learn programming. I installed that custom z-wave driver mentioned and confirmed my roller shade firmware is 11.2

I got a few (30-ish) fairly new bali z-wave blinds that I'm moving from a flaky c-4 to a new c-7. Had all sorts of flaky open/close/partial/nothing happens/etc. issues on the c-4 which I attributed to it having some sort of fundamental problem (every device having problems, not just blinds)...scrambled db likely. Rather than mess with it forever I bought a C-7 and am in the process of transfering things over slowly.

So on the new C-7, I've moved over 6 blinds last week and have had hit or miss issues. I wonder if anyone here has suggestions? Firmware of the blinds is 12.1. I've tried both the community driver from @ericvitale and the generic zwave blinds driver but still get missed close/open calls (i.e. nothing happens), very slow to start to respond, etc random fun. I have noticed the on/off seems to work better/faster than the open/close calls from the device page. RM4.0 rules don't seem to work well regardless of which call I make. This seems true for both drivers. I've done nothing to group them either with the multi-remote from bali or HE, just list them all in RM as on/off as approp.

Thanks in advance for any insights!

My understanding is that the issue is with 11.2 or lower firmware versions. So if your are on 12.1, not sure what could be the root cause! @ZebraBlinds any insight?

I have about 25 Bali blinds at the moment and I have similar problems. They were bought in two separate purchases a year apart. Because of the timing, I got two different revisions of their blinds with different firmware. 85% of them work great and consistent but there are several that are flaky and it is almost always the same ones. The odd thing is the problems occur on both revisions of the blinds. Its not distance or other basic things as far as I can tell. I have PM @ZebraBlinds numerous times but I had no luck in getting a response for the new firmware. I want to purchase more but I do not want to add to the mix if the issues can not be resolved. When I use the Somfy ZRTSI driver, I get the best results.

Download the Hubitat app