(Resolved) Moving from Wink - Bali/Somfy Shade Woes in Hubitat. Help!

I was thinking further on why does my morning rule work but not the evening one! Then I thought of the distance from the hub of all the shades. On inspecting both the rules, I realized that the order of shades in the morning rule is closest first and then the farthest (my Sunroom is closer than Breakfast area). I can't seem to order the blinds in the rules, so I split the evening rule in to two parts - to first trigger Sunroom blinds and then the breakfast area blinds with a delay. Holy Batman, that seem to have worked!! At least one trial that I did.....

I will test it more tomorrow (got yelled at 'cos kids were already in bed) but fingers crossed.....

Morning Rule


Evening (New) Rule

1 Like

Ok, that was a premature dance on my part. Gremlins are back :frowning:

I am going to move my HE to spot closer to the blinds as a new step. :expressionless:

Just a guess since I have Graber and not Bali but it's possible you have an old firmware. Not sure how to check firmware with HE but the old firmware caused random position on Smartthings and Hubitat. Not sure why but I didn't have issue with Wink either until I moved them to Smartthings. Pay attention to the indicator light on your shades when they stop at those random position. If they turned red then it's a firmware issue.

1 Like

Thanks. How do I update the firmware?

Get the firmware from your provider and use this below to update. Saying that, if you don't see the red light on your shade when it stopped. Then don't waste your time on the firmware. It's something else.

Thanks. I have about 20 shades, definitely see red light on few of them.

OK. I moved the HE within 15 -20 feet of direct line of sight of the blinds, repaired the network. It worked as intended once and then back to erratic behavior. :face_with_head_bandage: :cry:

Really frustrated. I have been trying to follow a couple of other threads, and tried to use another driver but that driver is throwing errors. Not really sure what else I can do!! In addition to getting HE, have sunk in quite some money in getting Lutron hub, repeaters, new z-wave switches. I might have to go back to using Wink (which I really don't want to) but proper working of blind automation is a must.

I haven't reached out to Hubitat support yet though, should that be the next step?

Thanks

What is the software version of your hub?

2.2.1.115

Upgraded to 2.2.1.116. It took a few tries over a week or so to get it to upgrade it from 2.2.1.115, finally it completed successfully yesterday.

I have been mucking around quite a bit and starting to dabble into groovy. Coding has never been my forte, but I was able to do some tinkering that has somewhat made the situation better but not fully resolved. I guess something is better than nothing.

(I wrote to Hubitat support, who after a few days of no response, closed my ticket with a message that my case has been handed over to engineering..... radio silence thereafter!!! Well, I will vent over support some other day.... Unfortunately, I am beyond my return date for both Hubitat & Lutron Hubs, otherwise, I might have taken that step because I was getting tired. Anyhow, I am still here, so onwards & upwards).

I am primarily now using a modified version of a driver from Eric Vitale

  • I essentially removed some of the Dimmer specific code.
  • To use devices running this driver in the Rule Machine in Hubitat, one needs an ability to set 'Position'. In contrast, the original code was referencing 'Levels,' so I changed 'Level' references/routines to 'Position' so I could now set the shade level/position using HE Rule Machine. Also updated custom scenes to 'Custom Set position' Commands.
  • I got the original driver idea from driver posted by @DeveloperDavidB's and extended @jdntx's Parse routine on this thread Bali Autowave Shades - Erratic Behavior

This driver seems to be doing a much better job than Generic Z Wave Shade driver. Some shades still don't close from a partial open position to fully close but definitely better than the original driver. I just hope that @hubitat support sees this and helps incorporate this in the stock driver and make it stable. I think there are enough of us with these shades that, this needs some official love.

Here is Link to the updated driver:

This is a partial solution (partial because pop-corn effect still occurs on some shades randomly) to my first two use cases:

Use Case 1: Open Shades 50% in the morning (Implemented using Rule engine)
Use Case 2: Close Shades entirely at night time (Implemented using Rule engine)

For the next two use cases, I created two virtual devices. I then created rules (for UC 3 & 4 respectively), for which the trigger is 'ON' state for the respective virtual device. Now I can ask Alexa to turn on this virtual device, which in turn triggers the rule. Here is the screenshot:

I see that you discussed firmware. Had you gotten anywhere with that?

I called Spring Fashion support (Parent company for Bali/Gerber). There is no firmware update for the blinds.

have you reached out to the developer of the community driver for assistance with the drivers you are trying? Maybe they'd want to know about the errors and offer some help?

Reach out to zebrablinds.com
Maybe load up the z-wave updater driver and see what firmware version you have for the blind.

Thanks. I’ll try that. I thing to consider though is that I never had any issue with blinds with Wink. Like ever! So given that, I don’t yet think firmware is culprit here. I feel there is some command that Wink sends to blinds that Hubitat is not being able to send.

Try conveying your wink hub to a repeater and see if that helps the issue

Ok, added Wink in as a repeater. No change. I don't think it is a signal issue because Hub is only 15 feet away from blind. Also, I have tried adding repeaters as well, which didn't help and neither did adding Wink to the hub. I think it is a driver/command issue.

I think I have tracked down the actual product on Z-wave alliance site. Bali & Graber, both are from the same company 'Spring Fashions'. This is the product link and here is its Z-Wave Network Management Instructions. I wonder if the following recommendation is not baked into the driver code?

The Wakeup command class should be configured by a hub when the remote is joined to a Z-Wave network. A WAKE_UP_INTERVAL_SET command should configure the NodeID at a minimum. The Wakeup interval can be configured to any value from 6 minutes to 25 hours. Recommendation is to leave the interval at the default of 12 hours to maximize battery life. The remote will wake up every WakeUpInterval and send a WakeUp Notification command as well as a battery report to the NodeID assigned with the Interval Set command. The WakeUp Notification will be sent within a few minutes of power being applied to the remote and then once every Wake Up Interval. A Wakeup Interval Capabilities command will inform the hub of the default, minimum, maximum and step size of the Wake Up interval.

@april.brandt Any additional recommendations? I tried emailing Hubitat support but didn't really get a response. How do I get some attention from one of their support engineers?

HE is probably not going to reply to your request, but will look at the driver to see if improvements could be made.
You could try some of the suggestions in this post? Or reached out to the link posted above?

2 Likes

Download the Hubitat app