Remove ghost device

I've always killed power on the original device so I don't have any experience leaving them powered myself.

1 Like

that does not work either...
I have it with a dimmer too.
in both cases, with our without power, I only have "refresh" and "Discover" can't remove them

You could try waiting a bit longer, and Remove might appear on its own. (But if you haven't tried Refresh and waiting a few seconds or more, then trying again if needed, I'd do that first.) I believe this is supposed to happen on its own after the device misses a certain number (maybe two?) of wake-up intervals if it's a battery device. The default with most Hubitat drivers sets this to something like 12 hours (or is it 24...), so it might take a day or two. But Refresh should work too, so it's mysterious if it doesn't.

You could try powering down the Z-Wave radio. Go to Settings > Shutdown to shut down the hub. Then, after the LED on the hub turns red (to indicate a complete shutdown), completely remove power for at least 30 seconds or so. Finally, re-connect power to let the hub reboot. (That middle step, removing power, is crucial to restart the Z-Wave radio, which is unaffected by a regular reboot or shutdown.) Then, try the refresh/remove thing above again.

If that still doesn't help, @danabw has a good write-up on how to use a secondary controller to remove "ghost nodes." That's rarely necessary nowadays (the above should work), but if you have a secondary controller, it's certainly an option...

1 Like

hum. those ghost devices are there for at least 4 days now. (the schlage door lock and a dimmer)
I also shutdown the hub and moved it somewhere else which was easily over 30 seconds to be unpluged. I hit refresh a few times after that. still no remove button. :frowning:

Check out this thread, the only friends in your case are time and patience. Also, if I were to guess, the Logs will tell you that the devices are no longer in failed table, so they cannot be removed.

1 Like

If you don't get it worked out from Bobby's link...

1 Like

ok. now I have the dimmer that allowes me to click remove but it does not remove it. prety frustrating

May take multiple tries on the Remove...agree that it's frustrating. The Z-Wave SDK is not under Hubitat control, and they can only expose capabilities provided by the SDK, and can't "make things work" perfectly. Make sure the dimmer is powered down, pull the air gap if it has one while you're trying Remove.


hum, ok. im remote, ill have to go there and pull the airgap.
what if I just remove that dimmer from any scene. will I still have issues?
between you and me, I dont really care it's there, as long as things work :slight_smile:

Yes, you can still have issues with your Z-Wave mesh if you have ghosts, so removing any ghosts is still something you want to do.


Can you just Disable the device to prevent issues on your Z-Wave mesh?

No, first because there is no actual Hubitat device to disable (instead there is a "Discover" button that would create one, not that it would be useful if the corresponding node is no longer on the network) and because the disable feature just stops Hubitat driver code from running (it originated as a troubleshooting feature, say if you had a hub slowdown and suspected a bad custom driver) but has no effect on the underlying network/protocol.


Hence the name...Ghosts. :slight_smile:

1 Like

@bertabcd1234 , for the dimmer, it's my fault. I thought it was not paired and I tried re-pairing it. didn't worked so I factory reset the dimmer and paired it. so I now have the "old" one as a ghost. but the device is still there. so could I exclude the "new" dimmer and hit Discover on the "old/ghost" dimmer?

ok and I tried shutdown the hub. once the led is red, unplug power.
then unplug power on door lock and airgap the dimmer.
then more the hub somewhere else, more centered in the house (I also did the external antenna mod which helps a lot for signal.)
powered on the hub
now I have the remove button on every ghost devices, but after 5-6 attempt on each, nothing.

ill check the USB thing procedure. but I might just factory default everything and start from scratch. sigh

You cannot, unfortunately. Every time you reset a Z-Wave device, the radio on the device creates a new ID, thus the hub sees it as a brand new device, after each reset.

Just give it time, the hub's radio will eventually mark it as failed and then the remove button on Z-Wave Details page will work.

Thanks Bobby, IT and patience are 2 things that dont work together... lol
but ill try... :slight_smile:


I know, that's why you see many folks jumping on the Z Stick. It gets the job done instantly. But I can tell you that in 10 years of working with Z-Wave, I didn't have to use a Z Stick to remove a ghost, once. That doesn't mean I don't have one ready to go :slight_smile:


"That doesn't mean I don't have one ready to go"
just bought one on amazon... lol

1 Like