Zwave ghost will not delete

I have a ghost zwave device. Not sure what device caused it. But its there and i have pressed the repair, but of course it did not work, the remove option came up, pressed it and it will not remove it.

What is the point of having the option if it does not work.

How do i delete it?

You need to remove power from the device you're trying to clear the ghost for. If the device is power and the hub can still ping it it won't be able to remove it.

If it's a switch\dimmer and has an air gap you can pull the air cap that will work on GE, Jasco, and Ultra Pro switches.

What is the device and can you post a picture of the Z-Wave details page showing it.

1 Like

Thats the issue. I have no clue what device it is. And hubitat cant ping it. When i try repair the pin fails.

I have tried to figure out what device it is but unable to. Why cant the remove just delete the ghost device.

Okay so we know it's a switch.

Ghosts are almost always followed closely by the parent if you will of the ghost. So you have a switch that created that ghost.

So I would remove power from the next switch in your Z-Wave details list, and then try to remove again. You may have to hit the remove button more than once.

Ghosts are created when a device doesn't pair properly. If you then go on to complete a successful pairing of the device after that, the ghost entry is usually followed by the entry for the device that created it in the Z-Wave details page.

1 Like

From that error message, it could also be Z-Wave database corruption. I don't think there is any guranteed fix for this (besides starting over, so you get the new standard database format instead of the old proprietary one that is apparently more subject to this kind of thing). A secondary controller, while not normally necessary (but sometimes helpful), might work.

Another thing that might help is time, as in waiting a day or two or few to see what happens then. Not as fun, but often helpful with Z-Wave. :smiley:

1 Like

The "...failure node is no longer in failed node list" I assume.

Why do you believe he has an old proprietary database format? Thanks.

Time is of the essence and patience is the key.

Check these threads too:


Radio flipping between failed and not failed carries a slight chance of corrupted Z-Wave, however, more often than not, giving the radio time to catch up solves the problem in 90% of cases.


One more thought. Running repair only prolongs the not failed state. You want to press Refresh, then when the Remove button shows, select it to safely remove the ghost.

1 Like

The reason is not necessarily the Hubitat's fault - the Z-Wave spec has some strict requirements that have to be followed. Also the process is dictated by the radio & firmware provided by SiLabs.

If you use a secondary controller like a UZB-7 you can see similar issues with their Z-Wave PC Controller Sw. The process is first testing to see if a device has failed (not responding) and if so then being allowed to remove it. The PCS has the advantage of some baked in "tricks" and/or "rule bending" that HE is not privy to..

It's a big pain sometimes...


Can you post your full z-wave details page? Also the other issue is that the device that created the ghost needs to be completely powered down (not just air gapped) so it is not pingable. If it's pingable hubitat will not remove it.

It may be the washer switch. Pull power from that switch. Shut down from settings menu, pull power at wall (not hub) for 5 mins and power back up. Attempt removal. On your removal click it may take up to a minute to prompt for force remove.

Ok I have pulled the power from washer and dryer plugs, then shutdown hub, unpluged from wall for 8 mins, pluged hub back in, went to z-wave details, refresh or repair / so I repaired, it failed, then shows option to remove, pressed remove and get this message even after a few mins "Failed node 49 remove status: 0 SDK failure node is no longer in failed node list"

I had an issue with 3 ghosts created after updating the firmware in my Aeotec repeaters. Waiting a few days and trying the “refresh” then “remove” worked like a charm. Patience WAS the solution (in my case).


ya but this has been going on for a week now.

Also i have shut power off to whole house, hub and wifi on battery backup, all zwave devices with batteries removed, shut hub down, unpluged, waited 5 mins, pluged hub back in and then tried to remove ghost device still getting

"Failed node 49 remove status: 0 SDK failure node is no longer in failed node list"

How? There is no zwave device that has power now.

At a total loss.

Retuning house back to normal and will wait for a dev to hopefully help

The z-wave radio's database is likely corrupted as first suggested by @bertabcd1234. AFAIK, there's nothing a Hubitat dev can do to fix this.


Bummer...I have not seen this happen before. :frowning:

I think at this point you will need to use a z-wave stick to remove it.