Ghost Devices?

Thanks again for everyone's help.

@danabw , yes I'm sure the power has been removed from the device. I have the motion sensor in a box :smiley:

@bobbyD it looks like I did get a busy message for one of the ghost devices i wanted to removed (I have 3 - 2A, 2B, and 2C). Screenshot below:

Please disregard the Server Room and VMS log :slight_smile:

Am I don't something wrong with the removal process?

Thank you again everyone!


FYI - If you click on the “sys:1” text, it will filter out everything else. :slight_smile:

As you see on the Logs, 2 of them are no longer in the failed table, so those cannot be removed by the hub. And likely because they are unresponsive, they prevent the third from being removed.

Thanks @bobbyD so does that mean I need a z stick or something similar to get rid of them as recommended by @rlithgow1 ?

Give it time until the radio moves them back to failed, or use a non-certified Z-Wave stick to forcefully remove them. The beauty of beign certified doesn't always pays off, unfortunately, especially when requirements get in the way of getting things done faster.

Thanks again @bobbyD. Do you know how long it normally takes for the radio to reset? This is my first (three) ghost devices and I just read how much havoc ghost devices can do to a network :sweat_smile:. Appreciate your help.

I was in a similar boat a while back, couldn't remove 2 ghosts. What worked for me was taking my hubitat to a friends house (miles away) and easily removed them there.

1 Like

You can also try wrapping your hub in tin foil (seriously) to foil (see what I did there?) it's attempts to connect to local devices. :slight_smile:

Thank you @JoeJ and @danabw. Would the foil suggestion still work if the device isn’t transmitting anymore? I have it in a bit without the battery installed and it’s not plugged in. I’m just curious but I’ll give anything a try :sweat_smile:.

I also ordered a zooz z stick (zst 10) just in case I would need to try to forcibly remove it as recommended by @bobbyD


Foil can work as it blocks the hub from pinging the device (or any device) and then it will come up as failed and the hub can remove it. I've never done it that way, but I've seen others (can't remember who, but maybe @thebearmay, or @Sebastien, or ??) recommend it.

Guilty as charged...:sunglasses:

1 Like

Yup, I’ve tried putting my hub in foil and then in a sauce pan to try to remove a device. I even tried taking it out for a drive! That was several platform and Z-Wave firmware versions ago…

1 Like

Hah! W/@thebearmay's admission of guilt I'm two-for-two!

Best day ever...going to allow myself a root beer float for dessert tonight to celebrate... :wink:


Oh yum!


Haha sounds like I got some options for these stubborn ghosts. I’ll try the foil before I fire up the Z stick then. I’ll report back with how it goes.

Enjoy your root beer float @danabw!

1 Like

ahh, a good ol' faraday cage

1 Like

Hi everyone, a big thank you for everyone's help. Reporting back on my adventures with these ghosts, and I am happy to say that I was able to remove the ghost today. I clicked the refresh button and then the remove button as soon as the screen reloaded the Z-Wave details, and they magically disappeared. Maybe it's a timing thing like @bobbyD suggested but I didn't have to roll out the tin foil or use a Z Stick, though my sister was rolling out the foil when I to hit the refresh button :smiley:.

Thank you everyone for your tips. I hope I never have ghosts pop up again, but if I do get them again, I'll be using the recommendations discussed on this topic.


When pairing a z-wave device, if it fails, power down the device, look for and remove ghost, reset the device then attempt pairing again.

1 Like

Thanks for the pointers. I’ll make sure to have a active log running and will check the z wave details after every device add.

1 Like