[RELEASE] Package Explorer - For use with Hubitat Package Manager

Introducing 'Package Explorer'
Conveniently explore the apps and drivers available within the Hubitat Package Manager.

Special thanks to @dman2306 for his amazing work on Hubitat Package Manager.
All code by dman2306 used with permission. Thank you.

  • See "What's New" for the past 7 days.
  • Search by Category, Tag, Developer and/or Keyword!
  • Create a Master List of all packages
  • Keyword search includes keyword, but not keyword
  • Keyword search based on name or description fields
  • Sort by app name or developer

Reminder, this is just a simple way to see what's available with full details on each package. Hubitat Package Manager is required to install any package.

Apps can be found on my GitHub or by using the Hubitat Package Manager.
(HPM is highly recommended)

When reporting problems...

  • Be sure you are on the latest version. I won't troubleshoot an older version.
  • Turn on debug and screenshot the issue happening in the log. One line or just the error doesn't cut it. I need a log.
  • Post the screenshot of the log with an explanation of the problem.



Some Screenshots...

Search by Category:

Search by Keyword:


Sorry to be a bit pedantic here but shouldn't this post be titled Package Explorer?
This is the only app I can find in your repository and this would then tie up with the post Title.

Just an observation but keep up the good work. :+1:

Yup, brain isn't working too good today. :roll_eyes:


Thanks. It was kind of obvious but thought it worth a mention.

I see the Inovelli Z-Wave association Tool listed in the Package Explorer, but I do not see it as available in the Package Manager. It this my error or an oversight? Also, has this tool been adapted to work for more than just Inovelli devices?

In Hubitat Package Manager...
Be sure to go into the 'Package Manager Settings' from the Main Menu. Then make sure all the Repo's are selected.

I ran into an error message. This happened in the search part after I had searched for Google. I had previously also renamed the Child App.

The Next button does nothing, If I back out and try any other search, it will not work and the error will show immediately.

This is what is posted in the Logs:

Also, clicking the logs link in the error only takes you to the current logs for all devices, not specifically for this one nor the past ones.

I uninstalled the app and re-installed but same error. Then it seems to dissapear from the Apps section as I cannot see it there anymore as well as category search was empty and did not contain a list of categories.
The app also dissapears from the App list.

I have to admit that I updated to Firmware this morning. Don´t know if that is the culprit ?

New version on GitHub...

1.0.1 - 05/02/20 - Minor changes

New version on GitHub...

1.0.2 - 05/07/20 - Added 'Developer Options' Search, cosmetic changes

This app seems to be suffering from the same issue that webCoRE was with hotfix fixed it for webCoRE but it is still present for HPM and HPE.

Apparently whatever the change is results in being unable to reference a LazyMap in code. The fix is to simply use def and let the type inference occur.


New version on GitHub...

1.0.4 - 05/20/20 - Fix for HE update

1 Like

New version on GitHub...

Can now see "What's New" for the last 7 days!


New version on GitHub...

1.0.6 - 06/03/20 - Added a Master List Option

1 Like

Great addition to the package manager app @bptworld

1 Like

Trying this for the first time over the last couple days. Everything works great except for Categories. When I select that item the app just spins in the upper right hand corner and nothing happens. The app freezes. No errors in the logs. I have to back out of the app to get anything to happen again.. I have reloaded and repaired numerous times. Any suggestions?

In the log below, the categories button was pressed at 12:34. Nothing happened on the screen other than the blue wait circle in the upper right-hand corner. That lasted 25 minutes before I hit "App List".


Brian, might you have any suggestions on the above?


All categories used with HPM have changed. This app needs to be updated.

Added to the list


Love this and love the package installer!! So grateful I’m going to donate simply because it’s made setting up our smart home so much easier! LOVE IT LOVE IT LOVE IT!!

1 Like

Download the Hubitat app