[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

Same problem with my setup, noticed it yesterday too.

A workaround for HPM is to close the dropdown menu and the open it again. Driver/app name should appear on the second try.


Thanks, you are right, workaround worked for me too. Never tried to close and open the dropdown menu again

1 Like

Hubitat was able to replicate and will release a fix for this. It exists in only, as far as I can tell. I rolled back to .134 and didn't see it.

v2.3.2.136 fixes the display issue.


Hubitat V
Can ping from router
Cannot ping from Hubitat ?
Did reach MaterRepo ok

Still working on the issue . May just wait for fixe to 135 then see if I can update Hubitat
May not be able then either? Hubitat check for update just spins and spins

I had changed the HE from DHCP to Static. Used the DHCP address for Static to match CSS coding I put into HE.
Turns out that goofed up DNS?
I could ping from Router but not from HE.
Reverted back to DHCP. When checking network settings all seemed well.
But the HE then could not Ping
When checking my router, the router said the HE was still Static! but was set to DHCP in HE.
Removed power from HE, restarted Router, Powered on HE then network settings set HE to DHCP again, Aha finally got a check mark in HE network settings that DHCP was set.
Power cycled HE one more time, Router now said HE was DHCP.
HPM is on 1.8.6 and is asking for an update to 1.8.7 and is working ok! with HE set to DHCP.
Will in a few days try to get HE to a Static IP.
Got me HE Network test still can not ping but HPM is working ok.

The problem I was having post 200

Removed Rachio from HE to use on a different HE controller.
and HPM now gives errors.

Unable to update or repair HPM
What are the steps to repair?
Should I remove HPM?
HPM says update available.

If hub is running 2.3.2, try using multiple DNS servers in format below. One of them got to work...,,,,


Yes, works sorry didn't mention that.

For some reason seems to be unreachable from the hub I have noticed this in a couple of threads recently. If I try to ping it also fails from the hub. I have seen it reported elsewhere as well. Not sure why?

Thanks for this work around. I needed it today.

@csteele - Has HE staff indicated that there a fix coming for this anytime soon? I am not seeing v2.3.2.136 available just yet.

Null In Dropdown

1 Like



Interesting - Not showing when I log in to the hub

I had to force an update check to see it.

Never the less, it has been released and my tests show it as fixed.

Screen Shot 2022-07-12 at 5.55.26 AM

Screen Shot 2022-07-12 at 5.55.02 AM


The announcement gets sent out using a staggered approach - everyone will not get the announcement at the same time. (Thus the reason I have a check for it in Hub Information.)


Oh I get that. But I also got the impression from the wink emoji that it was felt that I should have known the update was available when it had not been broadcast to me yet......

I am subscribed to the Hub Release forums. But, I had not gotten that notification either.

12 posts were split to a new topic: Missing Community Notifications

Knowing Bryan, I think it's more likely it was intended to be an "Ask and ye shall receive!" wink. He's not a snarky guy. Sometimes we hit the limits of emoticons... :slight_smile:


I installed v1.8.7 (current latest release that I found), but it kept giving me an error that my user name and password were incorrect from the Hub Security credentials (problem existed whether I checked Hub Security, in this app, or not). I had confirmed my Hub Security user name and password as directed at Hub Login Security - Hubitat Documentation

I had to reinstall the HPM app, but using v.1.8.3 for this app to work.

Sorry am new to HE. What am I doing wrong?

EDIT: I think I may have discovered the issue (?). I was using a possible forked update on Github that was not the most current official update. As far as I can tell (now), v1.8.3 is the most current working update. Right?

No, v1.8.7 is the new fork, which most people would recommended now (the original developer has left the platform, and 1.8.3 was the last release by him). Do you see any errors in Logs when this problem happens? Do you have hub security enabled? If so, it's possible something went wrong between now and then and hasn't been discovered yet. I suspect many users do not have it enabled. Otherwise, the setting in HPM needs to match whatever is configured in the hub (including being disabled if it is disabled).


If you simply Repair HPM:

Screen Shot 2022-07-17 at 12.19.36 PM

You'll transfer yourself to the correct fork.

There's a chance that a repair of itself can interfere with itself. It will hang and you'd think it didn't work... it did. The new code is found and installed and it's only the display of "succeeded" that gets lost. Just use the App menu on the left and go back into HPM. You'll quickly see that you're on v1.8.7 because of the upper right corner:

Screen Shot 2022-07-17 at 12.23.49 PM

I just did this entire recipe... I have a hub that does not have/use HPM and I installed it from the original github repo. v1.8.3. I did the match ups, I did an update pass, and so on. Then I did a Repair of HPM and am on v1.8.7 now. :slight_smile: Easy Peasy Lemon Squeezy


Done and fixed. Thank you both for your help.