[RECURRING] OAuth Connections Down / Performance Issues

There are intermittent recurring issues with the Hubitat OAuth authorization flow.

After each 'remediation' of the issue, the authorization flow will often continue to work fine for several weeks before the issue reoccurs (though sometimes just a few days or even hours).

When the issue occurs, you can usually reproduce it on any OAuth connected service like Alexa, Google Home, SharpTools, or IFTTT by proceeding through the OAuth authorization flow. Most commonly, there will be some variation of either the authorization screen itself taking an extended time to load / timing out, or once the authorization is approved the authorization/sync process itself will timeout or fail.

Usually just waiting a few minutes and then trying again will get you through the authorization process, but sometimes you might have to make multiple attempts before it succeeds.

Original Message for Posterity

It looks like something is going on with OAuth connections to Hubitat. I received a few messages about not being able to (re)authorize hubs and when I tested reauthorizing IFTTT, Alexa, and Google Home I'm seeing the issues with those connections as well.

FYI @support_team

1 Like

Assume you've checked to see if your hub has a cloud connection

All of my hubs are showing up at findmyhub.hubitat.com, and I am getting no errors on the hubs, so everything seems to be fine. Plus Josh is having the same issue, so it appears that something else is going on here. Thanks.

May be an AWS outage as everything here appears to be working.

I am not that familiar with this - @josh is much better versed than I am - this is the connection that is being used to connect Sharptools to the hub and it stopped authenticating sometime yesterday or before.

Out of curiosity - Did you generate this graph from the hub? Is it something I can check on my end? Thanks for replying.

Pulled that one from Down Detector. Can also look at what Amazon thinks: https://health.aws.amazon.com/health/status

I’ve been having issues trying to connect my Google Home to my Hubitat Hub. Hopefully this can be resolved soon. I have been trying to connect but always get the message β€œThe parameter "state" must be set in the query string.”

I think that happens if you have NO valid devices selected in the HE app to share to google. Try selecting at least one simple device like a light switch or outlet/plug and then try again.

The issue Josh is reporting is the same thing I am seeing. It is not that you can't get to the Hubitat site, it fails to authorize a connection, via oAuth or whatever means. My C-8 disappeared completely from SharpTools as a connection, and when I went thru the process to add it back, it failed each time. Josh then tested and saw that he couldn't re-authorize several services on his device.


I can't get passed the authorization screen to allow any device through.

1 Like

Ok that might be the OAuth issue then.
I usually app the app on the HE side first, select my devices, then pair with Alexa / Google but I think it is supposed to work the other way around as well.

If you already have the Google Home HE app installed, make sure you have devices selected in there before trying to pair Google to the HE.

It's pretty straightforward to test. Try to perform a fresh Hubitat account authorization of any app that uses OAuth and it will error out (IFTTT, Alexa, Google Home, SharpTools, etc.).

You can login to Hubitat's authorization server and see your list of Hubs, but once you select a hub, the authorization process will error out.



Oddly, the Hubitat OAuth servers are returning an error indicating:

"Hub is not responding, please verify it is running and connected to the Internet"

But the hubs are connected to the internet, don't have any connectivity issues indicated on the hubs themselves, and cloud endpoints continue to work as expected. For example, you can access Hubitat Dashboards using Cloud Endpoints or the Hubitat Maker API using Cloud Endpoints.

So it seems to be something limited specifically to the OAuth process rather than the Hubitat Cloud Relay or broader cloud connectivity from the hub itself.

I am getting further this morning. I now get the list of devices which I was not getting before, and then the colored spinner, and then the Oops message.

This issue should now be resolved. Please let us know if you experience any more issues.

1 Like

And as if by magic everything is back on my dashboards. Thanks!


Thanks for the update.

Just a heads up that there still seems to be some intermittent performance issues with the HE OAuth servers, but I'm not sure if that's related to things spinning back up and might calm down after a bit.

Sometimes when I attempt to start the OAuth process (from any service), it takes a looong time for the login / hub selection screen to come up in the browser... and similarly, after selecting the desired devices and confirming, the OAuth code β†’ token process sometimes times out.



I'm still having issues connecting to Google home. I can get past the authorization screen but I can't add any devices.

Can you please check the logs for additional details?

1 Like

@bobbyD I am having issues again this morning with Sharptools. I tried to authorize and it failed - tried several times.

1 Like