Quick Z-Wave fix

This isn't going to be everyone's fix, but I thought I would post this in case it helps someone else. I've never encountered this before, but it fixed the issue immediately.

I don't normally shut down my hub. It's on a UPS and runs constantly, except for an occasional reboot for various reasons unrelated to Z-Wave. As you may or may not be aware of, the Z-Wave and Zigbee radios do not shut off when you simply reboot the hub. So when you shut down for 30 seconds, the radios will power down, and that is it when my strange issue occurred.

After shutting down for 30 seconds, I found that all my Z-Wave devices were responding, except for my Z-Wave Plus door lock. The driver was not talking to the lock at all, since status wouldn't change in the driver from lock to unlock when I clicked the button in the device details and clicking Refresh did nothing to resolve the problem. Of course my next step was a Z-Wave repair, but this didn't fix the issue. I check the lock batteries and they were at 80% charge. This lock NEVER gives me issues, so this was quite a surprise.

What finally fixed the issue was to disable the Z-Wave radio for 10 seconds, and then re-enable it. The devices did not appear in the list after re-enabling the Z-Wave radio and waiting 10 seconds, so I clicked the Refresh button and my list of Z-Wave devices appeared immediately. Went back to the lock driver page and it instantly responded to unlock and lock commands as expected.

Hope this helps someone in need.

15 Likes

@SmartHomePrimer How do you Disable the ZWave radio? The only thing I found was a Reset Zwave and you would have to exclude and re-add every zwave device.

Z-Wave details. Updated my post above with a link to the docs page

1 Like

@SmartHomePrimer
This is the part that would scare the crap out of me.

Reset Z-Wave Radio
Warning! All values will be reset and you will have to exclude and re-add every Z-Wave device.

There's no way I'm going to Exclude and Re-Add all 80+ Z-Wave Devices.

I am sure that @SmartHomePrimer is not talking about resetting the zwave stick.

he is talking about enabling/disabled the Zwave stick
It is in the top right corner on that site

That will NOT delete your devices and you don't have to repair

4 Likes

@dan.t
Ok that would make more since.

I always thought that was just for the Secure Join. If you wanted to enable Secure Join not for the whole Z-Wave network

No I’m not talking about reset. I do you know what that does and I would never click that myself unless support advises it. The item is next to what you’re describing, and it is labeled D in the doc. It is the Z-Wave Status.

1 Like

@SmartHomePrimer Ya ok. I thought that only Enabled and Disabled the Secure Join. Maybe this all you had to do with the lock. I have a Schlage BE469 and have had nothing but issues with it since moving to HE. I replaced some of my Z-Wave Switches with Z-Wave Plus switches and that has made a huge difference. My Lock now works 99% of the time.

That’s a completely separate drop-down menu. It has nothing to do with the Enable/Disable Z-Wave Status drop-down which is to the right of the Secure Join drop-down menu.

1 Like

@SmartHomePrimer
That's awesome. I never knew we could do that.

We can but sorry, you can't. :wink:

2 Likes

Is there a way to access this feature via a RM call?
That would be ideal - as I (and others) have mentioned, just doing a reboot is often not enough. You have to turn off the radio for a certain portion of time. I thought that you had to shutdown the hub to do that.

Not aware of any way to do that in RM

@jtmpush18 @SmartHomePrimer

Here are the curl commands that need to be translated to Rule Machine to disable and enable the z-wave radio. Very similar to the zigbee radio that I posted some time back.

curl -sb cookiefile -d "zwaveStatus=disabled" -X POST http://he_ipaddr:8080/hub/zwave/update 
and 
curl -sb cookiefile -d "zwaveStatus=enabled" -X POST http://he_ipaddr:8080/hub/zwave/update
5 Likes

Sweet! Does that work for the Done buttons too? I’d love the create a rule that presses the Done button of my Lutron integration on hub startup.

The URL will vary, but yeah, it should.

1 Like

I'm sorry but I still missed what you mean by "Refresh button". Where?
The Z-wave Details page doesn't show a Refresh button.

Edit: Oh you meant a browser refresh? Now I got it.

sory im new how would you implment this in RM, im guessing i need virtual button, then where do i dorop this in rm

Can't do this in RM if you have hub login enabled - because you can't send saved cookies through RM.

i dont have login enabled