Questions on z-wave, lots of integrations

I have had hubitat for over a year now and it mostly works well. I didn't follow the steps in the FAQ to build my z-wave network and I'm wondering how to fix it.

I've got 57 z-wave devices that I probably added at all once over a 4 or so hour period, not starting from the hub and working out). Most of my devices are hard-wired, so they are repeaters.

I also have an integration with Konnnected as well as a weather integration which allows me to get current temp / weather conditions.

Most of the time things work ok, but especially with battery powered z-wave devices, they seem to very randomly work. Around those times, I notice that my konnected integration isn't able to turn on / off lights. I am using the z-wave poller to get status of some switches as well. (I'd honestly like to add more). I've tried z-wave repair a few times at night, but it always seems to error out.

I did not have these types of problems with SmartThings, and I've kept updated with Hubitat (version wise), so I believe it is possible to get this working.

Should I just go through and delete all or most of my z-wave devices and start adding them again, using the instructions in the faq or are there some simple troubleshooting steps I could take to maybe resolve this?

I assume I'm going to need to get familiar with logging - any hints here are appreciated as well.


If you are having trouble with an individual device doing a ZWave repair on the device may help, but generally doing a mesh wide repair is just going to clog the system. Generally one of the first questions you'll get asked in a situation like this is that you consider posting a screen shot of your ZWave Details pages. That will let us look for ghosts or partial pairing issues as well as give us an idea of where the weak spots are. Another thing to look at is reducing the number of paired devices using security (particularly S0), and the number of devices doing excessive amounts of power reporting.

1 Like

I wouldn't get that radical quite yet. Most zwave issues come down to mesh issues and most of the time they can be resolved using the tips @thebearmay mentions. If you don't mind posting your zwave details page (see, he said we would ask for it!) let us take a look and see what's going on.

Can you confirm that you did the latest zwave firmware update? It is done separately from hub platform updates so even if you are on the current version of the hub platform you may not be on the most current zwave firmware. There was one released a few months ago and it contained significant improvements. If it is available and still pending install you'll see an "update firmware" button on your zwave details page:


You either have to make so many posts or join the Owners group to post images. Its to prevent spam I guess.

1 Like

0x3B might be a ghost, 0x41 and 0x29 look to be partial pairings, but if the Discover button doesn’t complete the activity it may be best to remove them and re-pair.

Yes I agree, go after the ones with the discover button first. If pressing discover does not finish the pairing you may need to remove it. It may even be a duplicate of another device so just removing may be sufficient. Otherwise if the device is not paired at all after that you will have to exclude or factory reset the device and pair it again.

Also as someone said up above make sure the zwave radio firmware is updated. There is a screenshot showing the button that will be visible if it needs to be updated.

Some of your devices have an impressive number of hops. Does your home have a large footprint that these devices are very far from the hub? The max I ever see is 2 hops on my mesh.

Anyway, once you have gotten rid of the un-discovered devices and verified the firmware is updated, I would let it settle for at least 24 hours and then see what this device table looks like after that.

Also, a full zwave repair on the current zwave firmware should be able to complete, I have done it myself without any issues. On the old firmware it was pretty much impossible. Yours would fail at least on the un-discovered devices no matter what firmware though.

Pressing Discover did not help. I then clicked refresh and that brought up remove - I pressed it (many times) on all 3 that were called out, but they didn't remove. I updated the zwave radio firmware awhile back and the button is not currently visible.

Should I reboot and try remove again or just let it settle? Should I turn off the z-wave poller while I'm letting it settle?

The farthest device from the hub is probably 50-60 feet, going through 2 floors on the way. I don't feel like it is terribly big, but that's all relative I guess

Do you know what the devices are that have the discover button? It is odd they have routes as well, are they working and reporting to the hub?

For the discover to work you may need to put the device into inclusion/pairing mode.
For the remove to work you may need to power off the device, which sometimes helps but sometimes not. Its an issue with the zwave backend from SiLabs.

If the device in question is not paired under another node and working, you could also put the device into exclusion mode and run the exclusion on the hub, that may clear out the partially paired node.

Reduce polling as much as you can. How many non-plus devices do you have that need polling?

I do not know what all of them are. The fan controller has been removed because it died. The notification sensor and binary switch could be anything. Should I go through all of my devices and try to find one with a matching network ID in the device detail tab? I'm guessing they won't be there, but I could do that and report back.

I was just trying to give advice on how to resolve the "Discover" devices.

If you have a USB Z-wave stick, that would by far be the easiest, you can just force delete them with that. There is a guide on the forums on how to do it. Z-Wave Ghost Removal using a UZB-Stick - How To

The Z-Wave poller utility only needs to be used on Z-Wave devices...Z-Wave plus devices (500 and 700 series chipsets) do not need to be polled.

The polling generates extra traffic on the Z-Wave mesh that can be detrimental.

If you are not sure if a device is Z-Wave or Z-Wave plus, you can go to the device details screen...scroll down to the "Advanced" area...below that is "Device Details"...look for "Data" and then "inClusters". If the first Hex octet after "inClusters" is 0x5E, then it is a Z-Wave plus device and doesn't need to be polled.

1 Like

I've got a lot of the old z-wave GE / Jasco switches /dimmers. None of them are zwave plus.

I do not have a usb z-wave stick to help remove ghost devices.

I notice that A LOT of the routes are bouncing from one end of the house to the other, not taking anything even close to what I would consider a direct route.

At this point, should I invest in a usb stick? Delete all devices and start from scratch, doing them in batches of 15-20, or something else?

Typically removing the devices and starting over would not make a huge difference unless there is something different with the non-plus devices. I am not sure how the routing works for non-plus devices. Maybe someone else can give advise there.

For all my plus devices, the routes are constantly being adjusted, not sure if yours will do the same or if they lock on the initial route and stay there. So in theory once all the devices are added they should sort themselves out eventually.

The USB stick is handy to have for the C7 just due to the issues with removing nodes at times. Sometimes if you do a full power down, boot up, give it a minute to settle, then try the removal it will work. Sometimes people can never get it to work and need to use a USB stick. Having 'ghost' nodes has been attributed to some of the issues you are having.

You may want to try and pick one of the non-plus devices that has a crazy route. Exclude / remove it, and then add it back again. Then let it settle and see what the route looks like, better or similar?

Let's look at just a couple of your devices as an illustration:

Screen Shot 2022-11-18 at 9.26.18 AM

The 0x4B device has 120 route changes. But at the same time, RTT and Neighbor count are great. The implication is that the route that is actually in use is not very reliable and the hub is trying alternates. But there's only a very few alternates.. between 2 and 4 routes fit into the space allocated inside end devices. It means you may have tried all four 30 times already. Don't try and fix this yet, but it's probably a good 'canary' and as you fix other things, this may improve.

Don't expect instant gratification from clicking Remove. All of the work is done out on the radio and the hub just waits for a message. The hub doesn't make us wait, it pretends its done and refreshes the screen. IF the radio finds that the device responds in any way, the remove is cancelled.

Compare the RTT and Route Changes on 0x4C and 0x4D. Those are good numbers BUT the speed is 40K (far right column of your screen shots) That might mean the signal strength is causing the device to knock down the speed once. You'd expect Zwave + to run at 100K. You even have a couple running at Zwave's lowest speed: 9.6K

Start with devices where the Route column is blank. Then move to the ones with Discover. Once you solve those, let the mesh settle for a few hours. You should se improvement with each device you cure.

Ok - I went in and clicked remove on 0x3b. Now, if I understand correctly, I should wait for a few hours. Look again and it should be gone.

Should I turn off the poller while I'm waiting?

It doesn't take hours but then again it's not seconds either.

Many of us have gotten a ZWave USB stick and use it via SiLabs' PC Controller... what that does is function at a very low "engineering" level. To remove a device you have to FIRST get it to land in the 'IsFailed' queue. You do that by clicking the Is Failed button and watching the messages scroll by. It makes it pretty clear that the Controller is trying hard to find the device. Sometimes it fails to fail :slight_smile: and one must click Is Failed again, and again. Eventually it will indicate it did fail and then quickly one clicks the Remove button... which again does the entire try-to-find-the-device search. Only if that passes (by getting a fail) will the device be removed.

The Hub causes that entire process to be started and gets no answer til it's done. As should be clear, the process is biased towards NOT removing devices. Any excuse to not Remove is taken. that's why the standard advice is to power down the device that ghosted because it might still be answering.


I let this sit over the weekend after removing (I did NOT disable polling) and it didn't remove the one that I know is gone. The way I see it, I have two options:

  1. Get the usb stick -> I would possibly still have issues with weird routes.
  2. Reset the zwave radio and build the zwave network correctly - following the 20 at a time recommendation.

Which is the better course? I'm not opposed to either, but I'm worried about the route issues.

On the one that is now gone when you look at the details page is there a remove button still showing? I still sometimes find it takes a number of attempts at removing it before it is gone gone.

A zwave stick is handy and cheap, and the software is free, though it does require Windows. Not bad to have in your toolkit though I will say since the zwave firmware upgrade a few months ago I dont think I have used mine.