Patched webCoRE for Hubitat (2018/09/09)

community_app

#726

Ah, thanks for the screen shot! It was the use of the word 'dashboard' that had me confused. Endpoints. I was thinking the dashboards we configure to interact with the hubitat system (as oppose to where we code pistons)!.

I am not using custom endpoints. I am not running webCoRE on either a RPi or in a container simply using the default cloud.hubitat.com for piston management. Have I missed a required step somewhere?

FYI: I have deleted and restored HSM once or twice trying to see if that would resolve this. Obviously it did not.


#727

I'm sorry, I still don't understand. You are contradicting yourself. What do you have entered in the first and second boxes?


#728

They are blank.

Note in this screenshot I toggled the "use custom endpoints" to the on position just to show the fields. That slider is really off. This as it shows in the screenshot, cloud.hubitat.com is the endpoint.


#729

I would like to know if I can just use the device driver from Ecobee Suite from here https://community.hubitat.com/t/ecobee-app-driver-port-from-smartthings/732
that has been ported to Hubitat for certain commands in WebCore or do I need to have the actual Ecobee Suite App installed as well? This Device Driver has the variables that I was using in ST that I would also like to use in HE.


#730

Yeah, you need to only install the main manager app and the two ST handlers. You don't need to install any of the helper apps --- don't know if those would work anyway. Once those three are installed, open the ecobee manger app from the Apps page ... follow directions :smile:

You'll be able to access the functions (setThermostatProgram(), setThermostatMode(), etc.) you're interested in from webCoRE ... works fine for me.


#731

When I try to install the Suite Manager I am getting all kinds of errors and it won't let me save it:

startup failed: Script1.groovy: 549: unable to resolve class physicalgraph.app.exception.UnknownDeviceTypeException @ line 549, column 4. } catch (physicalgraph.app.exception.UnknownDeviceTypeException e) { ^ Script1.groovy: 1104: unable to resolve class physicalgraph.app.exception.UnknownDeviceTypeException @ line 1104, column 6. } catch (physicalgraph.app.exception.UnknownDeviceTypeException e) { ^ Script1.groovy: 1126: unable to resolve class physicalgraph.app.exception.UnknownDeviceTypeException @ line 1126, column 6. } catch (physicalgraph.app.exception.UnknownDeviceTypeException e) { ^ 3 errors on line null


#732

Are you sure you're using the ecobee-suite-manager.groovy source from the link you posted above? Those errors are referencing "physicalgraph", which is the ST version.


#733

Yes, I am using the one from the link. He said that he forked it but I am assuming that he made the changes. I don't see any other one on his github.
https://github.com/mattw01/Ecobee-Suite/tree/hubitat-dev#manual-install

I then click on smartapps/sandood and then take the code from the Suite Manager. Isn't this correct?


#734

Sorry, I think I did have the wrong one. I noticed that one had Mattw01 made changes and the other said Sandood made changes. So I did it again with Mattw01 changes and it worked.


#735

I am getting this error and warning in the logs:

dev:2052018-11-14 02:20:23.578 pm warnNo signature of method: java.util.LinkedHashMap.putAll() is applicable for argument types: (java.lang.Integer) values: [2] Possible solutions: putAll(java.util.Map), putAll(java.util.Map), putAll(java.util.Collection), putAt(java.lang.String, java.lang.Object), putAt(java.lang.Object, java.lang.Object), findAll()

dev:2052018-11-14 02:20:23.117 pm errorjava.lang.NullPointerException: Cannot get property 'debugLevel' on null object on line 2634 (refresh)

dev:2052018-11-14 02:19:40.162 pm warnNo signature of method: java.util.LinkedHashMap.putAll() is applicable for argument types: (java.lang.Integer) values: [2] Possible solutions: putAll(java.util.Map), putAll(java.util.Map), putAll(java.util.Collection), putAt(java.lang.String, java.lang.Object), putAt(java.lang.Object, java.lang.Object), findAll()


#736

Don't have access to Hubitat (or webCoRE or SharpTools or ST or anything-useful :rage:) at the moment, but I recall getting some error/warning messages too ... can't recall if those were the same ones, but the ecobee manager/drivers worked anyway :man_shrugging:

Did you install the drivers?

UPDATE:
I think the messages I got (and still get) are about authentication tokens :thinking: ... gonna check tonight ...


#737

Yes, everything went in ok. Found my ecobee and sensors. This seems to be the only error right now. Has to do with the SetthermostatProgram which I am using in a piston.

dev:2052018-11-14 02:31:40.590 pm errorjava.lang.IllegalArgumentException: Text must not be null or empty on line 1981 (setThermostatProgram)


#738

Yeah, that one takes three arguments, e.g.:

setThermostatProgram('Away', 'indefinite', 2)


#739

Do you mean I have to have it like that in the Webcore Piston? How do I put that in and how do I know what the arguments are?


#740

Maybe not ... the ecobee thermostat driver has defaults for most of its arguments (in its functions), so if you don't specify one, it'll probably be OK.

In my case, I couldn't set the ecobee to Away so I had to use the custom function, setThermostatProgram(), from the pull-down list of available commands:

Then specify the parameters:

If I can, I usually use the general device functions:

But you know this already ...

Probably the quickest way to find what the arguments are is to look in the source code (ecobee-suite-thermostat.groovy) for the functions.


#741

OK, thanks so much for your help. I have the same issue where I have to use the setThermostatProgram to change the mode to 'Sleep'. I will look at the code and see what it says. For the last value...is that an integer value?


#742

Yup, integer for holdHours, when holdType is holdHours:

void setThermostatProgram(String program, holdType, holdHours)


#743

I can't seem to get this to work. Is it just the notification command or the Push command?


#744

Apache is running enough that it serves the index page but the rewrite module doesn't seem to be functioning correctly.

Running "sudo a2enmod rewrite" confirms the module is already enabled and I have restarted services and the OS since then. Any idea what could be wrong?


#745

Turn ok the custom endpoints. In the first box put in the IP address of your HE hub. In the second put in the IP address of dashboard server (where you have the webcore dashboard software installed).