Patched webCoRE for Hubitat (2018/09/09)

community_app

#693

You should be able to just empty out the preference for it to default to cloud.hubitat and either reregister with a code or click the dashboard link.


#695

I tried that and it didn't want to work. Said data was out of date and the current mode/hsm wouldn't show.


#699

I know everything that you are saying. And your question still doesn't make any sense. The webcore app in HE has to point to the dashboard. Not to the Hubitat API. Think of it this way....when you had the WebCore app in HE set up locally, you had it set up using the local IP address of your server running the dashboard, correct? NOT the IP address of your hubitat hub. So, why would you be able to point it towards the Hubitat Cloud and still be able to connect to the dashboard?

Furthermore, you won't be able to edit your pistons remotely unless you open not only the device running the dashboard to a public IP but also your HE hub as well. Because all your pistons are stored on the hub, not on the dashboard server.

I suggest you look at OpenVPN as a better solution for making changes remotely. It's easy to set up and gives you access to everything on your home network, not just your webcore dashboard but also your HE web portal.

Also, I'm not flagging anything you're writing...so please stop flagging me just for the hell of it.


#701

That won't work. The hubitat cloud will not connect to your WebCore Dashboard server. It connects to your Hubitat hub.

How will your be able to get to your webcore dashboard server by using the hubitat cloud? I don't understand how you think a connection will be made.


#703

You shouldn't need to clear, it's been awhile since i wrote it, but the way it worked was the hub url was the default from the api, and the dashboard was dashboard.webcore.com.

Once the custom boolean endpoint is checked you can set either both or none of the settings with blank using the defaults described in the description.

When you register the link is sent off to the dashboard js code where it is cached, so it's a good idea to log out of the dashboard site and reregister or click the dashboard link to send off the new information to the dashboard js code.

Also dashboard.webcore.co locks out other instance urls that aren't from smartthings or hubitat which is why a custom/local dashboard is needed in those cases.


#704

So this should work ?
Configure%20App


#705

Yes that should work. If it's not you can hit f12 in chrome before it loads to see it try and communicate. You'll see links with "load" in it pointing to cloud.hubitat.com. If they're red or badly formatted something is wrong.


#709

So I got it working -- not only did I have to clear my browser cache but also the webCoRE cache and data and a rebuild of it.


#714

This morning it broke again. Looking at the logs I am seeing this..

app:682018-11-11 14:06:24.444:errorDashboard: Authentication failed due to an invalid token null
app:682018-11-11 14:05:41.103:errorDashboard: Authentication failed due to an invalid token null
app:682018-11-11 14:05:21.890:errorDashboard: Authentication failed due to an invalid token null

If I test the webcore endpoint url in the browser I am getting

{"message":"Missing Authentication Token"}

Setting hub to the local url it works.


#715

I pulled the load value and I see there is no auth token being generated.

load?access_token=ea17b00a-a199-4b4a-8672-7c8e58c64738&token=&pin=62dfaf5268511ac73d6842e1da462987&dashboard=0&dev=0&callback=angular.callbacks._3


#716

In the WebCore for ST there were a few more options when using Ecobee thermostat like weatherTemperature. Would we be able to get this in the Hubitat WebCore? It doesn't show in there at the moment?


#717

Depends on the DH not WC if it's a feature you need you could try and port the driver?


#718

That sounds like something I probably can't do. Is there changes that need to be made on the hubitat drivers when they are ported from ST?


#719

The Hubitat drivers weren't ported from ST. The native integration was developed by Hubitat. I've reached out separately to the guy who deloped the DTH that I used on ST for the Ecobee to see if he could assist. Porting the driver was easy. The problem is porting the app, which is necessary for the communication with the Ecobee cloud. The ST smartapp is really big and doesn't port easily to HE.


#720

Sorry been away for a few days.

Other than official apps, I have added this webcore, obviously and some of Cobra's apps. No other apps yet.

What I have done is import a lengthy and detailed piston from my ST deployment that references SHM a lot. It feels like to me that since that time I am having this issue.

That's actually why I had asked for a simple piston that references HSM that I can import. Care to share one?


#721

I don't have one anymore. I have ported all my HSM actions over to Rule Machine rules. The only thing I've kept in webCoRE are those things that are too complicated to implement in RM or are just too tough to work through right now. However, here is one I just threw together. Are you not seeing Set Hubitat Safety Monitor in your available actions if you leave Location as your device?


#722

Correct, no option. See post 685 (I think) I have screen shot there. :frowning:

Thanks for the piston, I figured it was a wild shot in the dark. No dice. It mapped your HSM to SHM.

image


#723

Which apps do you have installed? The default ones for ST or the modified ones for HE? Because I'm willing to bet you have the wrong ones installed.

Are you using the cloud dashboard or a local dashboard?


#724

Dashboard: Intrigued by this question, please educate how that comes into play! However, both. When home, LAN. When away, Cloud. All dashboard development on my side is very beta, so to be honest very little used.

Apps: I am assuming you mean the webCoRE ones when you ask about apps. See post 689, @putnamjwp had me confirm there was Hubitat code on line 3306. I suspect that unfortunately clears up your question. (from the jp0550 branch)

For the record, I LOVE that you are asking questions and trying to help (tone is so hard to follow in text form!). Any other ideas?


#725

How are you using both the cloud and your local endpoint simultaneously? You have to set one or the other in the app in HE.

Untitled

What do you have listed where I have the black boxes? Do you have the cloud link for both or your local IP address for both?

Something is making webCoRE think you're connected to ST. It obviously has to be something you did and not a problem with the code since many other people followed the same set of instructions and it is working correctly. I would suggest you delete what you have in HE and start again following the instructions exactly as they are written. i did, and it works for me.