Not possible to setup/first registration Hubitat C4


Finding difficulty to connect the Hubitat C4 hub registration setup. It finds the hub. but however not possible to connect to it. I purchased C4 when I was in the USA long time ago, and never used.
this is the first time I am trying to connect from Europe region.
Tried all debug options and unplug the power cable etc. Not helpful to resolve this problem.
It shows the Hub detected on the discovery, but unable to connect to it.

Please help


Tagging @support_team

I think the firmware on your hub is completely out of date. The C-4 has not been sold since February 2019 - more than 4 years ago.

It seems possible that cloud setup endpoints your hub is trying to connect to have been changed. Not sure what can be done to fix it because updated hub platforms can only be loaded if the hub is connected to Hubitatโ€™s cloud servers - but Iโ€™ve tagged support for you.

Personally, Iโ€™d just get a C-8 for a substantially better UX.

1 Like

so, there is no support for C4, and the C4 hub is not usable anymore?

If you have a USA version I think that your zwave radio or dongle will be for USA frequencies, so you may not be able to use Zwave.

You could try going to http://HUB.IP:8081 for the diagnostic tool. See if you can update the firmware from there.

Here is the guide on it: Hubitat Diagnostic Tool | Hubitat Documentation but your tool may look a little different since I assume it is an old firmware.

If are serious about setting up a smart home though I would also suggest either a used C7 or a new C8. I think both of those models you can switch the zwave radio to different regions as well. There is a pretty good performance boost once you get to the C7 and up.

1 Like

There is support for C-4 hubs whose owners have kept the platform updated.

The issue here may be that your hub was never setup at the time of purchase 4+ years ago, and therefore it may have a platform version that cannot be updated easily over the internet. Support may still be able help you.

1 Like

Unfortunately, the original discovery process is no longer available, as it has been replaced a few years ago. I am afraid that you may not be able to get started at this point.

1 Like

thank you, I have the radio dongle for Europe, purchased separately. Tried all options, none of them working, I will get C8 later, but want to get my C4 working. I sent detailed captured snapshots to please help

I don't think that support email is in use anymore. @bobbyD who posted above is staff and the main support contact on the forums.

@rmy Can you at least get into the diagnostic tool? The Update firmware button just is not working?

@bobbyD Is it just a matter of the URL it is trying to hit for the update? Just wondering if there could be a way for someone to setup a local DNS override that would redirect the old url to the correct one?

I don't know much else about it, just stabbing in the dark.

1 Like

It finds the hub, but unable to connect to it or update/recovery options.

The problem is internal to the hub and how it reaches out to download the update. The hub is looking for, which now redirects to The functionality that portal had 5 years ago is no longer in use.


nop. tried this already as per documentation. it goes as far as Step 4, and finds the C4 hub. However no controls to let me connect to that.

I want to explore C4 first, before getting C8

Please help me to get this platform updated manually, and provide necessary directions for me to start with. appreciated.

I am not staff. And as staff (@bobbyD) explained to you - your hub is trying to reach a setup endpoint that no longer exists.

If you had used/setup your C-4 hub when you first purchased it, it would have been updated to use the current cloud endpoints. But that is not possible retrospectively.

1 Like

thank you.

@bobbyD: please help. want to check way to get my C-4 hub platform updated manually and usable further ?

We have tried about a year ago with another C-4 hub and weren't successful. I am afraid that there is no way to get started at this point.


@bobbyD: I am about similar situations as

what solutions that you provided through support on this and get it worked?

That post is from 2019 when the old portal was still operational.

1 Like

These days, many EU users purchase their hubs from a reseller based in Poland.


Would a simple webpage at that redirects to, or perhaps a .htaccess RewriteRule fix this issue?

1 Like

@rmy can you try this link? Hubitat User Portal