New inovelli switches stuck on initializing C7 Hub

Hello everyone.

I just got the C7 hub in today and started to try to add my switches.

I was able to add 1 Inovelli Black Series On/Off switch successfully.

Unfortunately, when I try to add the Red Series dimmer switches (LZW31-SN), I can never get them to add. It never asks for the zwave code. I have excluded and included them multiple times, and even unplugged and replugged the hub in.

I do get the code on my Red Series on/off switch (LZW30-SN), but then it times out and never allows me to set a name.

I am also not getting a code supply popup on my LZW31 (Black Series Dimmer switch).

Any help would be greatly appreciated!

1 Like

It sounds like you could be dealing with range issues.. Make sure you start with mains powered devices.. and start with the ones closet to the hub and move outwards..

I have a few questions:
Q: when you unplugged the hub, did you make sure it was safely shut down? Please say yes
Q: are there any errors in the logs? Please share any errors you see. It will help to diagnose.

Try doing an exclude even though it's not added and see if your hub excludes an unknown device.


I tried with the first switch (LZW31-SN) that is right next to the hub. Got stuck on initializing. I then moved to the LZW30 (Black Series on/off switch) which is further than the LZW31-SN and that one paired up just fine.

1st question, Yes. I shut it down first, then removed the power and waited 15-20 seconds and powered it up again.

2nd question, errors just say the following over and over:
Z-Wave Secure Inclusion failed, the device needs to be excluded then included again.

1 Like

given you said that, go through the exclusion process on your hub with that device even though it's not connected. Watch your logs. You'll want to see something along the lines of successfully excluded unknown device. Then try to include it again. Maybe with the hub closer to the device.

1 Like

I did notice that the LZW31-SN and LZW31 are not in the compatible devices list here:

Yet, on Inovelli's youtube videos, they are able to connect it just fine.

I also installed the latest device drivers provided by Inovelli for both switches.

Yes, but please perform the exclusion before you try again. The hub thinks your devices is included elsewhere.

I am having this same problem. I have a LZW31-SN very close (2 feet) to my brand new hub and it is my first attempt to pair any Z-Wave device. I have had a lot of trouble. It is stuck on "Initializing" currently.

Previously today I did manage to get it included one time after several tries but it would not take any commands, despite sending power meter reports, so I excluded it again.

Logs are the same:

sys:12020-07-27 05:23:23.731 pm warnZ-Wave Secure Inclusion failed, the device needs to be excluded then included again.
sys:12020-07-27 05:22:46.235 pm infoZ-Wave Discovery Running

Thank you. I have excluded it multiple times. I will grab a long ethernet cable and try to move the hub closer for pairing.

1 Like

And you saw confirmation in the logs that an unknown device was excluded? If you are seeing that, then there might be another issue going on. Like range.

Maybe worth noting, I have never been offered a pre-checked box for the S2 mode on the LZW31-SN. I believe it should be supported.

I received those check boxes. 3 out of the 4 boxes were prechecked. I never checked the 4th box.

Also, it did say the unknown device was excluded in the logs each time.

hmm ... @bcopeland any input on this? I know that the inovelli can be a bear to pair. (sorry about the poetry)

Same, and no prompt for the leading digits in the Device Specific Key. I thought that was necessary.

This is despite the following:

  • The device is adjacent to the hub
  • The device was freshly factory reset
  • There are zero other z-wave devices and no automations
  • Fresh safe reboot on the hub following a Z-Wave Radio Reset.
  • The device worked on the SmartThings hub which is adjacent to the HE hub.

I'm also having issues with Inovelli switches, but LZW36 (Fan & Light). Pretty much the same as you.

This is probably the closest to the hub I can get..

still failed :frowning:

[sys:1]2020-07-27 04:48:03.644 pm warnZ-Wave Secure Inclusion failed, the device needs to be excluded then included again.

1 Like

If you are using inovelli's drivers you will want to pair without security as their drivers don't support S2 .. When the grants popup appears uncheck everything.


I will try that. Thank you for the reply.

Unfortunately that did not work. I unchecked all the boxes. It then never prompted me to enter the 5 digit DSK.

Stuck on initializing. Same distance as the picture before.

I made sure to exclude it before I tried to include it without any boxes checked.

[sys:1]2020-07-27 04:55:36.528 pm warnZ-Wave Secure Inclusion failed, the device needs to be excluded then included again.

[sys:1]2020-07-27 04:55:11.274 pm infoZ-Wave Discovery Running

[sys:1]2020-07-27 04:55:02.752 pm infoUnknown Z-Wave device excluded.

[sys:1]2020-07-27 04:55:00.464 pm infoZ-Wave Exclude Started for 30 Seconds