New C7 Install in progress

So I just fired up a new C7...

Updated to latest HE firmware (2.2.3.135), updated the Z-wave firmware and then shutdown gracefully and pulled the plug for > 30 secs before restarting. Everything is working in it's baseline state (no devices, no apps etc). For giggles made a backup as well.

This will be a "clean slate" install with only Z-Wave devices (Zooz Dimmers and Switches) at first. Will be adding those in a few hours.

Will report back if anyone is interested to know how it went.

2 Likes

Very interested, in same situation here, my C-7 just sits until things stabilize.

1 Like

Mine is still in the box, little scared to try, especially after last night trying to setup a new pfsense box on a Watchguard XT505 and trashed my whole network, had to start over. 4 hours later I got all my static IP's back, and my AP's working

1 Like

I started with my C7 a couple weeks ago and I have had some minor device issues that I worked through but nothing that was a show stopper.

So to report back it went okay sort of...

I was able to include 8 devices - 2 new GE Enbrighten Switches, 3 Zooz Dimmers and 3 Zooz Switches.

I hit the wall on trying to include an additional Zooz dimmer which was 10 ft away, across the room with no barriers. Inclusion did not recognize it like the others so tried to run an exclude. This did nothing as far as I could tell so used my Z-Stick (holding down the button until yellow light flashes). That seemed to work.. tried including again and got the notice (I'm pairing everything with NO security i.e. unchecked everything). Box went away and the "found device" disappeared. Went into the Z-Wave details page found the failed device but like @danabw could not remove/repair/refresh/discover or anything. Shutdown/pulled power rebooted - finally able to remove device. Tried to include other switches but no go. Shutdown again and pulled power and rebooted but no go. Decided to leave well enough alone for now.

Here are some logs..

Edit: the devices that did pair seem to be working and reporting fine..

Is your Z-Wave Details list free from ghosts?

My Z-wave devices would seem to be OK, but after some varying number of hours they would bog down and then stop responding. Be interesting to see if your system manages to soldier on w/all those busy messages.

It was until I just checked... UI had let me remove it after an earlier power down/reboot.

But now it has returned I now have a ghost just like that as well! Argh!!! :ghost:

I will attempt to remove via UZB-7 or Z-stick except I cannot pair anything at the moment... mmmmmm

Sorry to hear you got a ghost. My stick arrives tomorrow, really hope it works for me. Part of me thinks it would be best to exclude everything when I'm temporarily in a good state w/my Z-wave devices, and reset the radio and start over. Also want to wait and see what HE comes up w/in the next couple of days in terms of updated FW/tools. All my Zwave stuff is controllable via switches so the family can still use all the lights, and some key lights are on Hue integration so those automations and buttons still work, along w/Bond fan stuff. I'm limping along... :slight_smile:

1 Like

Yep that's what I'm thinking too except make your first pairing the stick so when things go south you can use it to hopefully remove the ghosts etc.

Ah, good point. Never used the stick so that is all new to me. What is the best guide to use to set it up and use it. It just pairs to the hub like any Zwave other device, I assume, but what are the steps to exclude a device that you want to remove?

Sorry my earlier post was a bit dated.. I am testing with the UZB-7 on one of my non-C7 hubs now.

You need to obtain the "Z-Wave PC Controller" software (included with the SDK) from SI-Labs.

https://www.silabs.com/products/development-tools/software/z-wave/embedded-sdk

You will probably have to sign up for an account...

Here's a quick (probably too quick) rundown:

  • install sdk
  • plug in UZB-7
  • run the PC Controller Sw and select the "Source" under settings.
  • Go to your HE hub and put it in inclusion mode.
  • On the PC Controller Sw go to network management and click on "Classic Learn mode" or "Learn Mode"/"Smart Start" or "NWI", may have to play around with this.
  • Hub should recognize the device as a generic Z-wave device, this is fine.
  • From there you should be able to see a list of the attached devices in the left hand column which you can test via "Is Failed" then "Remove Failed".
  • To exclude, on HE start the device removal process then on the PC Controller Sw
    go to "Learn Mode"/"NWE". Device should then be removed from the hub.

Here are some older sources to weed through (I don't think you need to update the firmware of the stick or anything - I did not).

3 Likes

Thanks very much for the details and links, sorry for taking your thread off-topic.

No I think it's totally okay - for those of us who have the proper usb controllers and a new C7 - seems like a great idea to do this in advance of adding other devices.

I am not sure I can add mine to the C7 at this point thanks to the ghost - will try tomorrow after the cleanup. If that doesn't work may reset and try again.

1 Like

You know, I probably should add mine to the hub before I start having problems... I think that's a good precautionary tip.

2 Likes

DOH moment...downloaded the SDK, no idea how to install it. Doing this on a Windows laptop...this doesn't require Linux to run, does it? I have a pi3 on my IoT VLAN if that will do. I'm a "lite" linux/Pi user, do most stuff via following cook-book directions as I haven't had a linux laptop up and running in ages and I unfortunately seem to forget everything over time when I don't use it... :slight_smile:

Nope, Windows only.

So what's the install secret, I don't see an "install.exe" or "setup.exe" in any of the SDK folders...

Download the PC Controller sw - the SDK is firmware I think. Sorry about that.

This link:
https://www.silabs.com/products/development-tools/software/z-wave/embedded-sdk

Click PC Controller. Login / sign up for account, then download.

Unzip.

Install:
\ZWavePCController_v5_39\Bin\ZWavePCController\ZWaveControllerSetup.msi

Note, you may also need to install the driver in the bin folder too for the USB dongle to be recognized.

1 Like

Thanks...I've downloaded and extracted both, the PC Controller included an MSI that I ran that installed the PC Controller SW:

I did find these exe's in the SDK folders...

My UZB stick arrives Saturday... :slight_smile:

2 Likes

Download the Hubitat app