Monoprice Motion/Temperature Z-Wave 15271 No motion updates

Monoprice Motion/Temperature Z-Wave 15271 Not working properly with Hubitat C7 Hub.

I just switched from Smart Things Hub V2, where this Zwave device worked no problem without issues.
I excluded it like 20times, Once from Smart things and then after adding to Hubitat, I noticed
the motion never updates. I then excluded from Hubitat and tried to re-add it I estimate about 20 times or so.
Always same result.
The hubitat uses a generic driver called:Generic Z-Wave Motion/Temperature Sensor
This appears to be the problem, I think? Even though I see other people added it without issues on the forums.

The only driver that works for me 100% is: "Generic Z-Wave Motion Sensor" But then I lose the function of the temperature part of the device.

Anyone experience this? Or recommend something to try?

I also tried the Basic Zwave Driver "Super basic Z-Wave parameter tool"
To try to update the zwave settings, but it doesn't seem to work for me, I don't see any settings are being actually updated as far as I can tell, and I believe I'm doing it the right way.
The "state variables" stay the same .
I also tried the Zooz 4-in-1 Sensor driver that kind of worked but was not reliable.
It brought like 7 different parameters that seem to not be necessary/compatible with the Monoprice device

Is there anyway to factory reset this device? May be that would help, may be some setting got mismatched? Any help greatly appreciated.
I don't think the live log shows anything of interest to post here, but if someone thinks it does let me know.

I figured out how to do the factory reset, following this manual:

But it still does not work properly.

Need a proper driver for this device.

Thanks to anyone that can provide any assistance.

If you have a C-7 hub you may want to add it to the list here.

1 Like

Same with me 15271 on a C-7 hub, and no motion updates.
Anyone figure this out?

same for me gets stuck active

bump anybody

It's unfortunate I don't think it will be fixed as it would have been by now, unless Hubitat developers don't know about the problem, did anyone open a ticket with them? I figured posting on the forum would get their attention but seems like not. Since the drivers are pre-installed and no one else is able to view or modify the code, according to this link Can we view driver code for preinstall drivers? And we know that something is wrong with the generic driver: Generic Z-Wave Motion/Temperature Sensor, when compared to the other driver that gets the updates in motion: Generic Z-Wave Motion Sensor. Code has to be changed or someone smart enough/willing to write a custom driver. I guess I'll try to open a ticket: ticket number: 18569


I had been having trouble getting my Monoprice Motion/Temperature Z-Wave 15271 to show motion. My system recognized the devices but wouldn't sense motion. After contacting Monoprice , no help, I read several support posts and figured out the devices wanted the Generic Z wave Motion sensor driver NOT the Generic Z wave Motion and Temperature sensor driver. So far so good.

1 Like

I just checked the generic zwave motion/temperature driver, looking good, finally works, thank you Hubitat support! Merry Christmas. Not sure when it was fixed but I finally gave it a try today. Takes a minute or so to clear motion but working.

Purchased one of these and paired it today; unfortunately on my C-3 running neither the generic Z-Wave motion/temperature sensor driver nor the generic Z-wave motion sensor reports motion. Temp reports ok, but motion attribute never appears in device details. Factory reset, tried again, same bad result. Tried pairing the device on SmartThings and it works as expected.