MOES Zigbee Dimmer Switch

Hi,
I recently purchased the MOES Zigbee Dimmer Switch MOES Zigbee Dimmer Switch but I could not find any driver that works with it (not even the basic ON/OFF switching).

Did anyone work with this device already? Is there any custom driver that I can use to make it work?

Even though I am totally new to HE and Zigbee, I tried to see the event that is sent by the device to HE when I press the button to switch it ON or OFF. What I received was the following:

SWITCH ON:
catchall: 0104 EF00 01 01 0040 00 808F 01 00 0000 01 01 00010101000101
catchall: 0104 EF00 01 01 0040 00 808F 01 00 0000 01 01 0002020200040000000A

SWITCH OFF:
catchall: 0104 EF00 01 01 0040 00 808F 01 00 0000 01 01 00010101000100

I tried to create a custom driver to send the standard switch on/off commands to the device but it did not work:
ON:
"he cmd 0x${device.deviceNetworkId} 0x${device.endpointId} 0x0006 0x1 {}"

OFF:
"he cmd 0x${device.deviceNetworkId} 0x${device.endpointId} 0x0006 0x0 {}"

Any suggestions on how to resolve this would be appreciated!

Regards,

Christos

Not helping with your problem, but always check here (List of Compatible Devices - Hubitat Documentation) for compatible devices know to work. Sometimes similar products may work as well, but there is no guarantee

The Philips Hue dimmer switch works nicely as one example

Thanks for the tip. I will keep that in mind for the future.
I already integrated successfully their Zigbee 3-gang light switch and I though that the dimmer switch wouldn't be much more difficult.

1 Like

What fingerprint does the device produce?

This is what I get at the device:
image
I noticed that the device is sending the EF00 cluster when I press its button to switch it ON or OFF. But I do not know how to format the command that is sent from HE to the device, in the way the device is expecting it

yeah, zha switch cluster is 0006, level cluster is 0008, bastard make ■■■■ up cluster is EF00...
meaning this is nothing close to Zigbee ZHA or 3.0 spec compliant

1 Like

I managed to get it to work (with the help of some of the articles in this forum).
@mike.maxwell you are right that it is not following ZHA specs. It seems that Tuya devices are following a different command structure.
Firstly, they are using the EF00 cluster (which I think identifies that is a Tuya device).
Then, they use the command payload to define additional attributes and attribute values.
For example, the payload of the 'switch on' command is '00010101000101'.

If anyone needs the driver (probably it will need some more refinement), let me know in order to share it.

Regards,

Christos

1 Like

I have same Moes switch. Can you please share driver for it? Thanks

Please note that it is still a BETA version :slightly_smiling_face:

1 Like

I don't own this, but impressed you figured it out

1 Like

Does that mean it's not good to be used as repeater?
Thinking about getting the Tuya/Moes 2-gang switch module from Ali to convert a motion sensor floodlight.

I cannot say for sure. My setup is very basic at the moment.

I am using this switch of MOES which is ZHA compatible (i.e. it works with the generic zigbee drivers) and it should work as a repeater too (and it comes with 20% off and free delivery at the moment).

Their website only has 1-load switch module (not the wall switch), I can only find 2-load switch module, which I need, from sellers at Aliexpress and their price is lower. Would like them to work as repeater to expand the mesh to my detached garage.

You are awesome @CPS ! I had just about given up finding a driver for my newly purchased Tuya dimmer switch when I happened across this thread about 2ms before I was going to close the browser.

I have loaded your driver and I can now turn the dimmer switch on and off! It also correctly displays the dimmer level and the switch status. However, I cannot get the Set Level command to work. It doesn't do anything when I ask it for level 50 and duration 1 for example. Any thoughts as to why that might be? My device is a Makegood dimmer switch with the thumbprint:
deviceTypeId: 135
manufacturer : _TZE200_1agwnems
idAsInt : 1
inClusters : 0000,0004,0005,EF00
endpointId : 01
profileId : 0104
application : 40
outClusters : 0019,000A
initialized : true
model : TS0601
stage : 4

I did not implement the 'duration' parameter yet, therefore try to call the setLevel without any value for the 'duration'

1 Like

That works really well. I don't need the duration anyway as I just want it to change level as fast as possible.

May I ask how your dimmer switch works when turned on but set to a lower dim level than 100%, say 50%. With my one, it will always come on at 100% brightness and then over a few seconds dim down to the set level. That is quite annoying at night when the lights come on a full brightness and then dim down to 5%. Does your one do the same?

I do not have this behaviour with my dimmer.
Does this happen when you switch it on from the device or when you send the 'On' command from HE?

Both. According to the manufacturer, this is expected :slightly_frowning_face:

Hi how did you get there 3 gang to work

I used the 'Generic Zigbee Multi-Endpoint Switch' driver

Download the Hubitat app