Matter Add device stuck on " current stage: SendNOC " then " Pairing failed @ FindOperational with code 50 (Timeout) "

Hi everyone,
upgrading from C-5 to C-8 today was pretty straighforward besides reconfiguring a few things...

I got 2 Kasa Matter KP125M outlets, i found ou that they did not work with my C5 but paired easely with my Google environment, so it pushed me to upgrade to C-8

The problem i get may sound stupid, so sorry if it is...
I add a new device, select Matter, on my google app i select the mater device and get the link code, i type it to start pairing.
The device is discovered and seems to sucsessfully do a bunch of tests.
then it gets stuck on this:

Pairing Matter device, current stage: SendNOC
Looks like you’re having trouble pairing your device. Please check that the device is in pairing mode and is on the same LAN as the hub.

after a while, i get this:

Pairing failed @ FindOperational with code 50 (Timeout)
Looks like you’re having trouble pairing your device. Please check that the device is in pairing mode and is on the same LAN as the hub.

Anyone know what i am doing wrong who could help me ?
Thanks !

Did you ever pair them with the kasa/tapo (I can't remember which app those use, sorry) app and see if there was a firmware update for them?

At least one person said they couldn't get them to reliably pair until the firmware was updated, that's why I ask.

1 Like

Yes the are both connted to the Kasa app and both are up to date.

1 Like

No other ideas on my end. Could always try the tried and true IBM/Microsoft fix - shut down the hub (from the gui), remove power for 30s, power it back up and try again.

1 Like

Was anyone able to connect these Matter smart plugs? Kasa Matter KP125M

@bobbyD , is it possible to get logs on the Matter pairing process ?
Thank you !

I just confirmed last firmware, factory reset it only added it to the Google app, tried to pair it with Hubitat, still no joy

I’ve got them connected to Hubitat, Google Home and Apple Home with no issues. @danabw had issues with them and might be able to help.

1 Like

Mine were Tapo Matter plugs, not Kasa...

My issue is that I was adding on a via Google Home on my Android phone and the add process would hang at the very end. However even though it looked like it didn't complete they were added successfully.


ok, mine were added to Google Home ok, it did hang at the end also though, but going back they appear and work.

i just can't add them to Hubitat... i tried via the Google app using the code, via the Tapo App using the QR Code number, did a factory reset, no joy it always get stuck at :

Pairing Matter device, current stage: SendNOC
Looks like you’re having trouble pairing your device. Please check that the device is in pairing mode and is on the same LAN as the hub.

Thanks for the reminder. So close, yet so far away. It would be nice if TP-Link could just settle on a brand.

What firmware is your C8 and plugs on? For my KASA's, I'm on firmware 1.1.4 Build 231019 Rel. 174214.

You definitely want to go Google Home to Hubitat and add to the manufacture's app last. What Google Home device are you using? You might need to unplug everything and force close the app on your phone.

As a temporary measure, you can get them into Hubitat via a non-matter integration ([RELEASE] TP-LINK TAPO Plug, Switch, Bulb, Hub and Robovac Integration).

I did update my Tapo plugs via their app before adding them to HE...

1 Like

Thank you for the advices

my C8 is on
my KP125M is on 1.1.4 build 231019 Rel. 174214

so i am going to remove it from everywhere, factory reset it and connect it first to Google and try again on Hubitat

no joy
i factory reset it, connected only to Google app, not connected to Tapo, tried connecting to Hubitat, still stuck on Pairing Matter device, current stage: SendNOC.

I suspect that Hubitat may not be fully Matter compatible yet

@bobbyD can you help ?

Same here. I then removed them from Tapo app, and used Alexa to commission the device. I used the pairing code within Alexa to bring them into Hubitat.

I also did the same for my other Matter devices, be sure the firmware is updated before doing anything else.

It is. Many of us have successfully added devices.

Is it possible your router is blocking IPV6 addresses? Your Wifi isn't something like a guest network where it might be blocked from the "normal" side of the router? Your devices are all on a 192.168.0.x network (or whatever number you are using for IP addresses) and not where some are 192.168.0.x and others are 192.168.1.x or a completely different segment period?

Do you have an Alexa or Apple Home to try that pairing code they create instead of Google? A few have complained about Google not always working correctly, and working fine with one of the other commissioning device brands.


all my IOT devices are on the same SSID but my Hub is on lan on another vlan with any * - any * rule between both vlans.
IPv6 Lan <-> WIFI multicast is enabled
since it works just fine from google or the TPLink apps i have doubts it is related

I also tried connecting my hub to WiFi only, still no joy, worse, it does not even find the device to start the pairing process

I would bet $0.05 it is either your network setup (multi-lan/routing/multicast relay) or IPv6 support on your base network or SSID...

Are you SURE all IPv6 traffic is making it unfettered between the two networks?

In my Matter device dev work I HAVE gotten devices and controllers to talk across subnets/VLANs. But many times they didn't without a lot of network tinkering (that really should not have been needed, but was...).

Side note - a LOT of consumers with complex networks are going to have issues with Matter in my experience. It was really designed for the controller and device to be on the same network segment. Not saying it can't work otherwise - they are just network packets in the end after all - but I am sure in my discussions with those closer to the standard than I am that this is not a tested scenario.

1 Like

could be, but as i said, i connected my hub on wifi only, so... no firewall involved on that test, it does not even see the device this way.
I will recheck my wifi and firewall setup.
what is weird is that it does connect to the device and does perform many handshakes as i see the progress on the page, it only gets stuck on the SendNOC step.
This is why i have doubts on a network problem, especially if google and tapo app work instantly, maybe it works differently