Just Placed an Order - Moving from ST

Well, the webcore shutdown by Smartthings was the straw that broke my camel's back (poor camel).

I see the video for switching, but is there a check list or step-by-step instructions? I'm a visual learner and unfortunately, most of the information provided by videos comes in the audio.

8 Likes

Welcome! I'm with you on learning style. Youtube videos, especially when they don't get right to the point, are really frustrating for me too. Sometimes I just want to reach into the video and... well... nevermind.

There's some good information in this thread started by @rlithgow1. There are video links in there but there are also lots of links to helpful reading material. I'd definitely take a look at the zigbee and zwave mesh articles. Even if you have a lot of ST experience they're good reading material. It was written before webcore became part of the native HE offering so I'm not sure he covers it so I also included a link to the announcement and a bunch of supplementary material.

And as always... reach out to the community if you have questions. Chances are someone has seen the issue before and knows how to resolve it. And there are a LOT of ST refugees.

2 Likes

In short you'll need to rebuild your mesh, both Zigbee & Z-wave, before moving devices over. Always build the mesh from the hub location(ideally Hub is centrally located in your living space) starting with repeaters near the hub and build outward. Add battery devices last.
And welcome !

3 Likes

I did the migration a few years ago. I did it in steps and to build a good mesh I'd migrate the closest devices to the hub first. A few a day until I got them all done.

4 Likes

HE? Hubitat Environment? I'm guessing.

I'm a little confused by this. Shouldn't I exclude the device from ST first and then add it to hubitat (moving close to further)?

Right. They (usually) make my blood boil. I want to skim and get to the good stuff which is nearly impossible in a video and forget going back to review something that you passed. Grrrrrr

Depends whether you want to keep things working in SmartThings. If you're trying to keep that up in the meantime, then work in lobes -- starting by the hub, moving out to the perimeter through that lobe, then starting the next lobe. For each device, you need to exclude it (using either hub), then include it from Hubitat.

If keeping ST working in the meantime isn't a goal, then you can also start by the hub and work outward in all directions / a spiral.

In either case, the important thing is to add your key repeaters first, so that other devices see them and have a sensible route available.

Clarification- Yes devices always need to properly excluded before re-pairing to Hubitat. Even better, exclude z-wave devices on both systems. Always start building the mesh, that is join repeaters first, from the HE hub center outward. The repeaters establish a solid mesh, to which your battery devices can connect through.

Providing a list of your devices will give us more info to help you.

Hubitat Elevation

Yes. That is the best philosophy on rebuilding your mesh on the new system. I think @Rxich got a little conflagration is all. (I do that all the time)

Honestly the HE videos are very well done videos and explain in detail how things are done.

1 Like

They are actually. Just a learning style thing for me.

3 Likes

Welcome to the Hubitat community. Seeing the shutdown coming, I decided to move over from SmartThings last November. Looking back, I wish I had done it sooner. Better device support, local execution, great community are some of the reasons. My change-over wasn't all that smooth but I found plenty of help in the forum here and worked through all the issues. I was impressed that I didn't need custom drivers for as many devices as with SmartThings. Most devices worked with the built-in drivers and I only added custom drivers to access some of the more device specific features and reports for a couple devices. Besides Webcore, you'll be surprised at all the devices and integrations that can be added. I added a Ecowitt Wittboy weather station, for example.

I'm happy with the Rule Manager mostly (you'll have to adjust to it a bit) and I was able to eliminate Webcore all together with the Rule Manager and Dashboard tools built in. The Dashboard tools are better than both SmartThings and Webcore, IMO. To get the most out of the Dashboards, it is helpful to brush up on CSS. Here's some of the Dashboards I'm using now (all done with the built in tools):
Main Dashboard for wide displays:


Main Dashboard for Phone displays:

Power Panel:

3 Likes

My 2 cents...I moved everything over from ST to HE during one weekend. Didn't want to deal w/a declining mesh on ST and a growing mesh on HE and the potential associated family "why isn't X working" issues. :slight_smile:

I did Z-wave first, and then Zigbee, IIRC, and as you've noted, working out from the hub.

I did my Z-Wave locks last, as they are generally the pickiest about a strong mesh and will want a beaming repeater (or two) like light switches near them.

Just prepare yourself and family members, if any, for a period where things are in transition.

Tons of helpful people here, let us know if you run into any issues.

5 Likes

My list of devices is long and varied. I have ST devices, Konnect, MyQ, locks from Schlage and KeyWe, Arlo, Zoos, Echo, TP Link, Hue, Home Seer switches/floods, whistle, Feit, Harmony, Feit, switchbot, and enbrighten, and probably a few others that I can't remember.

I think my my first step is to receive the hub and then come up with a plan of action starting with rebuilding the mesh networks.

IRRC? What is that?

If Remember Remember Correctly? :wink:

PEBCAK! :smiley:

Edited...

1 Like

Caution on the locks first. They are often the furthest from the hub so that can cause some grief with the mesh. IMHO

1 Like

Bingo.

And you should know, Z-Wave Schlage locks can be troublesome on HE, for some locks, for some people. I have one original Z-Wave Schlage and it's worked perfectly on both ST and HE, but others have had enough problems w/Schlage Z-Wave locks that HE doesn't officially support them anymore.

So I'd search the forums for your Schlage lock model(s) and see if you may be more or less likely to have issues based on model.

Look through the HE supported devices info...

But don't assume it's not supported if you don't see your device on the list, there are a ton of community developed integrations/drivers. Search the community for that.

And...you're going to want to install Hubitat Package Manager (affectionately known as HPM) soon...community-developed app and driver installer that contains a high percentage of those community developed apps and drivers, and allows easy install & update of them.

1 Like

how was the Zigbee inclusion with HE? were you able to pair all the Zigbee devices that you had? i have several Cree bulbs that were the first ones that i included on my ST and am anticipating a lot of grief from if i decide to move to HT.

Expect grief. In general ZLL bulbs do not play well on a mixed mesh with ZLL and ZHA devices. Even if you can get these to pair my experience was they caused all sorts of zigbee issues. I have all my bulbs on a Hue hub and use the Hue integration with HE. The Cree bulbs will pair to a Hue hub if you still want to use them. Apparently Zigbee 3.0 certified bulbs and Sengled bulbs do not suffer from the mixed ZLL/ZHA issue.

2 Likes

I haven't used Cree for years as they can be "bad" repeaters and cause problems for other Zigbee devices on the mesh. When I moved from ST, every other device I had, Zigbee or Z-Wave, paired for me and worked in my transition from ST to HE.

I'd suggest looking at Innr if you want repeating Zigbee bulbs, and Sengled if you want bulbs that don't repeat (my preference). Maybe this will be a good time to move away from Cree...both Inner and Sengled are very reasonably priced, and work well on HE.

2 Likes

My Schlage's work okay but they do reroute frequently. And I even put a repeater close so it must have to do with how the lock conserves battery I'm guessing.

1 Like

I have a repeater next to each of mine and they don't reroute... (Not that I've seen anyway)

Download the Hubitat app