Issue adding Sonoff S31 Lite Zigbee Smart Plug to C-8 Hub

I have both a C-5 and C-8 hubs. I am trying to add a Sonoff S31 Lite Zigbee Smart Plug to my C-8 Hub. When I start the Zigbee pairing process on the C-8 hub, it finds it and is stuck with:

Found a Zigbee device, initializing...

But it never completes. If I do the same with my C-5 hub, it is found and the pairing process completes.

  1. Could I pair it to my C-5 hub and then transfer it to the C-8 hub?
  2. Is there a way to force pair it?

I just switched my C8 from the new zigbee stack to the standard stack - and it was able to pair no issue

@support_team something is broken in the new stack

In fact - Zigbee on the C-8 with the new stack is not working at all for most of my devices. I'm having to repair to my C-5 to get them to work

Did you try this? I posted in one of your other threads

I have tried this - No success. I have had great success removing the devices and adding them to my C-5 hub

I've just ordered that particular plug, it should arrive tomorrow. Will check it out.

Thank you! If there is anything I can do - submit debug logs etc, let me know

Hi. I've had my C-8 all of one day, new to Hubitat, not home automation... is there a How-To for: switching C8 from the new zigbee stack to the standard stack -

I have numerous Sonoff zigbee devices I need to get working on the C-8 !!!

as well, my Z-Wave Schlage Lock is recognized down to the model, but not controllable

Any updates anyone? None of my Sonoff S31 or Zigbee sensors will complete the inclusion with the Hubitat... The C-8 is a new product and existing Zigbee devices they already claimed work with it, should just work out of the box...

Is there a handler we should install?

@gopher.ny said that he ordered a Sonoff outlet and would have it today for troubleshooting that issue. What Zigbee sensors are you having trouble getting to join? I have Hue, Sylvania, and Iris V2 motion sensors, Sonoff, Linkind, Samsung, and Iris V2 contact sensors, and Samsung and Linkind leak sensors working without any issues on my C-8.

Quick fix that worked for me. Factory reset the S31 & unplug it. Rebuild zigbee network. Plug the s31 in start zigbee pairing mode. I'm not using the C8 for zigbee anymore so wanted to see if I could replicate your problem. Soon as I turned on the C8 it starting pulling Zigbee devices from my C5 fun fun lol. Had to reset the zigbee radio on the C8 to get it to to stop doing that. After that tried to pair a S31 and I would get the same problem you're describing. I rebuilt the c8's Zigbee network and was able to pair the S31's like normal.

OH don't reset your zigbee network on the C8!! that's just something I had to do to get the C8 to stop taking devices off my c5. Hopefully that's not part of the fix for you guys.

Hi. Thanks for the feedback. Still no luck.
I held the power button 5 seconds on the S31, it did the double flash a few times, then back to the pairing flash. Unplugged it. Went to Hubitat Settings, Zigbee Details and clicked Rebuild network, tried Pairing again.

It finds it, then fails to pair successfully. I'll try plugging in a few and pairing to see what might happen!

have you ever had the s31 paired to the C8? I'm hoping you won't have to do a Zigbee radio reset. The only other thing I did other than a rebuild was Disable/Enable Zigbee radio. Maybe you have a backup with the s31 and your other devices working? I'll pair a third one just to see how it goes.

okay I have another that won't finalize. I'll get it working and let you know exactly the steps I took.

Hi. Update: I plugged in 2 new S31 Sonoff after doing the above Reset of them, and Zigbee rebuild, AND with the 2 plugged in a foot apart, and 10 feet from Hubitat C-8 (same distance as when trying to pair just 1), it Worked!!!

So now, I want to pair a Sonoff R5 Scene Controller wireless 6-pushbutton switch9# up-down paddles), and so for, Nothing is seen. the C-8 does NOT "find a new device"...

Just fixed this last outlet by rebuilding the network with the s31 plugged in. Then put the c8 in pairing mode then Factory reset the s31 while C8 is on pairing mode.
the Dev in the logs is the S31 before taking steps to fix it. These sonoff outlets like to ghost join the C8 so just keep an eye on the s31 blinking green light if it goes solid before you do anything to join it you know there's going to be a problem.

Thanks for that interesting update!

I just added a 3rd Sonoff S31, that was on my older Sonoff Hub... I could only get it to join sucessfully after Clicking Rebuild Zigbee Network in the Settings. But it has joined too...

Now how do I get the Wireless Scene Controller Button to join? the C-8 is NOT seeing it at all as a new device

What hub was the scene controller paired to. I'll see if I still have one laying around here. I'm going to have three large zigbee networks running soon lol. Home assistant, C5 and now the dang problem child C8 again can't stand these new log views only listing dev ID lol :crazy_face: When your messing around with the zigbee devices it's a good idea to keep the zigbee log open so you can see if anything tried to join.

The Sonoff R5 wireless controller is New, out of the box.

Other problem right now is Hubitat is not syncing to Google home. I say to google home to Sync, it says it is, BUT nothing new appears in the Home, from the Hubitat.

I'll admit I was Not expecting such 'growing pains' with this very latest device for 2023, the C-8

Are you sure the r5 is meant to run an anything other than the Sonoff bridge ? I just opened mine up I never used it I think it's meant for the Sonoff bridge or maybe not even the sonoff bridge. I was going to use it through Home assistant never got around to it.