Is your Hubitat automation using Picos and Caséta actuators too slow?

Like perhaps many of you with Lutron integrations you really get hooked on what we can do with Picos in Hubitat.
You have also likely noticed that taking pico events into an HE automation and then commanding your Caséta dimmers and switches probably harkens bad memories of cloud execution speeds on a bad day, meaning it's not the fastest thing on the planet...
So you have probably joined the pico and the Caséta device in the Lutron app and suffered the indignities of their command mappings or just accepted the 1 or 2 second delays right?

This issue is present under the following situations:
pico on pro bridge #1 -> HE automation -> actuator on pro bridge #1
pico on pro bridge #1 -> HE automation -> actuator on pro bridge #2
pico on pro bridge #1 -> HE automation -> actuator on RA2 main repeater #1
pico on RA2 main repeater #1 -> HE automation -> actuator on pro bridge #1

It's not present under this situation:
pico on RA2 main repeater #1 -> HE automation -> actuator on RA2 main repeater #2

However that's a very expensive fix since none of your Caséta actuators will work on RA2...

The reason it works between 2 RA2 main repeaters is when the second one is added to the network, it selects a different frequency than the first one, so repeater #1 doesn't see the commands from repeater #2 thus avoiding thinking it's interferrence...

I don't know why pico on pro bridge #1 -> HE automation -> actuator on pro bridge #1 doesnt work, but suspect this may be intentional, can't say for sure.

Anyway, there is a way to make this work without chucking all your Caséta devices if you really want to:

  1. get an RA2 main repeater (I picked one up off of ebay for $160)
  2. take your essentials online training (its free, essentials is the windows software required to program the RA2 repeater)
  3. Change the frequency of the repeater (more below)
  4. add the picos to RA2 and change their frequency
  5. add another instance of our Lutron integration for this repeater, and away you go.

When that's been done running a Hubitat automation using a pico from the repeater and actuators on the pro bridge is as fast (practically speaking) as the direct pairing, and you gain all the flexibility of the pico mappings in Hubitat.

Essentials training:
Log into www.lutron.com/lcionline. Select Web-Based Courses from the homepage. This will bring you to a list of all available courses, then select RadioRA 2 Level 1.

Changing Main Repeater frequency:

  1. On the design screen click the room name on the left that contains the main repeater.
  2. Press Alt+F6 on the keyboard to enable advanced settings for the main repeater.
  3. Right click on the main repeater icon.
  4. Click Advanced Settings.
  5. Choose a frequency for the Main Repeater other than 433.6 MHz (0x1A), I used 433.0 MHz (0x14).

Please note that one-way transmitting devices, such as Pico remote controls and Radio Powr Savr sensors, will require their frequencies to be changed.
Instructions on how to do this can be found in the left-side pane when in activation mode in Ra2 and selecting the device (Pico/sensor) that you want to activate.

If there are 2-way RF devices in the RadioRA 2 system, they will need to be defaulted and reactivated. This can be done by doing the following:

  1. Default the Main Repeater (triple-tap, hold, triple-tap). The default procedure on the Main Repeater will default all Ra2 devices that hear the Main Repeater at the time.
  2. Go into the "activate" tab in the RadioRA 2 software and click "Show advanced options…".
  3. Click "Reactivate All Devices". The system should go through and you should see the "Status" column fill up with good responses.
7 Likes

@mike.maxwell - So, I picked up a used RadioRA2 Main Repeater on ebay ~$120 and took the online training class. I was able to get the RadioRA2 12.9 software upgraded to "Essentials" and have been able to activate a pico remote and integrate it with Hubitat successfully. The problem I am having is that I cannot seem to get the Advanced Settings feature enabled for the main repeater by typing Alt-F6. I am curious if you're using Essentials or Inclusive? I am wondering if this only works with a fully unlocked Inclusive version of the software?

I'm definatly using essentials, though I don't think it's version 12.9, I'll check and let you know after I get through the morning coffee...

its fidgety, the room containing the main repeater must be selected (not highlighted) while altF6 is pressed, meaning leave the mouse hovered over it, i'm sure they could have made this more mysterious, but this was a pretty good start...

1 Like

Thanks Mike. I have determined that the problem is apparently with my particular desktop PC. I pulled out my laptop and was able to enable the Advanced Settings. Not sure why my desktop PC refuses to work correctly. Perhaps some other piece of software is trapping the Alt-F6 key sequence... :thinking:

UPDATE: For anyone else who may come to this thread searching for why Alt+F6 does not work... I discovered that the GeForce Experience software was trapping the Alt+F6 key sequence before it could get to the RadioRA2 software. Simply go into GeForce Experience, click settings, and then disable In Game Overlay. This will allow the Alt+F6 keystroke to get to the RadioRA2 software.

3 Likes

Thanks for this @mike.maxwell

I had not realized you could do this without a connect bridge pro. Is all it really for is cloud access?

Hubitat integrates with RadioRA 2 main repeater or Caseta Pro bridge directly over their Telnet interfaces.

So the Lutron connect bridge is not needed to integrate with Hubitat.

It is needed if you want to use the Lutron connect mobile app, or integrate your RadioRA 2 system with Alexa or HomeKit.

Caseta has a mobile app and can connect to Alexa/HomeKit without the connect bridge.

2 Likes

Yeah makes sense. I guess just through ignorance I had it in my head that it was required to make the magic work..

The various combinations of Lutron systems and devices can be hard to keep straight, no doubt.

They have a ton of detailed info on their website for all of their systems though, if you have the time to wade through it all.

I am experiencing exactly the issue described (delay) using an RA2 Select (UK). Is there a work around for this?

Thanks!

I’m guessing the solution is the same as the solution described above. You will need a separate RA2 main repeater to add all of your pico devices separate from your RA2 select bridge with switches/dimmers.

1 Like

In addition to @timrudd12’s suggestion, the only other way to avoid the slight delay is to simply pair the Pico directly to the Lutron switch/dimmer using the Lutron app.

2 Likes

Completely slipped my mind, but this is also a great solution when you don’t need the flexibility offered by HE.

1 Like

What do you mean here ? You mean just using the Pico as it was intended to control lutron kit natively ? confused

2 Likes

I’ve read this a few times and not sure what I’m missing.

So I buy another ra2 select main hub and when it’s powered up it will automatically run on a different frequency to the original main repeater. Pair the picos with the new repeater and set up a new integration in Hubitat …

Why do you need to do anything else with essentials software and manually changing frequency ?

do you know this for a fact?, if it does run on a different frequency then you are good to go

No, I was just going by your comment “ The reason it works between 2 RA2 main repeaters is when the second one is added to the network, it selects a different frequency than the first one, so repeater #1 doesn't see the commands from repeater #2 thus avoiding thinking it's interferrence...”

Just to be clear... RadioRA 2 Main Repeater is not same as RA2 Select Repeater. I am not sure that with RA2 Select there is an option for 2nd frequency than 1st hub (like the Caseta Pro Hub). With the RadioRA 2 Main there is this option as Mike indicates in post 1.

1 Like

The names of the product lines are similar so it might avoid confusion to call them by the complete names.

RadioRA 2 and RA2 Select.

A RadioRA 2 system can have two main repeaters, so it is designed such that the 2nd main repeater picks a different frequency than the 1st was using when it is brought online. That’s what @mike.maxwell is referring to.

I can’t speak to RA2 select’s features in this area because I’ve never used that system.

@bill.d knows a lot about Lutron, though.

1 Like

I believe that RA2 Select has no ability to change frequency. And note that UK RA2 Select and Picos use a different base frequency than the US.

3 Likes

Download the Hubitat app